Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Mar 31 21:59
    otavio synchronize #2
  • Mar 31 21:59

    otavio on defenv

    updatehub-active-set: Support o… (compare)

  • Mar 31 21:58
    otavio opened #2
  • Mar 31 21:58
    otavio review_requested #2
  • Mar 31 21:57

    otavio on defenv

    updatehub-active-set: Support o… (compare)

  • Mar 31 21:47

    otavio on defenv

    Improve logging for commands T… updatehub-active-set: Support o… (compare)

  • Mar 31 13:15

    otavio on u-boot-update-support

    (compare)

  • Mar 31 13:15

    otavio on u-boot-update-support

    u-boot-updatehub: Export initia… (compare)

  • Mar 30 21:06
    codysch starred UpdateHub/updatehub
  • Mar 30 13:59

    fbertux on master

    conf/layer.conf: Set layer comp… (compare)

  • Mar 30 13:58

    fbertux on master

    conf/layer.conf: Set layer comp… (compare)

  • Mar 30 13:57

    fbertux on master

    conf/layer.conf: Set layer comp… (compare)

  • Mar 30 13:56

    fbertux on master

    conf/layer.conf: Set layer comp… (compare)

  • Mar 30 13:55

    fbertux on master

    conf/layer.conf: Set layer comp… (compare)

  • Mar 30 13:11

    otavio on master

    general: Use json for requests … (compare)

  • Mar 30 13:11
    otavio closed #267
  • Mar 30 12:50
    Jonathas-Conceicao review_requested #267
  • Mar 30 12:50
    Jonathas-Conceicao opened #267
  • Mar 30 12:22

    otavio on master

    updatehub: Run rollback callbac… (compare)

  • Mar 30 12:22
    otavio closed #266
mtahirbutt
@mtahirbutt
or error
during run time
even zephyr main line was working fine only problem comes when i try to upload image
when i switched to master i see this problem
mtahirbutt
@mtahirbutt
just a question why u are using sha256 on binary and hex files
I think signing is done when some application is used in combination with mcuboot
Gerson Fernando Budke
@nandojve
Fixed 2h ago
Please, @mtahirbutt check it and report on the issue for erwango.
Gerson Fernando Budke
@nandojve
Please, check this doc update too.
mtahirbutt
@mtahirbutt
hi
i am still facing problem with [00:00:37.029,000] <err> updatehub: Could not receive data
with WiFi
sometimes it works when I restart CE
mtahirbutt
@mtahirbutt
[00:01:35.782,000] <err> updatehub: Failed to init flash and erase second slot
mtahirbutt
@mtahirbutt
Hi there?
mtahirbutt
@mtahirbutt
???
Gerson Fernando Budke
@nandojve

@mtahirbutt

with WiFi

I was thinking, since we send UDP packages....one bad package will compromisse the whole update. Currently updatehub was concepted to be used by cables and we are collecting all issues and improve it. So, I belive it will be normal you see failures on wifi ... even more when you have long distance, obstacles and many simultaneous networks close.

Otavio Salvador
@otavio
@nandojve CoAP won't retransmit it?
Gerson Fernando Budke
@nandojve

[00:01:35.782,000] <err> updatehub: Failed to init flash and erase second slot

UpdateHub uses MCUboot calls to do it and MCUboot uses Zephyr Flash Ctrl driver. This could be a flash driver issue.

mtahirbutt
@mtahirbutt
well yesterday i saw a behaviour that when i see 1 retransmission attempt from CoAP POST
so total 2 packets of CoAP POST are seen on wireshark at CE
Gerson Fernando Budke
@nandojve

@nandojve CoAP won't retransmit it?

I'm not complete sure and because of it we need investigate. My assumption is, people that wrote COAP copied from HTTP and HTTP was made to be used by TCP.
So, we need check all this stuff to be sure about behaviour on WiFi.

mtahirbutt
@mtahirbutt
whereas 4 packets (3 retransmission attempts) from the server report are also seen on wireshark at CE
with this situation connection was perfectly fine.
but that was with mainline
I saw this behaviour 1-2 weeks before with continous testing
In normal situation I see 1 CoAP POST message from the board
and 2 packets (1 retransmission attempt) of reply.
with this setting it becomes successful usually when I reset CE
or sometimes i use manual methoed updatehub run
with some time interval
of course
mtahirbutt
@mtahirbutt
Ok I think I will leave this problem intact for the moment.
@nandojve can you suggest a solution to mcuboot
Otavio Salvador
@otavio
@mtahirbutt we are ordering the same board you have so we can reproduce the error here
mtahirbutt
@mtahirbutt
ohh that means it will take a while
Gerson Fernando Budke
@nandojve
@mtahirbutt ST Disco L475 IOT01 (B-L475E-IOT01A) Is this your board, right?
mtahirbutt
@mtahirbutt
yes exactly
Gerson Fernando Budke
@nandojve
@mtahirbutt We will order the 915MHz, Is it ok for you?
mtahirbutt
@mtahirbutt
ohh that is RF module?
i think it is not an issue
Gerson Fernando Budke
@nandojve
just to make sure because he we can only use 915MHz.
mtahirbutt
@mtahirbutt
yes
but Wifi is not using that
I mean the RF module
Gerson Fernando Budke
@nandojve
yes, sure

ohh that means it will take a while

It'll depends on logistics because of COVID-19. In general, 3 days to get boards.

@nandojve CoAP won't retransmit it?

Reliability is provided by marking a message as Confirmable (CON). A
Confirmable message is retransmitted using a default timeout and
exponential back-off between retransmissions, until the recipient
sends an Acknowledgement message (ACK) with the same Message ID (in
this example, 0x7d34) from the corresponding endpoint; see Figure 2.
When a recipient is not at all able to process a Confirmable message
(i.e., not even able to provide a suitable error response), it
replies with a Reset message (RST) instead of an Acknowledgement
(ACK).