Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jul 28 2019 13:35

    UserApplePie on master

    Update README.md (compare)

  • Jul 28 2019 13:28

    UserApplePie on master

    Update README.md (compare)

  • Jul 24 2019 20:18

    davarravad on v4.3.0

    (compare)

  • Jul 24 2019 20:16

    davarravad on master

    Update Header.php Lost the the… Merge pull request #155 from Us… (compare)

  • Jul 24 2019 20:16
    davarravad closed #155
  • Jul 24 2019 20:16
    davarravad opened #155
  • Jul 24 2019 20:11

    davarravad on staging

    Update Header.php Lost the the… (compare)

  • Jul 23 2019 23:51

    UserApplePie on 4.3.0

    (compare)

  • Jul 23 2019 02:55
    davarravad closed #138
  • Jul 23 2019 02:54

    davarravad on master

    Additions and Updates Added Te… Merge pull request #154 from Us… (compare)

  • Jul 23 2019 02:54
    davarravad closed #154
  • Jul 23 2019 02:54
    davarravad opened #154
  • Jul 23 2019 02:54

    davarravad on staging

    Additions and Updates Added Te… (compare)

  • Jul 21 2019 02:08
    davarravad closed #102
  • Jul 21 2019 02:08
    davarravad closed #136
  • Jul 21 2019 02:08

    davarravad on master

    Updates Added Auto Friend feat… Merge pull request #153 from Us… (compare)

  • Jul 21 2019 02:08
    davarravad closed #153
  • Jul 21 2019 02:07
    davarravad opened #153
  • Jul 21 2019 02:07

    davarravad on staging

    Updates Added Auto Friend feat… (compare)

  • Jul 19 2019 16:19

    davarravad on master

    Site Routes URL fix Setup Site… Merge pull request #152 from Us… (compare)

DaVaR
@davarravad
@Promodrone_twitter Thanks. We have put a lot of work into UAP4. Have been slow with progress recently. Got a new house and new girlfriend. lol
As for the password handling I went with the usage built into PHP because everything I found online said it very secure and easy to use.
We have been working on security and always will do so. I am not aware of any vulnerabilities at this time, but if any do come to my attention we will do our best to fix them in future updates.
DaVaR
@davarravad
We also have a nice list of upgrades to give users and admins more control over the platform. I am sure it will be forever updated as any platform is. Hope UAP4 works well for you. If you have any issues or suggestions please share.
Lee Davis
@Promodrone_twitter
OK - I'm game (congrats on the recent life gifts, lol!), going to peruse the video again and launch test install on my WAMP so I can poke around a bit under the hood. I've managed to craft both code for the registration and login using the password_hash/password_verify PHP coding (with Bcrypt), so I'm interested to see what's there and if what I have working will port to UAP V4. Thx again!
DaVaR
@davarravad
No prob. Let me know if you need any help.
Lee Davis
@Promodrone_twitter
@davarrad - which version of V4 do I start with? Downloads section leads me to believe that the top entry is the "latest" version (Beta 2). Or is the "Full" version the one to start with? Going with Beta 2 just to get the feet wet. Thanks again for being as available as possible with this project and responding to my inquiries. It shows me that there's a project that means something to someone in the most quality of ways and lets me know that I won't be wasting time, effort, and energy.
DaVaR
@davarravad
The full version does not require composer. That's the only difference in each of the newer releases. However if you want to be up to date with all the latest fixes use the GitHub repo.
Lee Davis
@Promodrone_twitter
Miller Time (lol!) - with careful reading and minimal effort, have gotten default installation onto my WAMP environment. Must admit my shock at the rapidity of the entire process. Am TRULY amazed. Will registration process be as easy to make myself Admin? No SMTP process/details setup yet.
Getting an error trying to register myself for admin user. Any clue why?
Lee Davis
@Promodrone_twitter
Am I correct in assuming that I have to setup my Google RECAPTCHA keys BEFORE I can register myself as Admin user - gonna get that done anyhoo (lol!).
Lee Davis
@Promodrone_twitter
Also, where would I find the info on the location of the app folder - would like to move that out of root folder so there's no access web-wise (keep hackers from poking around file system)?
I'd recommend an auto-insert for admin user as I'm going bonkers trying to figure out a way not to disturb any part of my newly-minted install as I'm brand-noob to this whole codebase (lol!).
Lee Davis
@Promodrone_twitter
OK - If I want to put a password into the database, how do I do it so it isn't in there in plaintext?
DaVaR
@davarravad
The first user to sign up should automatically be set as Admin.
One way is to echo out the password in its own PHP file using the password function. Check Google. I'm on the road using my phone right now. Will be home in about 3 hours.
Lee Davis
@Promodrone_twitter
Thanks 4 all the help so far - figured out how to generate Bcrypt hash beforehand and am writing an SQL insert to put the DB elements in.
Lee Davis
@Promodrone_twitter
ALL GOOD - Admin user is lodged in database. Looking forward to experimenting with this as a new site codebase. Thanks again, @davarravad!
DaVaR
@davarravad
Welcome bud. Let me know if you need anything or have any suggestions.
Lee Davis
@Promodrone_twitter
Changed the Cookie file, but apparently need activekey to activate the user? Could use the example key in the Motakl example, but don't know if it's a good idea. Any way to generate that on my own? When I attempt to login as Admin, I get success message, and indication that member is online, but no access to my member account, so I can't customize or change details/avatar/etc.
Getting no error msgs since I changed Cookie file for GitHub blob fix.
Lee Davis
@Promodrone_twitter
Homepage Login State
Sorry if the image isn't coming thru (this Markdown is funny for me - used to StackOverflow, lol!).
Lee Davis
@Promodrone_twitter
DaVaR
@davarravad
Humm. I ran into that issue once. I think it was something to do with the cookies. Try clearing the cookie in your browser and see if that works.
Or change the cookie prefix in the config.php file.
Lee Davis
@Promodrone_twitter
OK - cleared browser cookies, but was not able (after line-by-line scan) to find reference to a cookie prefix in Config.php - or is there another file location I need to be looking for.
DaVaR
@davarravad
Oh. It's SEASION_PREFIX in config.php
Lee Davis
@Promodrone_twitter
The menu bar state never changes, even when the green success message appears and the Members Online count registers 1. It's the strangest thing. Even logged out of everything and rebooted box just to ensure everything got refreshed if anything was cached. This is the only problem I'm having at the moment; trying to login and there's nothing further I'm getting through perusing the forum entries. Thanks for anything you can tell me in regards to this.
Lee Davis
@Promodrone_twitter
Now, the Members Online count isn't nulled if I go to the login page then go back to the homepage, but I'm still not able to have access to my account profile, or see that state change on the menu bar after successful login.
DaVaR
@davarravad
Ok. Let me finish up at work and I will help.
Lee Davis
@Promodrone_twitter
Sorry, ...am trying as much as possible to get the overview so I can start usage.
Lee Davis
@Promodrone_twitter
Have recently tried share from http://www.userapplepie.com/Topic/34/, but there was no joy (lol!) - thanks for all the help so far - and, listen; if you just need to have a break, get back top me @ your next convenient time. Not in too much of a rush on this side.
DaVaR
@davarravad
@Promodrone_twitter I just got home. Any luck yet?
Lee Davis
@Promodrone_twitter
Sorry, no love yet (lol!).
Lee Davis
@Promodrone_twitter
Tried everything I could think of, and can't get the state change to kick in
DaVaR
@davarravad
Humm. Not sure why its being a pain. I tested it on Ubuntu 16.04, XAMPP, and WAMP servers...
Which internet browser are you using?
Lee Davis
@Promodrone_twitter
Could be something wonky on my side - looked @ code in Header.php, and nothing to me suggest any errors - IE Edge.
DaVaR
@davarravad
let me try it on my pc right quick
I always use firefox and forget to test with IE and others
Lee Davis
@Promodrone_twitter
Tried with regular IE, Firefox, & Chrome - all the same result as 1st reported.
DaVaR
@davarravad
ok... I am getting same issue with my wamp server. checking to see which version I have on there
Lee Davis
@Promodrone_twitter
I'm using the UAP v4.0.0-Beta-2-Full
DaVaR
@davarravad
yeah looks like I was using beta 1 on there
Lee Davis
@Promodrone_twitter
Yay! Don't feel crazy now (lol!).
DaVaR
@davarravad
I am going to try and copy the github repo and see what it does
ok... same result
Going to change the session prefix and see what happens.
define('SESSION_PREFIX', 'uap4_local_');