These are chat archives for ZaneDubya/UltimaXNA

23rd
Aug 2015
Rex-deadwall
@Rex-deadwall
Aug 23 2015 02:03
i looking to fix a bug in UOfiddler, have any of you dealt with UOfiddler?
Jeff Boulanger
@jeffboulanger
Aug 23 2015 03:10
Yes, some, it's just modified ultimasdk on top of winforms
Rex-deadwall
@Rex-deadwall
Aug 23 2015 03:13
i found a few repo's that people had on Github, and was messing around with it in VS2013. but i get a file output error when i try to run the debug. Basically what i want to fix is some of the map issues with regards to ItemID's above 0x4000. when trying to use the UOfiddler "defrag statics" or "defrag and remove duplicates" options, it deletes all the higher item id's.
within its map.cs file there are a few spots where its only using 0x4000 instead of 0x10000. how do you guys think i should proceed in getting help with this?
Jeff Boulanger
@jeffboulanger
Aug 23 2015 04:36
Probably as easy as looking at that function and changing the 0x4000 to 0x10000 but I'd have to look at the code again it's been a while
Deniz Sökmen
@denizsokmen
Aug 23 2015 04:36
map tiles are only 0x4000 AFAIK
Deniz Sökmen
@denizsokmen
Aug 23 2015 10:03
itemdata goes beyond 0x4000
multi data is itemdata-0x4000
Rex-deadwall
@Rex-deadwall
Aug 23 2015 14:10
ErrorOutputType.JPG
that's kinda what i did, but i just don't have enough experience to output it properly.
0x4000to0x10000.JPG
Rex-deadwall
@Rex-deadwall
Aug 23 2015 14:18
i don't mean to hijack the discussion here, I'll be posting this is some more appropriate forums as well.
Th3Ma5hatt3r
@Th3Ma5hatt3r
Aug 23 2015 14:39
@ZaneDubya
@ZaneDubya Have you noticed a problem with just house slabs?
Zane Wagner
@ZaneDubya
Aug 23 2015 17:26
You mean custom housing?
Not sure they're implemented yet.
Zane Wagner
@ZaneDubya
Aug 23 2015 18:18
@Rex-deadwall Did you figure out how to get the project running?
Rex-deadwall
@Rex-deadwall
Aug 23 2015 21:24
no
Jeff Boulanger
@jeffboulanger
Aug 23 2015 22:25
I can try
@Rex-deadwall Right click the fiddler project and choose set as srartip
Startup
There output error is cause the wrong project is setup as the startup project
I can try to reproduce the error tonoght
Tonight*
Jeff Boulanger
@jeffboulanger
Aug 23 2015 22:39
@Rex-deadwall I also don;t think those are the valeus you need to change
can you reproduce the error and post the exact error message here?
Rex-deadwall
@Rex-deadwall
Aug 23 2015 23:44
ok
Rex-deadwall
@Rex-deadwall
Aug 23 2015 23:50
hey great it launched
i'll test my changes and see it the defraged statics works now
Rex-deadwall
@Rex-deadwall
Aug 23 2015 23:59
great that seems to have done it perfectly