These are chat archives for ZaneDubya/UltimaXNA

10th
Sep 2015
V
@TormentedEmu
Sep 10 2015 02:02
Why is it that when I merge from the remote master, github reports that I'm X commits ahead?
Shouldn't it say instead, I'm on par with the remote master?
Zane Wagner
@ZaneDubya
Sep 10 2015 02:45
Interesting. How are you pulling from the remote master?
V
@TormentedEmu
Sep 10 2015 03:04
I'm using Github desktop to sync
Zane Wagner
@ZaneDubya
Sep 10 2015 03:08
I wonder if it's introducing some kind of cruft?
V
@TormentedEmu
Sep 10 2015 03:10
I don't know, I was hoping one of ya'll had the reason :)
Github is very new to me
Zane Wagner
@ZaneDubya
Sep 10 2015 03:15
Let's try syncing with a pull request. I've opened one on your repository. https://github.com/TormentedEmu/UltimaXNA/pulls
@TormentedEmu Perhaps this will work, perhaps not ;)
Ah, I take it that didn't work.
V
@TormentedEmu
Sep 10 2015 03:19
It didn't work so I made a pull request
Zane Wagner
@ZaneDubya
Sep 10 2015 03:19
That is so bizarre.
V
@TormentedEmu
Sep 10 2015 03:19
I know right
Zane Wagner
@ZaneDubya
Sep 10 2015 03:19
Well I don't want to merge the pull request if this is just going to keep happening. We should figure out what the cause of the problem is...
V
@TormentedEmu
Sep 10 2015 03:19
Ok, just close it no worries
Zane Wagner
@ZaneDubya
Sep 10 2015 03:21
It's bedtime, talk to you tomorrow.
Zane Wagner
@ZaneDubya
Sep 10 2015 03:29
One more idea, try (cmd line) git push origin master , worked for this guy
** do that after git pull origin mas
ter
V
@TormentedEmu
Sep 10 2015 05:14
I've tried git pull, push, fetch without any luck
Zane Wagner
@ZaneDubya
Sep 10 2015 13:58
@TormentedEmu That's lame, I'm sorry.
I'm just firing in the dark here, but it might be an issue with the github desktop client.
Next time try syncing through the web interface by opening a pull request to your own repo from mine?
Perhaps that'll work better...
V
@TormentedEmu
Sep 10 2015 14:31
@ZaneDubya I deleted and started over. I've been reading lots of guides so hopefully this doesn't happen again. :)
Zane Wagner
@ZaneDubya
Sep 10 2015 14:41
Haha we're learning together :D
I've started to get memory access exceptions --- I haven't changed any of the unsafe code, so I'm pretty certain it has to do with the increased amount of outlined fonts I'm rendering...
Yup, as it turns out I'm drawing outline pixels at y == -1.
and potentially at y == height.
:(
Zane Wagner
@ZaneDubya
Sep 10 2015 14:46
Back into the html renderer ...
Jeff Boulanger
@jeffboulanger
Sep 10 2015 16:05
;)
Zane Wagner
@ZaneDubya
Sep 10 2015 18:59
Ok! fixed that bug.
Found what looks like a huge memory leak. :(
if you create a bunch of dummy fighters in a guarded area and let the guards kill them - spawning a ton of speech (thou hast paid for thy villainy, etc) - the memory usage jumps from ~150mb to ~350mb.
I obviously need to figure out how to use the memory debugger...
No time left to do that today though, maybe tomorrow. :|
command for the dummy fighters: [tilez 25 dummysuper
or any other dummy, I'm sure.
Jeff Boulanger
@jeffboulanger
Sep 10 2015 22:26
follow the link, dont use what gitter is rendering
Zane Wagner
@ZaneDubya
Sep 10 2015 23:47
Amazing. And works on iphone
That angel statue does not actually appear in the room...
Creepy as hell