Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Micah Zoltu
    @MicahZoltu
    I haven't used the plugin on anything older than 2.10 before I think.
    So maybe it is an incompatibility with older versions of gradle.
    hanetzer
    @hanetzer
    oh, I'm using 2.12, not the wrapper
    Micah Zoltu
    @MicahZoltu
    Hmm, okay.
    hanetzer
    @hanetzer

    Gradle 2.12

    Build time: 2016-03-14 08:32:03 UTC
    Build number: none
    Revision: b29fbb64ad6b068cb3f05f7e40dc670472129bc0

    Groovy: 2.4.4
    Ant: Apache Ant(TM) version 1.9.3 compiled on December 23 2013
    JVM: 1.8.0_77 (Oracle Corporation 25.77-b03)
    OS: Linux 4.5.0-1-ARCH amd64

    Micah Zoltu
    @MicahZoltu
    Out of curiosity, does it build for you without the plugin? I tried to do a ./gradlew check and it fails on Could not find tools.jar.
    hanetzer
    @hanetzer
    the setup is kinda hinky. blame the oddness of minecraft modding
    Micah Zoltu
    @MicahZoltu
    Ah, its not as simple as just download, unzip, build?
    hanetzer
    @hanetzer
    it is, in general. but dealing with obfuscated code does make it funky.
    Micah Zoltu
    @MicahZoltu
    I see.
    Well, I should be able to troubleshoot without.
    hanetzer
    @hanetzer
    jesus h christ. didn't realize the wrapper was so outta date.
    Micah Zoltu
    @MicahZoltu
    2.7? How far back is that?
    hanetzer
    @hanetzer
    either way, I just use the system installed one and update the wrapper from time to time.
    well, arch generally is up to date within a small margin of oldness, and they ship version 2.12
    I found another git plugin that works, but I perfer the theoretical output yours should do, plus the autoincrement on commits. I'm lazy to a fault.
    Micah Zoltu
    @MicahZoltu
    Hmm, I see it pulling in a new version of jgit, so my original theory doesn't appear to hold.
    org.eclipse.jgit:org.eclipse.jgit:4.2.0.201601211800-r(compile) -> com.jcraft:jsch:0.1.53(compile,runtime)
    That surprises me. I'm not sure what exactly it means though.
    hanetzer
    @hanetzer
    just ran gradle cleanC and retried, same results.
    I don't think forgegradle makes use of any jgit stuffs.
    Micah Zoltu
    @MicahZoltu
    Yeah, and the arrow pointing to the right suggests to me that for some reason jsch is a dependency of jgit (which is definitely not the case).
    I'm going to do some googling and see if I can figure out what that line means.
    hanetzer
    @hanetzer
    not to abandon you, but I was just about to snooze a bit when I noticed you noticed me. I'll be up and running again shortly, though. I just keep odd hours :/
    Micah Zoltu
    @MicahZoltu
    DependencyGraphBuilder] Visiting dependency org.eclipse.jgit:org.eclipse.jgit:4.2.0.201601211800-r(compile) -> com.jcraft:jsch:0.1.53(compile,runtime)
    Now that I can reproduce I can dig in. I'll update the GitHub issue with my findings.
    Thanks for the bug report!
    hanetzer
    @hanetzer
    thanks for enabling my lazy :P
    Micah Zoltu
    @MicahZoltu
    Most people try the plugin and if it doesn't work on the first shot give up so I never hear about any bugs. I'm more than happy to try to fix them when they do come in.
    hanetzer
    @hanetzer
    heh. I found two bugs last night in gradle land, one was fixed already :D
    Micah Zoltu
    @MicahZoltu
    Ah, the jcraft thing is a red herring, unrelated to minecraft.
    Micah Zoltu
    @MicahZoltu
    So I copied the versioning code into the forge-mdk project and it works. This makes it very difficult to troubleshoot unfortunately. :/
    If I remove the buildscript block from the forge-mdk build.gradle the plugin works (but nothing else does, of course)
    Switching to id "net.minecraftforge.gradle.forge" version "2.0.2" results in the same problem.
    Micah Zoltu
    @MicahZoltu
    My current theory is that one of net.minecraftforge.gradle.forge's dependencies has thrown an old version of jgit into a fat jar and it is providing the org.eclipse.jgit.api.DescribeCommand class with an old version.
    Micah Zoltu
    @MicahZoltu
    Okay, figured out a workaround. The correct fix is to figure out which of net.minecraftforge.gradle.forge's depnedencies is bringing org.eclipse.jgit.DescribeCommand into the classpath.
    The workaround is to add classpath 'org.eclipse.jgit:org.eclipse.jgit:4.3.0.201604071810-r' to your buildscript dependencies. That will force all of the plugins to use that version of jgit instead of whatever they depend on or have hard-coded.
    hanetzer
    @hanetzer
    oh dayum, you navigated that crazy mess?
    @Zoltu
    Micah Zoltu
    @MicahZoltu
    @ntzrmtthihu777 Yeah. Let me know if you need any additional help. Do you mind if I close the issue or do you think there is more that can be done on my end?
    hanetzer
    @hanetzer
    yeah, I think that should about do it. I'm having words with the Srg2Source guys.
    Micah Zoltu
    @MicahZoltu
    Okay, sounds good. Feel free to re-open the issue if there is some additional work I can do, or open up a new one.
    Does the work-around work for you?
    @ntzrmtthihu777
    hanetzer
    @hanetzer
    haven'
    t actually tried it, I don't much care for workarounds when an actual fix is doable.
    Micah Zoltu
    @MicahZoltu
    Agreed. Unfortunately I don't believe there is anything more that I can do with the versioning plugin. I think that the problem is on their end (they are not following standard dependency management practices).
    Definitely let me know if things start to point back my way though.
    At a glance, it doesn't appear that Srg2Source is actually using jgit, you may be able to just submit a PR to remove it. I'm still not sure if that would work, but it may be worth a shot.