Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    ramyasrikontham
    @ramyasrikontham
    Hi
    I am integrating SwiftR in my swift app.I am getting
    Error: Optional({
    message = "Error during negotiation request.";
    })
    this error.
    please let me know how can i solve this?
    Adam Hartford
    @adamhartford
    It's hard to say without having access to your server. Are you able to make your server public temporarily? Also, were you able to use the demo server without any problems?
    ramyasrikontham
    @ramyasrikontham
    @ramyasrikontham for http://swiftr.azurewebsites.net this i could able to connect signalR
    Adam Hartford
    @adamhartford
    The most common reasons for this are 1. Trying to connect to the wrong version of SignalR or 2. Using WKWebView in SwiftR and not having CORS enabled on your SignalR server.
    ramyasrikontham
    @ramyasrikontham
    This message was deleted
    Wrong Version means?
    I will try enable CORS and test
    Thanks For quick support.
    Adam Hartford
    @adamhartford
    Wrong version means for example, you're running SignalR version 2.0.0, but SwiftR is configured to expect 2.2.0 by default. You would need to set SwiftR.signalRVersion = .2_0_0 // Or whatever matches the version you're running
    ramyasrikontham
    @ramyasrikontham
    How do i know current version i am using? do i have any get method to know that?
    I set is like this SwiftR.signalRVersion = SignalRVersion.v2_2_0 and server side also we are using same version,But still i am getting same issue.
    ramyasrikontham
    @ramyasrikontham
    Hi Adamhartford
    I took code from GIT and i run SwiftRIos demo with my url it worked fine.And then i tried it installing cocoapods as metioned but i am getting Error: Optional({
    message = "Error during negotiation request.";
    }) this error.
    ramyasrikontham
    @ramyasrikontham
    I want to make sure that , In the demo app downloaded from GIT is giving proper results but same code is giving error from my app
    Please let me know why this is happening .I can even share you 2 codes so that u can check quickly.
    ramyasrikontham
    @ramyasrikontham

    Hey it worked after I added <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">
    <dict>
    <key>NSAllowsArbitraryLoads</key>
    <true/>
    </dict>
    </plist>

    in plist
    i missedout this
    realpunk
    @realpunk
    Hi guys, is it planned to make SwiftR for swift 3 ?
    or is it already updated ? :)
    Adam Hartford
    @adamhartford
    Hi, yes. Version 0.12.0 is for Swift 3.
    realpunk
    @realpunk
    Cool, thanks ;)
    Tadd
    @electromaggot
    Hi Adam,
    Nice work on SwiftR! I'm developing for macOS at the moment, client-side, which connects to an existing SignalR server. I'm just starting to incorporate your project. Your chat client works great on iOS, but I wanted to see it on macOS. So I forked your project and added a 'SwiftR Mac Client Demo' subproject and target... and it works great. It's 95% derived from your code, but with a Mac windowed UI of course. I committed it to my fork in case it may be helpful to you or anyone else. Thanks again for your efforts!
    -- Tadd
    Adam Hartford
    @adamhartford
    Hi Todd, sorry -- just seeing this now. That sounds great. Would you be able to send a pull request?
    Julien Goudet 
    @jlngdt_twitter
    ahoy Adam and Happy New Year
    I will use your framework for longpolling stuff, if i have any questions, i will let you know, btw thank you for this great framework
    Julien Goudet 
    @jlngdt_twitter
    Hello @adamhartford
    I'm using Swift 3 and integrate SwiftR through cocoapod
    do you have any idea why, after a import SwiftR, i can't have access to the init of SignalR object (it's telling me "SignalR" initializer is inaccessible due to internal protection level )
    Adam Hartford
    @adamhartford
    The latest CocoaPods version is behind the current master branch. API has changed, but not been pushed to CocoaPods yet. I'd suggest either pointing your pod to the master branch, or using the older version of the README from the SwiftR page at cocoapods.org.
    Julien Goudet 
    @jlngdt_twitter
    ahoy, thanks
    i managed the init, and now i'm facing into "Error during negotiation request" but it must be on my side. Any tips about JS authorization or debugging method ? it could be nice for the next version to have a debug log for the JS stuff
    :+1:
    Adam Hartford
    @adamhartford
    You can use a Safari web inspector to view any JS logs that aren't currently captured. I also often use Charles Proxy to watch network communication.
    qazaleh
    @qazaleh
    Hello @adamhartford i'm using swift 3 and set signalR Version .v2_2_0 , and get "message": Error during negotiation request. this error .
    Nathanael Gethers
    @DIGnmg
    @adamhartford i had a question about teh invoke method on the hub class. Does that also pass the query params to the websocket of i added some?
    we are having auth problems and i can connect and disconnect and reconnet. But when i try to send it gives me an error
    kiethandsome
    @kiethandsome
    hello im Lou
    can your lib help me to connect to SignalR core?
    @adamhartford