These are chat archives for adamhartford/SwiftR

28th
Jul 2016
ramyasrikontham
@ramyasrikontham
Jul 28 2016 12:18
Hi
I am integrating SwiftR in my swift app.I am getting
Error: Optional({
message = "Error during negotiation request.";
})
this error.
please let me know how can i solve this?
Adam Hartford
@adamhartford
Jul 28 2016 12:25
It's hard to say without having access to your server. Are you able to make your server public temporarily? Also, were you able to use the demo server without any problems?
ramyasrikontham
@ramyasrikontham
Jul 28 2016 12:27
@ramyasrikontham for http://swiftr.azurewebsites.net this i could able to connect signalR
Adam Hartford
@adamhartford
Jul 28 2016 12:28
The most common reasons for this are 1. Trying to connect to the wrong version of SignalR or 2. Using WKWebView in SwiftR and not having CORS enabled on your SignalR server.
ramyasrikontham
@ramyasrikontham
Jul 28 2016 12:29
This message was deleted
Wrong Version means?
I will try enable CORS and test
Thanks For quick support.
Adam Hartford
@adamhartford
Jul 28 2016 12:33
Wrong version means for example, you're running SignalR version 2.0.0, but SwiftR is configured to expect 2.2.0 by default. You would need to set SwiftR.signalRVersion = .2_0_0 // Or whatever matches the version you're running
ramyasrikontham
@ramyasrikontham
Jul 28 2016 12:40
How do i know current version i am using? do i have any get method to know that?
I set is like this SwiftR.signalRVersion = SignalRVersion.v2_2_0 and server side also we are using same version,But still i am getting same issue.