Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Christos Devaris
    @devaris
    Should I update the box menu?
    Chuck Lorenz
    @chucklorenz
    version 5 of the BoxMenu uses BEM and SMACSS, so you'll see __ in the class names.
    Christos Devaris
    @devaris
    Doesn't node update.js does that?
    So I do have the updated version
    I see
    Chuck Lorenz
    @chucklorenz
    Previous versions such as version 4 of the Boxmenu didn't, so you'll see .menu-header
    hyphens instead of __
    Christos Devaris
    @devaris
    ok I can deal with this :)
    Chuck Lorenz
    @chucklorenz
    I suspect that you are running version 5 of the framework inside you AT.
    Christos Devaris
    @devaris
    So in order to achieve this menu:
    εικόνα.png
    I have to write custom css?
    Chuck Lorenz
    @chucklorenz
    Does your course theme look like this: https://adaptlearning.github.io/v5demo/
    Christos Devaris
    @devaris
    yeeeeees!
    Chuck Lorenz
    @chucklorenz
    v4demo uses a different version of the Vanilla theme.
    OK. Does this bring you to a different level of thinking abt what you want to achieve?
    Christos Devaris
    @devaris
    Yes start customizing :)
    Chuck Lorenz
    @chucklorenz
    @devaris check out image below. Did you find this option?
    v5-menu-settings-01.JPG
    Christos Devaris
    @devaris
    Yes I did, already tried that, thanks! :)
    Chuck Lorenz
    @chucklorenz
    goog! then you saw the options in the theme picker, too, right?
    Christos Devaris
    @devaris
    I wonder is there a way to go back to older Vanilla version? Have to go back to older AT version I guess
    Chuck Lorenz
    @chucklorenz
    Yes, that would be the easiest way to get that v4 look.
    To get technical, you don't have to get an "older AT version." You would install the current version of the AT, but you would specify the older version of the framework while you are installing the AT.
    Chuck Lorenz
    @chucklorenz
    @devaris the following snippet of a thread gives you better instructions about getting the correct framework version you want (even if the thread itself doesn't apply to your situation). https://community.adaptlearning.org/mod/forum/discuss.php?d=3930&parent=14429
    Christos Devaris
    @devaris
    Thank you so much!
    Chuck Lorenz
    @chucklorenz
    no worries! cheers
    JeremyBradshaw7
    @JeremyBradshaw7
    image.png
    Hi. Looking to author a single page of content which does not require a menu. Have managed to get it to start at page and stop going back to menu but it's still displaying this back banner at the top. Any way to avoid showing this?
    Guy Willis
    @guywillis
    Hi @JeremyBradshaw7 there is a custom class that you can use on the page html classes property to hide this back button:
    https://github.com/adaptlearning/adapt-contrib-vanilla/blob/master/less/project/theme-extras.less#L8
    JeremyBradshaw7
    @JeremyBradshaw7
    image.png
    Thanks @guywillis , I just found this way too, but yours may be more robust, I'll try it.
    Guy Willis
    @guywillis
    Just a note that this is built into v5 and above
    But you could copy the implementation and paste it in the custom code area of the AT for earlier versions of the framework / theme
    JeremyBradshaw7
    @JeremyBradshaw7
    @guywillis it did work but only removed the button, not the white banner that contains it (which is applied as padding to the #wrapper), so I may stick with the custom CSS fix unless you don't recommend that.
    Guy Willis
    @guywillis
    Ah ha, yes it won't remove the entire nav bar, just the back button
    The custom css would be your best route in this instance
    If you had additional resources in your course and you wanted this accessible via the nav bar then the custom class would be the better route
    git123925
    @git123925
    i have a course built in Adapt and I want to change its menu by doing some customization.i needed some information on it. can any one help?
    christian swanepoel
    @oomgert_twitter
    I have installed Adapt, and logged into the UI. However many of the UI pages load as blank. In fact they don't even log in the activity when clicking on e.g. users
    Oliver Foster
    @oliverfoster
    which browser?
    christian swanepoel
    @oomgert_twitter
    mmm didnt think of that - FF
    Oliver Foster
    @oliverfoster
    browser up to date? try chrome?
    christian swanepoel
    @oomgert_twitter
    Yup - will try quick
    Oliver Foster
    @oliverfoster
    send screen shots, which version of the authoring tool and node ?
    christian swanepoel
    @oomgert_twitter
    safari and chrome does the same
    only #pluginManagement shows content
    info [10 May 21 09:40:22 +00:00] Connection established: adapt-tenant-master
    info [10 May 21 09:40:23 +00:00] Adapt authoring tool 0.10.5.
    info [10 May 21 09:40:23 +00:00] Adapt framework 5.13.0.
    info [10 May 21 09:40:23 +00:00] Server started listening on port 80
    I now see an error: Error: Failed to determine user's tenant!
    christian swanepoel
    @oomgert_twitter
    Where should I go for assistance on this issue?
    John Niezen
    @johnniezen
    @oomgert_twitter are you sure MongoDB is running? and you have the correct authorities to let the AAT access?
    Oliver Foster
    @oliverfoster
    which version of node and screenshots?