Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 17 10:15

    tomgreenfield on pre-releases

    Add logic for compatible newer … (compare)

  • Nov 05 11:07
    tomgreenfield synchronize #134
  • Nov 05 11:07

    tomgreenfield on 133

    Revert redundant default (compare)

  • Nov 05 10:58
    tomgreenfield opened #134
  • Nov 05 10:54

    tomgreenfield on 133

    Switch to inquirer (compare)

  • Nov 05 10:52
    tomgreenfield opened #133
  • Oct 02 10:55
    moloko commented #132
  • Oct 02 10:54
    moloko opened #132
  • Sep 25 08:45
    chris-steele closed #125
  • Sep 25 08:45
    chris-steele commented #125
  • Sep 25 08:40

    chris-steele on v2.1.11

    (compare)

  • Sep 25 08:38

    chris-steele on master

    create course now uses highest … fix merge conflicts Merge pull request #131 from ad… (compare)

  • Sep 25 08:38
    chris-steele closed #131
  • Sep 25 08:32
    chris-steele opened #131
  • Sep 25 08:32

    chris-steele on develop

    Bump lodash from 4.17.11 to 4.1… Bump bower from 1.8.4 to 1.8.8 … Bump mixin-deep from 1.3.1 to 1… and 10 more (compare)

  • Sep 25 08:21

    chris-steele on develop

    create course now uses highest … (compare)

  • Sep 24 11:47

    chris-steele on v2.1.10

    (compare)

  • Sep 24 11:47

    chris-steele on v2.1.10

    (compare)

  • Sep 24 11:45

    chris-steele on master

    Update package.json (compare)

  • Sep 24 11:34

    chris-steele on v2.1.10

    (compare)

Matt Leathes
@moloko
what I would do is adapt create course my-legacy-course legacy
LE-sferenchak
@LE-sferenchak
and move the course directory over?
Matt Leathes
@moloko
and see if you can do adapt install adapt-audio or similar in there
yeah maybe
or use something like WinMerge to compare that one to your exported course to see if you can figure out where they are different and therefore where the problem might lie
it sounds like the adapt-cli is generally working for you
but there's a problem with the exported course
that's all just conjecture of course since I can't see any of this - so just having to go on what you've told me
LE-sferenchak
@LE-sferenchak
Yeah, I was able to install the adapt-audio plugin in the new course we created earlier just fine. I'll try with a "legacy" course using adapt create courses legacy-course legacy
Matt Leathes
@moloko
but yes you could certainly move over the src/course folder into a fresh 'legacy' course
making sure you've amended config.json first (as per link above)
LE-sferenchak
@LE-sferenchak
Sounds like I need to update the framework on my AT install though if it's exporting as 2.2.5
Matt Leathes
@moloko
all depends on whether you want to figure out what the problem is or just get on with it ;-)
LE-sferenchak
@LE-sferenchak
Yeah, the funny thing about src/course/config.json is that there was no "build": {} object
Could that be a cause?
Matt Leathes
@moloko
that is odd. and I don't know.
LE-sferenchak
@LE-sferenchak
Figured it out!
The export isn't including the .bowerrc file
Now I just have to figure out why not, and how to fix it...
Matt Leathes
@moloko
:thumbsup:
check the exported zip file - just in case it did get exported but your zip utility didn't extract it cause it's a 'hidden file'
if it didn't get exported would you mind logging a ticket? https://github.com/adaptlearning/adapt_authoring/issues/new?template=bug_report.md
LE-sferenchak
@LE-sferenchak
Absolutely
Chuck Lorenz
@chucklorenz
@moloko Just discovered an Oct 30 email from C Steele with comments about my CLI README update. I've incorporated his feedback. I believe I still have permissions to write. Would you like me to copy this directly to master or to submit a PR? Alternatively, you can copy from my repo and paste over CLI README.
Matt Leathes
@moloko
would you mind doing it as a PR?
Chuck Lorenz
@chucklorenz
nope. Will do
Zheng Xu
@samumist
I just run into a problem with adapt-cli. When I run adapt create course, I’ve got an error. I use NVM on a MacOS 10.14.2. I tried the command in both Node 6 lts and Node 8 lts, same error. Please have a look of the error screenshot.
Screen Shot 2019-01-02 at 11.25.35 AM.png
Steven W
@sputza_twitter
For those that use RUB CLI, is there an equivalent command to grunt scorm-server? I'm trying to test a change to bookmarking and I would prefer to do this locally rather than a bunch of uploads to SCORM Cloud.
Matt Leathes
@moloko
I just run rub server but manually add scorm_test_harness.html to the url
Steven W
@sputza_twitter
Ok, I will do that. Thanks Matt!
Oliver Foster
@oliverfoster
rub -ds will allow you to watch, edit and rebuild automatically
midhun0909
@midhun0909
hi, i have installed bg image scroll image extension in Adapt cLI. now how can i use that in course
can anyone help me in this
Matt Leathes
@moloko
@midhun0909 typically the README for the extension explains this. you might also want to look at example.json
it’s not a core component so if you need further help you’ll need to contact the extension owner.
VikramSDoke
@VikramSDoke
Can we install the plugin through web access in Adapt authoring tool.
Matt Leathes
@moloko
what is 'the plugin'?
VikramSDoke
@VikramSDoke
any plugins
available in it.
might answer your question? if not please just let us know what you'd like to know more about
VikramSDoke
@VikramSDoke
getting this error
image.png
i have tryied in adapt course directory also
Matt Leathes
@moloko
sorry did you definitely mean to say 'adapt authoring tool' earlier
that is a very different thing
and you wouldn't use the CLI with it
the above error looks like a CLI error
VikramSDoke
@VikramSDoke

and you wouldn't use the CLI with it

so how can i install plugin through command