These are chat archives for adaptlearning/adapt_authoring

23rd
Mar 2016
Himanshu Rajotia
@hrajotia
Mar 23 2016 07:16
Good Morning!
New PR: adaptlearning/adapt_authoring#1117
Brian Quinn
@brian-learningpool
Mar 23 2016 09:23
good morning!
thanks @hrajotia, i'll get a look at that later today
Dan Gray
@dancgray
Mar 23 2016 09:24
Morning all
Brian Quinn
@brian-learningpool
Mar 23 2016 09:27
morning Dan
Dan Gray
@dancgray
Mar 23 2016 10:13
@taylortom are you still having issues installing dev branch on Win7?
lc-thomasberger
@lc-thomasberger
Mar 23 2016 10:30
i do
Dan Gray
@dancgray
Mar 23 2016 10:33
Is it isolated to win7?
lc-thomasberger
@lc-thomasberger
Mar 23 2016 10:36
the weird part is, it worked during development
Tom Taylor
@taylortom
Mar 23 2016 10:37
latest issue is a broken build of the AT, worked until then
errors during the requirejs grunt task
lc-thomasberger
@lc-thomasberger
Mar 23 2016 10:38
i had one issue during node install. AT compiled and ran but i could not login. it turned out that no user was created
Tom Taylor
@taylortom
Mar 23 2016 10:41
odd
I haven't really looked into my problem, it could just be random
Dan Gray
@dancgray
Mar 23 2016 10:46
Very odd. Installs & upgrades fine on windows 10 (new vagrant box) and Mac
Brian Quinn
@brian-learningpool
Mar 23 2016 11:09
are we affected by the left-pad issue?
Tom Taylor
@taylortom
Mar 23 2016 11:24
no idea
gpu17
@ganeshubhare
Mar 23 2016 12:11
hello there . I am trying to install the authoring tool using the Vigrant for windows. After successful installation the http://localhost:5000 does load the tool
can anyone please guide me on what could be causing this
lc-thomasberger
@lc-thomasberger
Mar 23 2016 12:13
hello, have you used the master branch?
gpu17
@ganeshubhare
Mar 23 2016 12:13
yes
lc-thomasberger
@lc-thomasberger
Mar 23 2016 12:15
i would recommend reinstalling using the develop branch since this branch fixes two known issues. Unfortunately we do have still some odd issues on windows. It would be very helpful if you could test the develop branch.
gpu17
@ganeshubhare
Mar 23 2016 12:17
okay. I will try that and let you know if that works .Mine is win7 64 bit
will that make any differece?
lc-thomasberger
@lc-thomasberger
Mar 23 2016 12:17
this should be fine. thanks for testing. do you have git installed?
gpu17
@ganeshubhare
Mar 23 2016 12:18
yes
I will download the develop version and test it. Thanks for your advise
lc-thomasberger
@lc-thomasberger
Mar 23 2016 12:18
great, no problem
gpu17
@ganeshubhare
Mar 23 2016 12:47
Hi, used the development version and the http://localhost:5000 works but it only shows the following message "app.loading" and nothing else
lc-thomasberger
@lc-thomasberger
Mar 23 2016 12:48
can you please check the cmd prompt for error messages
gpu17
@ganeshubhare
Mar 23 2016 12:49
blob
that's my command prompt. don't think there are any errors
lc-thomasberger
@lc-thomasberger
Mar 23 2016 12:50
probably somewhere before
can you please type: vagrant ssh
pm2 stop 0 grunt build:prod pm2 start server.js
gpu17
@ganeshubhare
Mar 23 2016 12:54
vagrant ssh provide following info
blob
other commands don't work
lc-thomasberger
@lc-thomasberger
Mar 23 2016 12:56
are you sure that you have git installed?
gpu17
@ganeshubhare
Mar 23 2016 12:59
installing it now. I am not a hardcore developer. Just following the installation instruction here https://github.com/adaptlearning/adapt_authoring/wiki/Install-with-Vagrant
lc-thomasberger
@lc-thomasberger
Mar 23 2016 13:02
yeah we might update the documentation to be more specific. Most of the developers testing the releases do have git installed so it is hard to track this bugs
gpu17
@ganeshubhare
Mar 23 2016 13:06
ok thanks. Will let you know more about any specific errors I got during installation
lc-thomasberger
@lc-thomasberger
Mar 23 2016 13:13
that would be very helpful
Tom Taylor
@taylortom
Mar 23 2016 13:43
don't think git/ssh client should be a pre-requisite for install, but there should maybe be a section for debugging
lc-thomasberger
@lc-thomasberger
Mar 23 2016 13:44
well windows does not have ssh by default
i just reinstalled on the same two machines using develop branch. this time it worked on both. i don't like this
debugging section would be good
Tom Taylor
@taylortom
Mar 23 2016 13:48
but is ssh needed for anything other than advanced debugging? if all goes well, there should be no need to get into the virtual machine
lc-thomasberger
@lc-thomasberger
Mar 23 2016 13:49
i don't know tbh. i thought that vagrant uses ssh to setup the machine
i will check the vagrant docs
lc-thomasberger
@lc-thomasberger
Mar 23 2016 14:20
looks like it is only required for vagrant ssh
Rui @LetItHappen
@letithappen
Mar 23 2016 17:28

After upgrading framework to v.2.0.8 I started getting this error building my courses: Warning: Error while processing "courses/56cb37ad172613280cc8d334/56d9c742720a62
9c16e122aa/build/imsmanifest.xml" file. Use --force to continue.

Aborted due to warnings.

Rui @LetItHappen
@letithappen
Mar 23 2016 17:33
It stopped once I disabled the Tutor Extension