Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Chuck Lorenz
@chucklorenz
still getting the file structure error or something else?
Sam Howell
@squire:privacytools.io
[m]
about to find out, currently in progress
it gets to halfway then the progress bar starts from the beginning again :S
... then "course import failed" and no further info
Chuck Lorenz
@chucklorenz
crazy. Have you eliminated node_modules?
is file size an issue?
max import size can be adjusted
Sam Howell
@squire:privacytools.io
[m]
yeah it wasn't in the folder, that's why it worked importing to VM, just won't import into this server. it's only 7.8MB
it must be something specific to this instance
(or server)
ok maybe not, i tested another way by exporting new AT course, then importing, and that works fine... so maybe versioning issue?
Chuck Lorenz
@chucklorenz
pushing my experience with import problems. Haven't encountered many. However, I'm surprised that it is failing without a specific error message.
maybe some clue in the server logs??
Sam Howell
@squire:privacytools.io
[m]

I think it may be a memory issue. I now get this trying to import a ~3MB zip:

Request Entity Too Large

Console warning:

Will-change memory consumption is too high. Budget limit is the document surface area multiplied by 3 (1803040 px). Occurrences of will-change over the budget will be ignored.
Chuck Lorenz
@chucklorenz
good clue
Sam Howell
@squire:privacytools.io
[m]
still not sure though. I've just kept my eye on htop via shell into server, monitoring memory usage, and it wasn't maxing out, so i figure it must be something else...
No idea what this is... Request Entity Too Large
so i'll need to find out how to adjust this for nginx
Chuck Lorenz
@chucklorenz
default for AAT is 200MB, I believe. I've had courses with many images that went higher. Might consider upping that too at this point while you're at it. There's a post or two in the forums about where to do that. (I think the framework might be optimizing images now; but lots of courses authors, in my experience, forget to optimize images before uploading.)
Sam Howell
@squire:privacytools.io
[m]
OK got it working :) I just needed to tell nginx to allow uploads of up to 20MB
Chuck Lorenz
@chucklorenz
:thumbsup:
Sam Howell
@squire:privacytools.io
[m]
by default there was no setting at all, so it was potentially not allowing any uploads
thanks for the tips
Chuck Lorenz
@chucklorenz
np
kateblocki
@kateblocki
Hi Not sure if anyone can help but is it possible to change the navigation so that you go from main menu module one to submenu module 1, then back to main menu 2 then submenu 2? I am having issues with quick assessments and end of module assessments that have a 60% pass mark. I am putting the end of module assessment on separate section but don't want to over load the screen with lots of modules. I read something from2016 that it might not be possible in the adapt auth tool version but wondered if things ahad changed and now you can alternate between sub menu and main menu?
Simon Date
@simondate
@kateblocki Do you mean navigating using the back button (top left in the nav bar) or navigating using a compoent/extension like QuickNav?
Sam Howell
@squire:privacytools.io
[m]
What's the recommended way to insert a script tag into the head of the authoring tool html page?
tomgreenfield
@tomgreenfield
there isn't a recommended way, so hack it however you see fit?
Sam Howell
@squire:privacytools.io
[m]
Thanks, where would I start in adapt_authoring directory? I had a look for a handlebars template, but not sure where this is exactly, and whether this would be the best file to edit.
Sam Howell
@squire:privacytools.io
[m]
👍️
Matt Leathes
@moloko
@chucklorenz to optimise images in the framework do grunt compress && grunt build (IIRC)
grunt compress will optimise the images in the src/course folder, then grunt build (or grunt dev) copies them to the build folder
... not that you need to upload the build folder to the AAT
Chuck Lorenz
@chucklorenz
Yes, that's my understanding
Rob Meals
@rmeals
Hello, I am trying to get the authoring environment to load from a new AWS instance. Seems install has worked, and I am able to log in. However, I only have usability on the Plugin Management page. Everything else is (effectively) blank. Wondering if this is a common issue that can be corrected. TIA!
Rob Meals
@rmeals
Upon further reading, I see the following in my server logs: Error: Failed to determine user's tenant! I tried "npm install mongoose@5.8.13 " and after a server reboot, the same error occurs. Any ideas would be appreciated.
Rob Meals
@rmeals
I got everything working. There are some steps that are not clear in initial setup guides.
Ailiniyazi Maimaiti
@fkcailiniyazi
Hez Rob, could you please include which version of AAT and Framework you installed and which version of node/npm do you have?
*Hey
https://community.adaptlearning.org/mod/forum/discuss.php?d=1084#p5173
I didn't have such issue personally, but what I can see it from the discussion above, it could be the problem of node version, try to use node TLS Version 10 (or above).
Sam Howell
@squire:privacytools.io
[m]
Is there any way to search for an image in the assets library using its ID? It's seemingly like a needle in a haystack without being able to do this.
John Niezen
@johnniezen
@squire:privacytools.io what I sometimes do is publish the course, and then check which component it is in, then check in the page editor for the picture, and then I go the the asset manager, clumsy I know
1 reply
there is most probably a faster way but I rarely need it so not bothering
Chuck Lorenz
@chucklorenz
@squire:privacytools.io Another technique, which likewise doesn't fill every need: use MongoDB or Robo 3T to inspect asset data. Take _fieldName from the courseassets collection and match it to fileName in the assets collection.
John Niezen
@johnniezen
@chucklorenz yes more or less the route I take to delete not needed assests, find which have the deleted flag and remove the record
Sam Howell
@squire:privacytools.io
[m]
thanks both, unfortunately the difficulty arises from the fact I'm trying to search for specific images via the frontend, with no access to the database or anything else in the backend.
Sam Howell
@squire:privacytools.io
[m]
I wanted to do some work on this idea: adaptlearning/adapt_authoring#2507, by editing the nav template, but none of the changes I make to this file seem to pull through in the frontend. Is this the wrong file? Any suggestions on customising the nav template appreciated.
John Niezen
@johnniezen
@squire:privacytools.io maybe these 2 repositories give some hints to go forward : https://github.com/taylortom/adapt-systemInfo and https://github.com/taylortom/adapt-sysadmin-serverconfig