Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 02:23
    jayseventwo commented #2570
  • 00:20
  • Oct 20 22:03
    jayseventwo commented #2570
  • Oct 20 10:22
    simondate commented #2570
  • Oct 20 10:21
    simondate opened #2571
  • Oct 20 10:17
    simondate commented #2570
  • Oct 18 04:25
    jayseventwo commented #2570
  • Oct 18 01:16
    jayseventwo commented #2570
  • Oct 16 13:12
    sadeghbarati starred adaptlearning/adapt_authoring
  • Oct 14 22:31
    jayseventwo opened #2570
  • Oct 14 03:15
    jayseventwo commented #2569
  • Oct 06 17:36
    chucklorenz labeled #2515
  • Oct 06 12:33
    fkcailiniyazi commented #2562
  • Oct 06 12:33
    fkcailiniyazi commented #2562
  • Oct 06 12:14
    fkcailiniyazi closed #2550
  • Oct 06 12:09
    fkcailiniyazi labeled #2564
  • Oct 06 12:08
    fkcailiniyazi commented #2565
  • Oct 06 12:06
    fkcailiniyazi commented #2569
  • Oct 06 12:05
    fkcailiniyazi commented #2569
  • Oct 06 12:04
    fkcailiniyazi commented #2569
John Niezen
@johnniezen
@squire:privacytools.io what I sometimes do is publish the course, and then check which component it is in, then check in the page editor for the picture, and then I go the the asset manager, clumsy I know
1 reply
there is most probably a faster way but I rarely need it so not bothering
Chuck Lorenz
@chucklorenz
@squire:privacytools.io Another technique, which likewise doesn't fill every need: use MongoDB or Robo 3T to inspect asset data. Take _fieldName from the courseassets collection and match it to fileName in the assets collection.
John Niezen
@johnniezen
@chucklorenz yes more or less the route I take to delete not needed assests, find which have the deleted flag and remove the record
Sam Howell
@squire:privacytools.io
[m]
thanks both, unfortunately the difficulty arises from the fact I'm trying to search for specific images via the frontend, with no access to the database or anything else in the backend.
Sam Howell
@squire:privacytools.io
[m]
I wanted to do some work on this idea: adaptlearning/adapt_authoring#2507, by editing the nav template, but none of the changes I make to this file seem to pull through in the frontend. Is this the wrong file? Any suggestions on customising the nav template appreciated.
John Niezen
@johnniezen
@squire:privacytools.io maybe these 2 repositories give some hints to go forward : https://github.com/taylortom/adapt-systemInfo and https://github.com/taylortom/adapt-sysadmin-serverconfig
systeminfo works for us
Sam Howell
@squire:privacytools.io
[m]
Interesting, I'll take a look, thanks
Sam Howell
@squire:privacytools.io
[m]
I'm still not sure why my own changes to the template file aren't pulling through...
Sam Howell
@squire:privacytools.io
[m]
This is what I've tried so far:
          {{#if isAuthenticated}}
            <span class="navigation-item">{{adapt_authoring}}</span>
            <span class="navigation-item">{{adapt_framework}}</span>
            <a href="#" class="navigation-item navigation-help" data-event="help">
              <span>{{t 'app.help'}}</span>
            </a>
            <a href="#" class="navigation-item navigation-profile" data-event="user:profile">
              {{t 'app.loggedinas'}}: <span>{{email}}</span>
            </a>
            <a href="#" class="navigation-item navigation-user-logout btn white-hollow" data-event="user:logout">
              <span>{{t 'app.logout'}}</span>
            </a>
            {{/if}}
          </div>
tomgreenfield
@tomgreenfield
personally i wouldn't recommend adding anything more to the nav bar - we've had problems in the past even with long emails! (adaptlearning/adapt_authoring#2511) not every user has their window maximised or a high resolution screen. i do like tom's plugin in the menu
1 reply
Sam Howell
@squire:privacytools.io
[m]

Anyone know what could be causing this (in browser's console error after a "Oops, something went wrong")?

Error occured getting the tags collection - try refreshing your page

The authoring tool I'm using seems very temperamental at the moment but there sometimes seems to be no way to identify the cause of issues. Sometimes I'll go to click on edit, save or preview buttons and it will throw the "Oops" error. This seems to happen at random. Could others using the authoring tool be a part of this?

I'm also getting this in the popup errors:
app.errorfetchingdata
Sam Howell
@squire:privacytools.io
[m]

:point_up: Edit: I'm trying to mark a Graphic component (which contains a GIF) as not accessible by trying the following:

  • Adding the not-accessible class (I seem to remember seeing this was built-in, but I might be wrong, or may have been removed)
  • Checking the "Is the accessibility state disabled?" box

But when using NVDA, the component is still be called out with "Graphic clickable". Not sure where I'm going wrong. I've had to overlay this GIF with a <span> in rather a hacky way so it acts as button to open a Notify popup. It sits hidden over the top of the GIF. I want the learner to be able to tab to this 'button' so I added the attribute tabindex="0", but once the learner closes the popup, they land at the GIF and hear "Graphic clickable" - what's the best way to override this?

FW: v4.5.0

:point_up: Edit: I'm trying to mark a Graphic component (which contains a GIF) as not accessible by trying the following:

  • Adding the not-accessible class (I seem to remember seeing this was built-in, but I might be wrong, or may have been removed)
  • Checking the "Is the accessibility state disabled?" box

But when using NVDA, the component is still be called out with "Graphic clickable". Not sure where I'm going wrong. I've had to overlay this GIF with a <span> in rather a hacky way so it acts as button to open a Notify popup. It sits hidden over the top of the GIF. I want the learner to be able to tab to this 'button' so I added the attribute tabindex="0", but once the learner closes the popup, they land at the GIF and hear "Graphic clickable" - what's the best way to override this?

Framework: v4.5.0

:point_up: Edit: I'm trying to mark a Graphic component (which contains a GIF) as not accessible by trying the following:

  • Adding the not-accessible class (I seem to remember seeing this was built-in, but I might be wrong, or may have been removed)
  • Checking the "Is the accessibility state disabled?" box

But when using NVDA, the component is still be called out with "Graphic clickable". Not sure where I'm going wrong. I've had to overlay this GIF with a <span> in rather a hacky way so it acts as button to open a Notify popup. It sits hidden over the top of the GIF. I want the learner to be able to tab to this 'button' so I added the attribute tabindex="0", but once the learner closes the popup, they land at the GIF and hear "Graphic clickable" - what's the best way to override this?

Framework: v4.5.0
Authoring tool: not sure as the attribute isn't in <html>

tomgreenfield
@tomgreenfield
sweet mary of nazareth
gitter.png
Sam Howell
@squire:privacytools.io
[m]
Sorry, didn't know it was adding edits underneath like that.
tomgreenfield
@tomgreenfield
haha np
sounds like a question for the accessibility room?
Sam Howell
@squire:privacytools.io
[m]
I thought it would just update the post. That's how it appears my end.
Yes, considered that, but thought I'd keep it here temporarily as it's also authoring tool related. I'll move it now.
tomgreenfield
@tomgreenfield
sounds like there's enough going on for a custom component, but i haven't any authoring tool specific advice for you i'm afraid
Sam Howell
@squire:privacytools.io
[m]
No worries, thanks. I'd usually avoid so many workarounds to try to balance the desired effect and accessibility, but it's a customer request so I've had to compromise.
willkl2433
@willkl2433
Good Morning All, I hope soemone can help me, I am not a technical person. I do have the Adapt authoring tool set up on AWS (done by a friend), it works perfectly but for one thing I cannot upload additional plugins to the authoring tool in the prescribed way when I try I get the same message each time, the message is "Plugin upload failed Error: EACCES: permission denied, mkdir '/plugins
Oliver Foster
@oliverfoster
You'll probably need your friend to help you change the permissions on the folder.
Each program is run with the permissions of a user account on the system. Each folder has read/write/etc permissions for each user account, group etc. You just don't have permissions in the user account the AAT is running in to write to that folder.
willkl2433
@willkl2433
@oliverfoster Thank you Oliver, it is now sorted
Oliver Foster
@oliverfoster
:+1:
Sam Howell
@squire:privacytools.io
[m]
Every time I upload a new version of a theme, it seems to affect a course's Trickle. Trickle remains enabled, but all buttons disappear and I have to go into every block/article which has it enabled, and resave, for it to work again. Is there a reason for this, and can it be prevented in any way?
FW: 4.5.0
AT: 0.10.5
Trickle: 3.0.2
Sam Howell
@squire:privacytools.io
[m]
I've now solved the issue, which appeared to just be browser caching.
Sam Howell
@squire:privacytools.io
[m]
Hi all, we've had our first experience of a customer running into the Chrome on Android issue re image lazy loading. I noticed there's this useful patch: https://github.com/cgkineo/adapt-lazyLoadPatch - can it be uploaded to the AT as well?
tomgreenfield
@tomgreenfield
have you tried uploading it?
Sam Howell
@squire:privacytools.io
[m]
Yes, just about to say I've sorted it now. I should have just tried it before asking.
tomgreenfield
@tomgreenfield
:+1:
Sam Howell
@squire:privacytools.io
[m]
I can see in the bower.json for the extension that it's compatible up to FW v5.3 Is that because the fix is present by default in frameworks 5.4>?
Sam Howell
@squire:privacytools.io
[m]
We just want to know when we'd be safe to no longer rely on the plugin, or whether using this with a certain version of the framework would cause conflicts
thanks
silly me for not checking the changelog...
Sam Howell
@squire:privacytools.io
[m]
I have a theme which seems to not work with Trickle in the authoring tool. I've confirmed that the Trickle button appears as expected when other themes are used, but with the theme in question it won't. Steplocking does work, it's just the button never appears, so if button is enabled, you can never proceed once a section is complete. I'm not sure how best to troubleshoot. It worked fine in the framework, but in the authoring tool the button never loads in the DOM, only for this one theme. I may have mistakenly broken something related to Trickle button styling in the theme, but if anyone has any other ideas please let me know.
Oliver Foster
@oliverfoster
no block padding used to do that
i believe
Sam Howell
@squire:privacytools.io
[m]
Is there a way to pass Less class parameters into the Classes field of components as shown? Doesn't seem to like it...
tomgreenfield
@tomgreenfield
less is a preprocessor that compiles into css when the grunt task is run. the classes field adds classes to the dom via js. two separate ecosystems...
Sam Howell
@squire:privacytools.io
[m]
Yeah I guess I thought that as I could add Less to the CSS/Less box, I could use it in the classes field, but I suppose all the custom box is doing is appending its contents to the theme before anything is compiled. Is that right?
tomgreenfield
@tomgreenfield
yup