Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
tomgreenfield
@tomgreenfield
sweet mary of nazareth
gitter.png
Sam Howell
@squire:privacytools.io
[m]
Sorry, didn't know it was adding edits underneath like that.
tomgreenfield
@tomgreenfield
haha np
sounds like a question for the accessibility room?
Sam Howell
@squire:privacytools.io
[m]
I thought it would just update the post. That's how it appears my end.
Yes, considered that, but thought I'd keep it here temporarily as it's also authoring tool related. I'll move it now.
tomgreenfield
@tomgreenfield
sounds like there's enough going on for a custom component, but i haven't any authoring tool specific advice for you i'm afraid
Sam Howell
@squire:privacytools.io
[m]
No worries, thanks. I'd usually avoid so many workarounds to try to balance the desired effect and accessibility, but it's a customer request so I've had to compromise.
willkl2433
@willkl2433
Good Morning All, I hope soemone can help me, I am not a technical person. I do have the Adapt authoring tool set up on AWS (done by a friend), it works perfectly but for one thing I cannot upload additional plugins to the authoring tool in the prescribed way when I try I get the same message each time, the message is "Plugin upload failed Error: EACCES: permission denied, mkdir '/plugins
Oliver Foster
@oliverfoster
You'll probably need your friend to help you change the permissions on the folder.
Each program is run with the permissions of a user account on the system. Each folder has read/write/etc permissions for each user account, group etc. You just don't have permissions in the user account the AAT is running in to write to that folder.
willkl2433
@willkl2433
@oliverfoster Thank you Oliver, it is now sorted
Oliver Foster
@oliverfoster
:+1:
Sam Howell
@squire:privacytools.io
[m]
Every time I upload a new version of a theme, it seems to affect a course's Trickle. Trickle remains enabled, but all buttons disappear and I have to go into every block/article which has it enabled, and resave, for it to work again. Is there a reason for this, and can it be prevented in any way?
FW: 4.5.0
AT: 0.10.5
Trickle: 3.0.2
Sam Howell
@squire:privacytools.io
[m]
I've now solved the issue, which appeared to just be browser caching.
Sam Howell
@squire:privacytools.io
[m]
Hi all, we've had our first experience of a customer running into the Chrome on Android issue re image lazy loading. I noticed there's this useful patch: https://github.com/cgkineo/adapt-lazyLoadPatch - can it be uploaded to the AT as well?
tomgreenfield
@tomgreenfield
have you tried uploading it?
Sam Howell
@squire:privacytools.io
[m]
Yes, just about to say I've sorted it now. I should have just tried it before asking.
tomgreenfield
@tomgreenfield
:+1:
Sam Howell
@squire:privacytools.io
[m]
I can see in the bower.json for the extension that it's compatible up to FW v5.3 Is that because the fix is present by default in frameworks 5.4>?
Sam Howell
@squire:privacytools.io
[m]
We just want to know when we'd be safe to no longer rely on the plugin, or whether using this with a certain version of the framework would cause conflicts
thanks
silly me for not checking the changelog...
Sam Howell
@squire:privacytools.io
[m]
I have a theme which seems to not work with Trickle in the authoring tool. I've confirmed that the Trickle button appears as expected when other themes are used, but with the theme in question it won't. Steplocking does work, it's just the button never appears, so if button is enabled, you can never proceed once a section is complete. I'm not sure how best to troubleshoot. It worked fine in the framework, but in the authoring tool the button never loads in the DOM, only for this one theme. I may have mistakenly broken something related to Trickle button styling in the theme, but if anyone has any other ideas please let me know.
Oliver Foster
@oliverfoster
no block padding used to do that
i believe
Sam Howell
@squire:privacytools.io
[m]
Is there a way to pass Less class parameters into the Classes field of components as shown? Doesn't seem to like it...
tomgreenfield
@tomgreenfield
less is a preprocessor that compiles into css when the grunt task is run. the classes field adds classes to the dom via js. two separate ecosystems...
Sam Howell
@squire:privacytools.io
[m]
Yeah I guess I thought that as I could add Less to the CSS/Less box, I could use it in the classes field, but I suppose all the custom box is doing is appending its contents to the theme before anything is compiled. Is that right?
tomgreenfield
@tomgreenfield
yup
Guy Willis
@guywillis

Good morning @squire:privacytools.io

Whilst you cannot pass in LESS, as detailed by Tom, you could create a mixin (either in the theme itself or within the custom CSS/LESS textarea) that allows you to pass in a common and unique class to style up a plugin. For example, in the theme there is a block color mixin that showcases this concept - the common class applies the unique styling whilst the unique class defines the colour - https://github.com/adaptlearning/adapt-contrib-vanilla/blob/master/less/project/theme-extras.less#L158

Safwan Hossain
@safwanhossain92_twitter
Hi, How do i change the size of mcq boxes in adapt-contrib-vanilla theme?
Oliver Foster
@oliverfoster
Please only ask your question in one room @safwanhossain92_twitter
kylethrock
@kylethrock
I just upgrade the authoring tool to the latest version... Now my instance of the authoring tool is running very slow and it takes a long time to open courses and use the tool. I am looking to see if there is a fix for this or if anyone else has this same issue after an upgrade?
Francescasiquis
@Francescasiquis
Hello! I just upgrade the authoring tool to the latest version... but I cannot do anything, because the dashboard is empty! I only have the plugin settings! Please, can you help me to understand the problem!!!
MartinJuhler
@MartinJuhler

Hi I was wondering if anybody could help me with the scaling problem I get when adding a picture as header in the main menu. See gif. Here I used zoom but, it also happens if you change the size of the window.

Header problem.gif

Another question that I would like an answer to is how to change the Accordian so that when it expands, the users don't have to scroll back up as shown in the gif.

Accordian scrole back problem.gif

MartinJuhler
@MartinJuhler
I tried to figure out how to post these questions in the Technical forum, but I can't find an add new discussion button. Do I need permission to do this. If yes, how do I do that. Or has everything switched to this forum?
Simon Date
@simondate
@MartinJuhler I think you need to create an account to post on the forum. It's still used although not as watched as here
Simon Date
@simondate

Regarding the menu header image - I think it's something to do with the css value you are using for height/width. In v5 of Adapt we moved towards rem (root em) which is relative to the root size of the HTML element - https://www.sitepoint.com/understanding-and-using-rem-units-in-css/

Perhaps switch either to rem or something else to see if it fixes it

And for the accordion thing a setting doesn't exist. You could request it as a feature here - https://github.com/adaptlearning/adapt_framework/issues
2 replies
MartinJuhler
@MartinJuhler
Does there exist a plugin that allows teams to comment on each other's work... If not. What is the best practices out there for addressing this challenge?
3wc
@3-w-c

2020-10-24 @3-w-c
hi, I don't know if there are any docker fans in here, but I made some updates to the images pvadimir and @garyritchie made: https://github.com/3-w-c/docker-adaptauthoring :whale:

the main change is that you can now set up and deploy in one step, so it's more easily compatible with Docker "swarm mode". The way I automated the node install script feels a bit diabolical and I'd be very open to suggestions improving it.

Is anyone interested in working together to try and get this image / another image / some combination of images integrated into Adapt? :pray:

hiya folks, just wanted to check in whether there was any news on an official Adapt Authoring Docker set-up? I'm still running an instance of AAT using this set-up (via Co-op Cloud) and it's working fine – I'd still be very happy to help try and contribute this work to core if anyone is down

Chetan Sachdev
@cksachdev

Q. I have configured a 3 node mongodb cluster and tried to configure dbReplicaset in the configuration, but the settings are not clear. Below are the configuration values tried:

"dbName": "adapt-tenant-master",
  "useConnectionUri": true,
  "dbHost": "10.0.2.4",
  "dbPort": 27017,
  "dbUser": "",
  "dbPass": "",
  "dbConnectionUri": "mongodb://10.0.2.4:27017,10.0.2.14:27017,10.0.2.252:27017/adapt-tenant-master?replicaSet=mongo-rs",
  "dbAuthSource": "",

After updating these configuration, when I run node server connection isn't successful, I am able to ping all 3 nodes and able to telnet to 27017.

Safwan Hossain
@safwanhossain92_twitter
Q. Hello, Safwan here. After 100% completion, I want to provide the student with certification. how do I do that?
Safwan Hossain
@safwanhossain92_twitter
Also how do i turn off the Log window while previewing the course
Oliver Foster
@oliverfoster
certificates: usually an LMS thing
you could try https://github.com/cgkineo/adapt-certificate, i don't know if it still works or if you'd need to modify it