Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Aug 04 11:06
    oliverfoster edited #2566
  • Aug 04 11:06
    oliverfoster edited #2566
  • Aug 04 11:05
    oliverfoster opened #2566
  • Jul 27 22:52
  • Jul 26 19:01
    taylortom unlabeled #1941
  • Jul 26 19:00
    taylortom unlabeled #2211
  • Jul 26 18:55
    taylortom labeled #2367
  • Jul 26 18:53
    taylortom labeled #2554
  • Jul 26 18:52
    taylortom labeled #2549
  • Jul 26 18:52
    taylortom labeled #2512
  • Jul 26 18:50
    taylortom labeled #2449
  • Jul 26 18:50
    taylortom labeled #2436
  • Jul 26 18:50
    taylortom labeled #2435
  • Jul 26 18:50
    taylortom labeled #2434
  • Jul 26 18:50
    taylortom labeled #2427
  • Jul 26 18:50
    taylortom labeled #2333
  • Jul 26 18:46
    taylortom labeled #2265
  • Jul 26 18:46
    taylortom labeled #2263
  • Jul 26 18:46
    taylortom labeled #2262
  • Jul 26 18:46
    taylortom labeled #2237
Sam Howell
@squire:privacytools.io
[m]
We just want to know when we'd be safe to no longer rely on the plugin, or whether using this with a certain version of the framework would cause conflicts
thanks
silly me for not checking the changelog...
Sam Howell
@squire:privacytools.io
[m]
I have a theme which seems to not work with Trickle in the authoring tool. I've confirmed that the Trickle button appears as expected when other themes are used, but with the theme in question it won't. Steplocking does work, it's just the button never appears, so if button is enabled, you can never proceed once a section is complete. I'm not sure how best to troubleshoot. It worked fine in the framework, but in the authoring tool the button never loads in the DOM, only for this one theme. I may have mistakenly broken something related to Trickle button styling in the theme, but if anyone has any other ideas please let me know.
Oliver Foster
@oliverfoster
no block padding used to do that
i believe
Sam Howell
@squire:privacytools.io
[m]
Is there a way to pass Less class parameters into the Classes field of components as shown? Doesn't seem to like it...
tomgreenfield
@tomgreenfield
less is a preprocessor that compiles into css when the grunt task is run. the classes field adds classes to the dom via js. two separate ecosystems...
Sam Howell
@squire:privacytools.io
[m]
Yeah I guess I thought that as I could add Less to the CSS/Less box, I could use it in the classes field, but I suppose all the custom box is doing is appending its contents to the theme before anything is compiled. Is that right?
tomgreenfield
@tomgreenfield
yup
Guy Willis
@guywillis

Good morning @squire:privacytools.io

Whilst you cannot pass in LESS, as detailed by Tom, you could create a mixin (either in the theme itself or within the custom CSS/LESS textarea) that allows you to pass in a common and unique class to style up a plugin. For example, in the theme there is a block color mixin that showcases this concept - the common class applies the unique styling whilst the unique class defines the colour - https://github.com/adaptlearning/adapt-contrib-vanilla/blob/master/less/project/theme-extras.less#L158

Safwan Hossain
@safwanhossain92_twitter
Hi, How do i change the size of mcq boxes in adapt-contrib-vanilla theme?
Oliver Foster
@oliverfoster
Please only ask your question in one room @safwanhossain92_twitter
kylethrock
@kylethrock
I just upgrade the authoring tool to the latest version... Now my instance of the authoring tool is running very slow and it takes a long time to open courses and use the tool. I am looking to see if there is a fix for this or if anyone else has this same issue after an upgrade?
Francescasiquis
@Francescasiquis
Hello! I just upgrade the authoring tool to the latest version... but I cannot do anything, because the dashboard is empty! I only have the plugin settings! Please, can you help me to understand the problem!!!
MartinJuhler
@MartinJuhler

Hi I was wondering if anybody could help me with the scaling problem I get when adding a picture as header in the main menu. See gif. Here I used zoom but, it also happens if you change the size of the window.

Header problem.gif

Another question that I would like an answer to is how to change the Accordian so that when it expands, the users don't have to scroll back up as shown in the gif.

Accordian scrole back problem.gif

MartinJuhler
@MartinJuhler
I tried to figure out how to post these questions in the Technical forum, but I can't find an add new discussion button. Do I need permission to do this. If yes, how do I do that. Or has everything switched to this forum?
Simon Date
@simondate
@MartinJuhler I think you need to create an account to post on the forum. It's still used although not as watched as here
Simon Date
@simondate

Regarding the menu header image - I think it's something to do with the css value you are using for height/width. In v5 of Adapt we moved towards rem (root em) which is relative to the root size of the HTML element - https://www.sitepoint.com/understanding-and-using-rem-units-in-css/

Perhaps switch either to rem or something else to see if it fixes it

And for the accordion thing a setting doesn't exist. You could request it as a feature here - https://github.com/adaptlearning/adapt_framework/issues
2 replies
MartinJuhler
@MartinJuhler
Does there exist a plugin that allows teams to comment on each other's work... If not. What is the best practices out there for addressing this challenge?
3wc
@3-w-c

2020-10-24 @3-w-c
hi, I don't know if there are any docker fans in here, but I made some updates to the images pvadimir and @garyritchie made: https://github.com/3-w-c/docker-adaptauthoring :whale:

the main change is that you can now set up and deploy in one step, so it's more easily compatible with Docker "swarm mode". The way I automated the node install script feels a bit diabolical and I'd be very open to suggestions improving it.

Is anyone interested in working together to try and get this image / another image / some combination of images integrated into Adapt? :pray:

hiya folks, just wanted to check in whether there was any news on an official Adapt Authoring Docker set-up? I'm still running an instance of AAT using this set-up (via Co-op Cloud) and it's working fine – I'd still be very happy to help try and contribute this work to core if anyone is down

Chetan Sachdev
@cksachdev

Q. I have configured a 3 node mongodb cluster and tried to configure dbReplicaset in the configuration, but the settings are not clear. Below are the configuration values tried:

"dbName": "adapt-tenant-master",
  "useConnectionUri": true,
  "dbHost": "10.0.2.4",
  "dbPort": 27017,
  "dbUser": "",
  "dbPass": "",
  "dbConnectionUri": "mongodb://10.0.2.4:27017,10.0.2.14:27017,10.0.2.252:27017/adapt-tenant-master?replicaSet=mongo-rs",
  "dbAuthSource": "",

After updating these configuration, when I run node server connection isn't successful, I am able to ping all 3 nodes and able to telnet to 27017.

Safwan Hossain
@safwanhossain92_twitter
Q. Hello, Safwan here. After 100% completion, I want to provide the student with certification. how do I do that?
Safwan Hossain
@safwanhossain92_twitter
Also how do i turn off the Log window while previewing the course
Oliver Foster
@oliverfoster
certificates: usually an LMS thing
you could try https://github.com/cgkineo/adapt-certificate, i don't know if it still works or if you'd need to modify it
Safwan Hossain
@safwanhossain92_twitter
Thank you, one more thing, How can I show " % completition" on my course?
Oliver Foster
@oliverfoster
You have to write some code. Each model has a Boolean _isComplete property, you'd have to do the math.
Chetan Sachdev
@cksachdev
@moloko @oliverfoster Any suggestion on my query to dbReplicaset configuration
Oliver Foster
@oliverfoster
Hi Chetan, @moloko has left to try something different. Hopefully he'll come back one day but he's no longer available for questions.
Chetan Sachdev
@cksachdev
@oliverfoster okay.. wishing him luck on the new job! He has been very helpful to the community.
the link you shared doesn't mention any configuration. is this something which I need to be modify in the Adapt Authoring?
Oliver Foster
@oliverfoster
replSetGetStatus?
The replica set stuff is way out of the scope of the Authoring Tool
It's a function of mongodb database whereby you can disribute database changes across many machines.
Chetan Sachdev
@cksachdev
okay.. I looked at the configuration of adapt authoring and there is a property to configure dbReplicaset. https://github.com/adaptlearning/adapt_authoring/wiki/Configuring-the-Authoring-Tool#database-options
adaptlearning/adapt_authoring#1978
The above 2 links show the property, but it isn't clear why its not allowing to connect. If I don't supply dbConnectionUri then it works fine
Safwan Hossain
@safwanhossain92_twitter
Hi there, I have been using adapt-certificate but it doesn't show certification after course completition.
Oliver Foster
@oliverfoster
@safwanhossain92_twitter you're in the wrong room, please go to adaptlearning/adapt_framework
migervais
@migervais
Hello community. I have installed Adapt authoring yesterday and all was fine until this morning. Now when I add a page, the Add Block and Add Component buttons are no longer available. Only the Add Article button is available. In the end, it's like if I can only have one black per article and one component per block. Weird isn't it ?
tomgreenfield
@tomgreenfield
have you a screenshot?
migervais
@migervais
Yes wait a minute
image.png
tomgreenfield
@tomgreenfield
now that is interesting! i wouldn't expect an add component button because you already have one full-width. but the add block button has definitely gone walkabout