Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 09:43
    fkcailiniyazi edited #186
  • 09:42
    fkcailiniyazi labeled #186
  • 09:37
    fkcailiniyazi opened #186
  • May 16 13:11
    fkcailiniyazi opened #185
  • May 16 12:56
    fkcailiniyazi edited #184
  • May 16 12:56
    fkcailiniyazi opened #184
  • May 16 12:27
    taylortom closed #170
  • May 06 18:58

    taylortom on master

    Update assets container styling Add ContentPane ready event Delay init to after contentPane… (compare)

  • May 05 17:34

    taylortom on master

    Add query route config from Abs… (compare)

  • May 05 16:23

    taylortom on master

    Change output folder name (compare)

  • May 05 16:03

    taylortom on master

    Update to new attribute name (compare)

  • May 05 16:02

    taylortom on master

    Change output dir name (compare)

  • May 05 16:02

    taylortom on master

    Fix issue with changing attribu… (compare)

  • May 05 15:17

    taylortom on master

    Change output dir name (compare)

  • May 05 14:27

    taylortom on master

    Remove log (compare)

  • May 05 14:26

    taylortom on master

    Remove repitition of standard c… (compare)

  • May 05 14:26

    taylortom on master

    Make page title configurable (compare)

  • May 05 13:58

    taylortom on master

    Remove license declaration (compare)

  • May 05 13:57

    taylortom on master

    Add doc comments (compare)

  • May 05 12:53

    taylortom on master

    Switch to class doc tags (compare)

Tom Taylor
@taylortom
@fkcailiniyazi can confirm it's broken, request hangs until timeout for me. Might not be worth fixing for v1.0.0 as it's a new feature anyway
Ailiniyazi Maimaiti
@fkcailiniyazi
Should I create new issue for it?
Tom Taylor
@taylortom
yes please
Ailiniyazi Maimaiti
@fkcailiniyazi
:thumbsup:
Tom Taylor
@taylortom
Afternoon @/all! Meeting today at 3pm BST at the usual link: https://meet.google.com/nky-eutq-duf
Tom Taylor
@taylortom
@fkcailiniyazi I've added a page on the testing site to view server logs, which should help with testing/debugging :smile_cat: https://testing.kineoadapt.com/logs
newest logs are at the top, and the page refreshes every 5 secs
Ailiniyazi Maimaiti
@fkcailiniyazi
@taylortom great tom!
Kristoffer
@KristofferBroberg
@taylortom is the test server open for everyone interested?
Also, I'd like to (once again) to do a local install. Anyone has a "primer" on how to start clean? Done plenty of both successful and failed installs in the past...should I uninstall/flush mongodb? Remove/uninstall anything?
Tom Taylor
@taylortom
@fkcailiniyazi I've just run through the installer on windows, and everything worked fine for me :unamused: what errors were you getting?
Tom Taylor
@taylortom

@KristofferBroberg that would be much appreciated :heart_eyes:

To do a clean install, all you need to do is make sure you're installing into a new folder (which will give you a fresh copy of the source code), and specify a new database name during configuration (e.g. mongodb://localhost:27017/my-new-db) - you can also drop the DB first and use that name instead

Ailiniyazi Maimaiti
@fkcailiniyazi
After the reinstallation of Visual Studio, I finally installed authoring tool
Tom Taylor
@taylortom
oh great :smile: do you have any idea what the problem was?
Ailiniyazi Maimaiti
@fkcailiniyazi
I don't know exactly, but I followed the steps from this link to install node-gyp and Visual C++ Build Environment then restart my PC then it works:
https://github.com/nodejs/node-gyp#on-windows
Tom Taylor
@taylortom
ah ok, interesting
I wonder if we need to include some notes about that in the install instructions
Ailiniyazi Maimaiti
@fkcailiniyazi
I don't know if others have the same problem.
Kristoffer
@KristofferBroberg
Could someone shed some light on the config part of the installation; what's the difference between listening port and server URL? Let's say I define port to 8080, the URL should read localhost:8080?
Ailiniyazi Maimaiti
@fkcailiniyazi
server URL is localhost
then URI will be http://localhost:8080
Kristoffer
@KristofferBroberg
Skärmavbild 2022-04-20 kl. 10.33.51.png
Ailiniyazi Maimaiti
@fkcailiniyazi
yeah
Kristoffer
@KristofferBroberg
OK
Ailiniyazi Maimaiti
@fkcailiniyazi
I forgot to add http:// to the uri then I got error
Kristoffer
@KristofferBroberg
Just had to make sure :)
Ailiniyazi Maimaiti
@fkcailiniyazi
Sure
Tom Taylor
@taylortom

Hi @KristofferBroberg, yeah as @fkcailiniyazi the url will be the host + port unless custom config's been set up so the site points to a custom domain.

If anyone has any recommendations for areas of the installer/config that we could explain better, do shout

canstudios-nicolaw
@canstudios-nicolaw
@taylortom is it expected that the kineo testing server doesn't send password reset emails at present? A member of our QA team has just asked me, and I notice error server {"code":"ENDPOINT_NOT_FOUND","statusCode":404,"meta":{"description":"API endpoint does not exist","data":{"endpoint":"The missing endpoint"}},"data":{"endpoint":"/api/createtoken"}} in the server logs which seems relevant
Tom Taylor
@taylortom
@canstudios-nicolaw it is expected, as the server doesn't have email set up, but that is still an issue (looks like I've not updated the code to use the new API endpoint)
canstudios-nicolaw
@canstudios-nicolaw
OK thanks :) I asked our QA to raise it as an API issue in github
Tom Taylor
@taylortom
Thanks :smiley_cat:
canstudios-nicolaw
@canstudios-nicolaw
@taylortom are you currently updating the server at all? QA have told me they are getting a lot of 503 errors at the moment and they aren't sure if it is a result of what they are doing or whether anything else is going on
Tom Taylor
@taylortom
No haven't updated all week, that's worrying...
:crying_cat_face:
canstudios-nicolaw
@canstudios-nicolaw
OK I'll ask QA to document what they were doing
Tom Taylor
@taylortom
Thanks! It's a pretty slow server, but haven't seen that error myself
Tom Taylor
@taylortom
Afternoon @/all, just as an FYI Kirsty Hames will be joining us on the call today to present some UI findings. Anyone interested, please swing by at 3pm :smile_cat:
canstudios-nicolaw
@canstudios-nicolaw
Please could you share the google room link? :)
Pete Smith
@kineopete
hey @canstudios-nicolaw it's this one - https://meet.google.com/nky-eutq-duf
Tom Taylor
@taylortom
Afternoon @/all, here's the link to the UI feedback form https://forms.office.com/r/s7hzxssLSy
We'd appreciate any feedback you can provide :smile_cat:
Tom Taylor
@taylortom
Good afternoon @/all :sunglasses: catch-up at 3pm BST today for anyone who's available
Tom Taylor
@taylortom
btw, link will be the usual: https://meet.google.com/nky-eutq-duf
Pete Smith
@kineopete
Hey folks, as trailed at the last meeting Tom's on holiday this week so, unless anyone has anything urgent to raise, let's skip this week's AAT catch-up
Chetan Sachdev
@cksachdev
👍
canstudios-nicolaw
@canstudios-nicolaw
:thumbsup:
Tom Taylor
@taylortom
Afternoon @/all, meeting @3pm BST for anyone who's about
Ailiniyazi Maimaiti
@fkcailiniyazi
:thumbsup:
Ailiniyazi Maimaiti
@fkcailiniyazi
Is the version on the test server up to date?
I got a strange behavior on the testing server and locally it doesn't happen.