Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 31 2019 17:23
    brian-learningpool opened #46
  • Jan 07 2019 17:33

    brian-learningpool on update-xapiwrapper.js

    Corrects issue with SHA256 calc… (compare)

  • Jan 03 2019 15:29

    brian-learningpool on update-xapiwrapper.js

    Proper handling of binary attac… (compare)

  • Nov 20 2018 13:12
    brian-learningpool commented #42
  • Nov 20 2018 13:12
    brian-learningpool commented #43
  • Nov 20 2018 13:12
    brian-learningpool closed #43
  • Nov 20 2018 13:03

    brian-learningpool on v0.5.1

    (compare)

  • Nov 20 2018 13:02

    brian-learningpool on master

    Version bump to 0.5.1 for patch… (compare)

  • Nov 20 2018 13:01

    brian-learningpool on master

    Issue/6 (#44) * Set offline st… (compare)

  • Nov 20 2018 13:01
    brian-learningpool closed #44
  • Nov 19 2018 09:55
    danielstorey synchronize #44
  • Nov 19 2018 09:24
    danielstorey synchronize #44
  • Nov 16 2018 14:39
    danielstorey synchronize #44
  • Nov 16 2018 14:33
    danielstorey synchronize #44
  • Nov 16 2018 14:32
    danielstorey commented #43
  • Nov 16 2018 14:28
    danielstorey synchronize #44
  • Nov 16 2018 12:03

    brian-learningpool on 33

    (compare)

  • Nov 16 2018 12:03

    brian-learningpool on #2149

    (compare)

  • Nov 16 2018 12:03

    brian-learningpool on #2149

    (compare)

  • Nov 16 2018 12:02

    brian-learningpool on #2149

    (compare)

Brian Quinn
@brian-learningpool
Does anyone have any experience of adding verbs or extensions to the Tin Can registry?
I've tried registering but never received the confirmation email, so can't sign in
The reason I'm asking is because it would be good to get something like http://id.tincanapi.com/extension/assessment-id added (per adaptlearning/adapt-contrib-xapi#77)
Oliver Foster
@oliverfoster
I don't. It sounds frustrating again...
Not a good look.
Brian Quinn
@brian-learningpool
Does anyone from Rustici ever lurk around here?
Brian Quinn
@brian-learningpool
Hi guys, I've actually been talking to Chris from Rustici and I get the impression he's not keen to add something as discussed on adaptlearning/adapt-contrib-xapi#80 to the TinCan registry
Any thoughts on whether it's time to expose Adapt specific xAPI resources?
Oliver Foster
@oliverfoster
should be pretty easy with the adaptlearning.github.io site
Dan Gray
@dancgray
We are getting a number of instances on xAPI courses where it appears that the learner has passed the course but no course passed statement is sent to the LRS. Correct assessment statement and all session state statements are sent OK.
Anyone else had this problem?
Brian Quinn
@brian-learningpool
I haven't noticed that, Dan
which LRS are you using?
how is _completionCriteria set in config.json?
if _requireContentCompleted: true is it possible that some content is being missed?
Dan Gray
@dancgray
Ha, our own :(
"_requireContentCompleted": false,
"_requireAssessmentCompleted": true
Brian Quinn
@brian-learningpool
are you certain the statements aren't being sent? I.e. you're not seeing them sent in the Network panel when you use the browser's debug tools
Dan Gray
@dancgray
TBH, I have not been able to reproduce, but we seem to get a consistent but very small number of learners reporting this. All their other statements and session data seems to back them up.
Brian Quinn
@brian-learningpool
is there any commonality, e.g. browser version, mobile, etc.? Here's the code responsible for sending completion statements: https://github.com/adaptlearning/adapt-contrib-xapi/blob/master/js/adapt-contrib-xapi.js#L974-L1010
Matt Leathes
@moloko

we seem to get a consistent but very small number of learners reporting this. All their other statements and session data seems to back them up.

Man, I hate having to deal with these! I feel for you, @dancgray

Dan Gray
@dancgray
:) Thanks, IE 11 and courses with banks seem to be the only commonality, probably on return after partial completion. Will try and get a reproducable example.
Brian Quinn
@brian-learningpool
?
partial completion would have been a factor there
Matt Leathes
@moloko
fixed in FW v3.5.3 & v4.1.1 if that helps
Dan Gray
@dancgray
Using FW v4.3.0 :+1:
Brian Quinn
@brian-learningpool
and Assessment v3.1.0 or greater?
Dan Gray
@dancgray
Yep assessment v3.1.0
Brian Quinn
@brian-learningpool
off the top of my head that covers the known issues which might have been a factor here
by "consistent" did you mean that it's happening the same learners all the time, or just that it's happening frequently?
Dan Gray
@dancgray
The learners it is happening to can complete other courses, so just more frequent.
Thanks for your help, will try and get a reproducible example.
When I do I’ll probably be looking at the code in the two defers on assessment and xAPI
Brian Quinn
@brian-learningpool
that would be a good place to look :+1:
rschweigert
@rschweigert_gitlab
Hello, I try to launch the default example adapt-course with adapt-contrib-xapi and the adl-xapi-launch-server. Despite I've replaced the xapiwrapper.min.js of the server with the most recent one (v1.11.0), I get an error: https://pastebin.com/rDkhHnBD . Any ideas?
Matt Leathes
@moloko
what version of adapt-contrib-xapi are you using?
and by adl-xapi-launch-server, do you mean https://github.com/adlnet/xapi-launch ?
rschweigert
@rschweigert_gitlab
adapt-contrib-xapi v0.8.1 and yes, this xapi-launch-server you mentioned
Matt Leathes
@moloko
hmm
there's no reference at all to _launchMethod in either repository
FYI the xapi-launch repo hasn't been updated since Nov 2016 as is marked as 'archived'
rschweigert
@rschweigert_gitlab
I know. That's why I replaced the original xapiwrapper with the most current one from https://github.com/adlnet/xAPIWrapper
rschweigert
@rschweigert_gitlab
It looks like, other parts of the server are also outdated. Too bad.
rschweigert
@rschweigert_gitlab
I should mention, that I try to connect to a Learning Locker LRS (v6.0.3). I got no error messages from the adapt xapi-extension during launch, but the course stucks at the loading-animation. I also tried the adapt-alt-xapi extension. With this extension I successfully managed to launch the course with the basic authentication method and send statements to LL (which with adabt-contrib-xapi also fails). But the developer mentioned problems with his extension and LLv2 (statements are not recognized by LL). Probably the error is not caused by adapt but LL?
rschweigert
@rschweigert_gitlab
tried to start the course in SCORM Cloud: same result !?
Brian Quinn
@brian-learningpool
Hi @rschweigert_gitlab, the adapt-contrib-xapi extension definitely works with Learning Locker
and with SCORM Cloud
I can't vouch for the xapi-launch server, it's been some time since I looked at it but I'd imagine it should still work
I'm not sure what impact dropping in different versions of dependencies would have
is it possible you have the remnants of another xAPI extension in your content?
_launchMethod is defined in https://github.com/Acutilis/adapt-alt-xAPI
rschweigert
@rschweigert_gitlab
Hi @brian-learningpool I aggree with you. I think , I did something wrong. At least Scorm cloud should work (tested it successfully some month ago). I will check my setup and try it again. Thanks so far and have a nice week end!
Brian Quinn
@brian-learningpool
No problem, same to you :+1: