These are chat archives for adempiere/adempiere/es

8th
Nov 2017
Helio Gutierrez
@heliogutierrez
Nov 08 2017 16:41
Buen día, tengo un proyecto en Adempiere que ocupa incluir el jar commons-codec-1.4.jar y ya reemplacé los jars anteriores que existían y compila y corre muy bien pero al llegar a la línea que necesita de la nueva versión del jar marca error, como que está tomando la versión anterior pero no sé como hacer que tome primero el jar nuevo, alguna sugerencia?
Yamel Senih
@yamelsenih
Nov 08 2017 16:47
Hola @heliogutierrez como te va?
que bueno que escribes por aqui
ese error te da en el ZK o Swing
?
Helio Gutierrez
@heliogutierrez
Nov 08 2017 16:48
uso ZK, el proyecto es en zkwebui
buen día Yamel
Helio Gutierrez
@heliogutierrez
Nov 08 2017 16:57
imagen.png
así configuré el build pero creo que ese sólo sirve para compilar y no para tiempo de ejecución
John Agudelo
@jdaison
Nov 08 2017 17:26
@developers02 aqui está el link con las instrucciones http://wiki.adempiere.net/LCO_Instrucciones_Instalacion
Yamel Senih
@yamelsenih
Nov 08 2017 17:51
@heliogutierrez aquí se guardan unas libs /adempiere/jboss/lib
es probable que aún cuando las agregas al otro directorio las esté sobrescribiendo con la principal
Helio Gutierrez
@heliogutierrez
Nov 08 2017 18:10
@yamelsenih efectivamente, busqué todo los archivos que contenían Base64.class y si me salieron varios jars commons-codec de varias versiones las cuales ya reemplacé con la versión 1.4, después encontré que las librerías en Adempiere\lib: CCTools.jar, CSTools.jar, AdempiereCLib.jar y AdempiereSLib.jar también internamente contenían otra versión, y encontré que tools\build.xml construye CCTools y CSTools, pero no sé en dónde se construyen las otras 2, no pensé que tuviera tantas versiones del mismo
Yamel Senih
@yamelsenih
Nov 08 2017 18:12
has probado cambiarlo en la ruta /adempiere/jboss/lib?
Helio Gutierrez
@heliogutierrez
Nov 08 2017 18:14
Así es mira ya puse mi librería reemplazando las existentes en estas ubicaciones: db\ddlutils\lib, ServerApps\lib, jboss\lib, jboss\server\lib, yools\lib, zkwebui\WEB-INF\lib
pero no encuentro el classpath para el tiempo de ejecución y conocer cual librería está tomando primero porque al parecer se encuentra en muchos lados la librería commons-codec
Mario Calderon
@marcalwestf
Nov 08 2017 18:48
Hola @heliogutierrez Creo que respondí en el otro chat desconociendo éste
Helio Gutierrez
@heliogutierrez
Nov 08 2017 18:51
Que tal @marcalwestf sí también expuse mi problema en el chat en inglés
imagen.png
Mario Calderon
@marcalwestf
Nov 08 2017 18:53
Bienvenido a los foros de Adempiere. Si, lo vi... Muchas veces sucede que Eclipse funciona y la instalación no
Helio Gutierrez
@heliogutierrez
Nov 08 2017 21:19
@marcalwestf hay alguna manera de apuntar a la clase determinada o conigurar el classpath?
Mario Calderon
@marcalwestf
Nov 08 2017 21:36
mmmh yo lo he hecho siempre desde la IDE. Supongo que puedes correr RUN_Adempiere.sh con el paquete en los parámetros, pero ignoro si funcione.