Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 26 16:24
    EdwinBetanc0urt opened #3709
  • Jan 25 21:03
    e-Evolution synchronize #3694
  • Jan 25 19:52
    e-Evolution review_requested #3708
  • Jan 25 19:52
    e-Evolution review_requested #3708
  • Jan 25 19:52
    e-Evolution milestoned #3708
  • Jan 25 19:52
    e-Evolution review_requested #3708
  • Jan 25 19:52
    e-Evolution labeled #3708
  • Jan 25 19:52
    e-Evolution opened #3708
  • Jan 25 19:49
  • Jan 25 19:44
    eduardolopezuy labeled #3707
  • Jan 25 19:44
    eduardolopezuy assigned #3707
  • Jan 25 19:42
    rcapecce opened #3707
  • Jan 24 22:24
    e-Evolution synchronize #3694
  • Jan 24 22:16
    e-Evolution synchronize #3694
  • Jan 24 22:12
    e-Evolution review_requested #3706
  • Jan 24 22:12
    e-Evolution review_requested #3706
  • Jan 24 22:12
    e-Evolution milestoned #3706
  • Jan 24 22:12
    e-Evolution review_requested #3706
  • Jan 24 22:12
    e-Evolution labeled #3706
  • Jan 24 22:12
    e-Evolution labeled #3706
DulipKumara
@DulipKumara
set CLASSPATH
Set JAVA_HOME as C:\Program Files\Java\jdk1.8.0_211
Set JRE_HOME as C:\Program Files\Java\jre1.8.0_211
Set POSTGRES_HOME as C:\Program Files\PostgreSQL\12
After that run RUN_setup.bat in adempiere file and did setting in database server as follow
DulipKumara
@DulipKumara
database local server - localhost
database name - adempiere
data base user - adempiere
Data base type - postgresql
Data base port - 5432
DB admin password - postgres
data base password - default password
and Run_setup.dat was done successfully.
facing issue in import data - RUN_ImportAdempiere.bat is not working
DulipKumara
@DulipKumara
please check and advice
fincencius hasti mahardhika
@FincenciusHastiMahardhika333
For Adempiere Creator, Thank you Sir , you are Amazing
Michael McKay
@mckayERP
@DulipKumara can you share the error you are getting from RUN_ImportAdempiere?
Sanoop K
@sksanoopz
image.png
@all Is it possible to map direct JSP pages in Adempiere Form Window ? Currently I am using Adempiere Ver 3.9.0
DulipKumara
@DulipKumara
Dear Mr.Michael , yes it was happening when clicking RUN_ImportAdempiere.bat in utils folder.when clicking that bat file do not open any command window or any error . i am trying to run adempiere on windows 10 . i have tried on adempiere 380 and 393.in the both version couldn't run RUN_ImportAdempiere.bat.
fincencius hasti mahardhika
@FincenciusHastiMahardhika333
Dear Mr.Michael , can we use jboss wildfly 10.1 for replaced jboss AS for adempiere?
DulipKumara
@DulipKumara
Much appreciated your support to sot out
DulipKumara
@DulipKumara
Dear Mr.Michael , it is sorted out.I copied RUN_ImportAdempiere.dat file of adempiere version 3.0 into adempirere version 393 . then its working
Michael McKay
@mckayERP
@DulipKumara glad to hear it. I always run the bat files in powershell or a cmd window.
@FincenciusHastiMahardhika333 replacing Jboss would be challenging. If you are using the web interface, consider using the tomcat server instead. Jboss only makes sense if you need to use the swing client.
fincencius hasti mahardhika
@FincenciusHastiMahardhika333
Thank You Mr. Michael McKay for your advice
DulipKumara
@DulipKumara
hi can some one say how to import/restore postgre data bakup.
1 reply
backup file with custom file type.
using command line in windows
Sanoop K
@sksanoopz

Hai @All
We were using ADempiere 3.9.0 with some customised columns in the production.

As part of upgrade to 3.9.3, We have followed the steps mentioned in the http://wiki.adempiere.io/Migrate. We have used Migration Tool.

From the reading what I understood is

  1. Keep the Reference database as ADempiere 3.9.3 Seed
  2. Keep our current production database as Target
  3. Run 'Start Migration'

The process took 4.5 hours to completed in my 8GB RAM PC and generated 9792 errors and 1851 warnings.

While trying logging to the migrated production database to see the complete errors, we identified that certain columns we created in AD_Role is removed from that table(But AD_Column of the same table still exists).
The 'Migration' window is not recorded any errors.

The below is my doubts:

  1. Using Migration Tool, Can I migrate the production database 3.9.0 to directly 3.9.3?
  2. Why the migration tool is removing the columns from the AD_Role table?
  3. In case more columns are removed, how do we track those columns?
  4. How do we get the the error list(9792)? (While clicking on the View Errors Button - we are getting only 500 errors - in our case that was related to the add/drop constraints)
  5. Is there any another way to improve the speed of migration process?
MicrosoftTeams-image (41).png
sajeev
@sajeevsahadev
@sksanoopz I had tried this before - but could not make it happen from 3.9.0 to 3.9.3. I think the custom columns that I created in 3.9.0 will make some issues while migrating database. I had got around 5000+ errors that time. Some one else may can help you here.
e-Evolution
@e-Evolution
@sksanoopz HI , I migrated in past and I had the problems with the errors, but this issue with postgresql configuration
is necessary to custom the parameters, the ADempiere Migration Tools use intensively the DDL to recreate all database
e-Evolution
@e-Evolution

On the other hand, for custom fields, they must be identified with their own entity or the customization entity so that the migration tool does not delete them, if your new fields in the window have the Dictionary entity, they will be overwritten or not migrated.

In other words, the migration tool is based on any definition in the application dictionary and only migrates those that are correctly identified.

On the other hand, if you have modified any component of the application dictionary, this change generates a history which should be marked as customization, since the tool at the end of the migration takes all the historical changes and applies those that were marked as customization

Prapon-VDevSoft
@PraponVDevSoft
Yes, After trying many times I just understand,
Makes the migration from version 3.7x to version 3.9x have a lot easier.
@e-Evolution @sajeevsahadev
e-Evolution
@e-Evolution
@sksanoopz about the problem of gen_random_uuid ()
do you need check that have the right PostgreSQL versiĆ³n.
So I think that you are using an obsolete postgresql version
Sanoop K
@sksanoopz
@e-Evolution Thanks for the replay. Currently I am using Postgres Version 9.6. But I am not able to execute this function.
e-Evolution
@e-Evolution
is very old
adempiere 3.9.3 use pg 12
Sanoop K
@sksanoopz
@e-Evolution Ok Sir Now its working fine. Thank You
fincencius hasti mahardhika
@FincenciusHastiMahardhika333
Screenshot from 2020-12-16 14-58-10.png
Thank You Mr. @mckayERP , Its Work for me
I'm Use Ubuntu 20.04 Focal Forsa
I'm use postgresql-12
fincencius hasti mahardhika
@FincenciusHastiMahardhika333
I'm Use Adempiere new version 3.9.3
for Transfer database I use navicat