Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 26 00:24
    yamelsenih assigned #3571
  • Nov 26 00:24
    yamelsenih commented #3571
  • Nov 26 00:23
    yamelsenih synchronize #3571
  • Nov 26 00:23
    yamelsenih synchronize #3571
  • Nov 25 08:01
    bmagoha starred adempiere/adempiere
  • Nov 24 20:41
    rcapecce commented #3571
  • Nov 24 09:25
    MichaelLud1AI starred adempiere/adempiere
  • Nov 23 17:55
    e-Evolution synchronize #3694
  • Nov 23 17:46
    e-Evolution synchronize #3694
  • Nov 23 13:56
    SusanneCalderon commented #3691
  • Nov 23 12:54
  • Nov 23 09:44
    e-Evolution synchronize #3694
  • Nov 23 04:34
    e-Evolution synchronize #3694
  • Nov 23 02:51
    e-Evolution synchronize #3694
  • Nov 22 23:42
    SusanneCalderon milestoned #3695
  • Nov 22 23:42
    SusanneCalderon labeled #3695
  • Nov 22 23:42
    SusanneCalderon labeled #3695
  • Nov 22 23:42
    SusanneCalderon labeled #3695
  • Nov 22 23:42
    SusanneCalderon opened #3695
  • Nov 22 23:21
    e-Evolution synchronize #3694
DulipKumara
@DulipKumara
hi can some one say how to import/restore postgre data bakup.
1 reply
backup file with custom file type.
using command line in windows
Sanoop K
@sksanoopz

Hai @All
We were using ADempiere 3.9.0 with some customised columns in the production.

As part of upgrade to 3.9.3, We have followed the steps mentioned in the http://wiki.adempiere.io/Migrate. We have used Migration Tool.

From the reading what I understood is

  1. Keep the Reference database as ADempiere 3.9.3 Seed
  2. Keep our current production database as Target
  3. Run 'Start Migration'

The process took 4.5 hours to completed in my 8GB RAM PC and generated 9792 errors and 1851 warnings.

While trying logging to the migrated production database to see the complete errors, we identified that certain columns we created in AD_Role is removed from that table(But AD_Column of the same table still exists).
The 'Migration' window is not recorded any errors.

The below is my doubts:

  1. Using Migration Tool, Can I migrate the production database 3.9.0 to directly 3.9.3?
  2. Why the migration tool is removing the columns from the AD_Role table?
  3. In case more columns are removed, how do we track those columns?
  4. How do we get the the error list(9792)? (While clicking on the View Errors Button - we are getting only 500 errors - in our case that was related to the add/drop constraints)
  5. Is there any another way to improve the speed of migration process?
MicrosoftTeams-image (41).png
sajeev
@sajeevsahadev
@sksanoopz I had tried this before - but could not make it happen from 3.9.0 to 3.9.3. I think the custom columns that I created in 3.9.0 will make some issues while migrating database. I had got around 5000+ errors that time. Some one else may can help you here.
e-Evolution
@e-Evolution
@sksanoopz HI , I migrated in past and I had the problems with the errors, but this issue with postgresql configuration
is necessary to custom the parameters, the ADempiere Migration Tools use intensively the DDL to recreate all database
e-Evolution
@e-Evolution

On the other hand, for custom fields, they must be identified with their own entity or the customization entity so that the migration tool does not delete them, if your new fields in the window have the Dictionary entity, they will be overwritten or not migrated.

In other words, the migration tool is based on any definition in the application dictionary and only migrates those that are correctly identified.

On the other hand, if you have modified any component of the application dictionary, this change generates a history which should be marked as customization, since the tool at the end of the migration takes all the historical changes and applies those that were marked as customization

Prapon-VDevSoft
@PraponVDevSoft
Yes, After trying many times I just understand,
Makes the migration from version 3.7x to version 3.9x have a lot easier.
@e-Evolution @sajeevsahadev
e-Evolution
@e-Evolution
@sksanoopz about the problem of gen_random_uuid ()
do you need check that have the right PostgreSQL versiĆ³n.
So I think that you are using an obsolete postgresql version
Sanoop K
@sksanoopz
@e-Evolution Thanks for the replay. Currently I am using Postgres Version 9.6. But I am not able to execute this function.
e-Evolution
@e-Evolution
is very old
adempiere 3.9.3 use pg 12
Sanoop K
@sksanoopz
@e-Evolution Ok Sir Now its working fine. Thank You
fincencius hasti mahardhika
@FincenciusHastiMahardhika333
Screenshot from 2020-12-16 14-58-10.png
Thank You Mr. @mckayERP , Its Work for me
I'm Use Ubuntu 20.04 Focal Forsa
I'm use postgresql-12
fincencius hasti mahardhika
@FincenciusHastiMahardhika333
I'm Use Adempiere new version 3.9.3
for Transfer database I use navicat
fincencius hasti mahardhika
@FincenciusHastiMahardhika333
Thank You Mr. @e-Evolution , you are very nice and Amazing
DulipKumara
@DulipKumara
Dear Mr.Michael, Which method is support on windows for Adempiere webui . whether jboss or tomcat ?
Michael McKay
@mckayERP
@DulipKumara Either will work well. Jboss is required to use Swing. Both serve the webui. Tomcat is a better choice if you don't need the Swing UI.
e-Evolution
@e-Evolution
@mckayERP do you finish with refactory to update testing env?
pmdw
@pmdw
image.png

Hi to all. I am getting a (re)posting error when using Adempiere 3.9.3

Under the menu
Performance Analysis

  • Accounting Rules
    -- Unposted Documents

I get the above error when re-posting.

BTW when using the java UI the data does not display when you switch from row to grid mode. but it does in the web interface.
adaxa-steven
@adaxa-steven
@mckayERP .. Hi Mike, re "Jboss is required to use Swing". I thought I had seen swing working with Tomcat so asked and was told the following. I assume it is still the case I pass on in case relevant to someone. I can't remember when I last used the Swing client!
"Auto-configuration doesn't work.
The swing client used EJBs to pull the database configuration from the server if available.
You can manually supply the database host/user/password or provide a properties file."
e-Evolution
@e-Evolution
@/all Somebody have the Adempeire French translation ?
DulipKumara
@DulipKumara
Dear Mr Michael , (pgsql - 9.6 , Adempiere 3.7 , Java -jdk1.6.0_45 and win10 64) I have run RUN_setup.bat and done Jboss and other configuration successfully.Then run RUN_Server2.bat.Then getting some errors as follows
DulipKumara
@DulipKumara
21:26:01.075 Adempiere.startup: ADempiere(r) Release 3.7.0LTS_2011-09-01 -Smart Suite ERP,CRM and SCM- (c) 1999-2011 ADempiere(r); Implementation: ${ADEMPIERE_VERSION} 20201222-2035 - ${ADEMPIERE_VENDOR}
21:26:01,075 ERROR [STDERR] 21:26:01.075 Ini.loadProperties: C:\Adempiere\Adempiere.properties #29
21:26:01,075 INFO [STDOUT] 21:26:01.075 Ini.loadProperties: C:\Adempiere\Adempiere.properties #29
21:26:01,501 ERROR [STDERR] [INFO] MLog clients using com.mchange.v2.log.FallbackMLog logging.
21:26:01,575 ERROR [STDERR] [INFO] Initializing c3p0-0.9.1.2 [built 21-May-2007 15:04:56; debug? true; trace: 10]
21:26:01,636 ERROR [STDERR] [INFO] Initializing c3p0 pool... com.mchange.v2.c3p0.ComboPooledDataSource [ acquireIncrement -> 3, acquireRetryAttempts -> 2, acquireRetryDelay -> 1000, autoCommitOnClose -> false, automaticTestTable -> null, breakAfterAcquireFailure -> false, checkoutTimeout -> 0, connectionCustomizerClassName -> null, connectionTesterClassName -> com.mchange.v2.c3p0.impl.DefaultConnectionTester, dataSourceName -> AdempiereDS, debugUnreturnedConnectionStackTraces -> false, description -> null, driverClass -> org.postgresql.Driver, factoryClassLocation -> null, forceIgnoreUnresolvedTransactions -> false, identityToken -> 1hge0ysae12m2poo12jtaxl|6c408893, idleConnectionTestPeriod -> 1200, initialPoolSize -> 10, jdbcUrl -> jdbc:postgresql://localhost:5432/adempiere?encoding=UNICODE, maxAdministrativeTaskTime -> 0, maxConnectionAge -> 0, maxIdleTime -> 1200, maxIdleTimeExcessConnections -> 1200, maxPoolSize -> 150, maxStatements -> 0, maxStatementsPerConnection -> 0, minPoolSize -> 5, numHelperThreads -> 3, numThreadsAwaitingCheckoutDefaultUser -> 0, preferredTestQuery -> SELECT Version FROM AD_System, properties -> {user=**, password=**}, propertyCycle -> 0, testConnectionOnCheckin -> false, testConnectionOnCheckout -> false, unreturnedConnectionTimeout -> 0, usesTraditionalReflectiveProxies -> false ]
21:26:05,868 ERROR [STDERR] -----------> EMail.setFrom: you @ company.org: javax.mail.internet.AddressException: Local address contains control or whitespace in string you @ company.org'' 21:26:22,282 ERROR [STDERR] -----------> EMail.setFrom: you @ company.org: javax.mail.internet.AddressException: Local address contains control or whitespace in stringyou @ company.org''
21:26:22,313 ERROR [STDERR] -----------> EMail.addTo: you @ company.org: javax.mail.internet.AddressException: Local address contains control or whitespace in string you @ company.org'' 21:26:22,313 ERROR [STDERR] -----------> EMail.addTo: you @ company.org: javax.mail.internet.AddressException: Local address contains control or whitespace in stringyou @ company.org''
21:26:22,320 ERROR [STDERR] -----------> EMail.isValid: From is invalid=null
21:26:22,320 ERROR [STDERR] -----------> EMail.isValid: From is invalid=null
21:26:22,320 ERROR [STDERR] -----------> EMail.isValid: From is invalid=null
21:26:22,320 ERROR [STDERR] -----------> EMail.isValid: From is invalid=null
21:26:22,320 ERROR [STDERR] -----------> MClient.sendEMail: Could NOT Send Email: Server started: ? to you @ company.org: Invalid Data (System)
21:26:22,320 ERROR [STDERR] -----------> MClient.sendEMail: Could NOT Send Email: Server started: ? to you @ company.org: Invalid Data (System)
21:26:22,366 INFO [TomcatDeployer] deploy, ctxPath=/admin, warUrl=.../tmp/deploy/tmp4404726046388432674adempiereRoot-exp.war/
21:26:22,466 ERROR [STDERR] ===========> Env.getContextAsDate: No value for: #Date
21:26:23,300 ERROR [STDERR] ===========> Env.getContextAsDate: No value for: #Date
21:26:23,653 INFO [TomcatDeployer] deploy, ctxPath=/, warUrl=.../tmp/deploy/tmp7699319950556869042adempiereWebCM-exp.war/
21:26:23,800 INFO [TomcatDeployer] deploy, ctxPath=/wstore, warUrl=.../tmp/deploy/tmp3367259514947651127adempiereWebStore-exp.war/
21:26:24,170 INFO [TomcatDeployer] deploy, ctxPath=/posterita, warUrl=.../tmp/deploy/tmp4813214862736953972posterita-exp.war/
21:26:24,456 INFO [WebappClassLoader] validateJarFile(C:\Adempiere\jboss\server\adempiere.\tmp\deploy\tmp481321486
3 replies
] whereas object of type
21:26:24,703 ERROR [STDERR] log4j:ERROR "org.jboss.logging.appender.FileAppender" was loaded by [org.jboss.system.server.NoAnnotationURLClassLoader@55e859c0].
21:26:24,703 ERROR [STDERR] log4j:ERROR Could not instantiate appender named "FILE".
21:26:24,725 INFO [STDOUT] 21:26:24,725 INFO [ResponseOverrideFilter] Filter initialized. Response buffering is enabled
21:26:25,606 INFO [TomcatDeployer] deploy, ctxPath=/webui, warUrl=.../tmp/deploy/tmp9188822434367369747webui-exp.war/
21:26:27,707 INFO [EARDeployer] Started J2EE application: file:/C:/Adempiere/jboss/server/adempiere/deploy/adempiere.ear/
21:26:27,776 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-GFS-IT01%2F192.168.0.100-8080
21:26:27,792 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-8443
21:26:27,792 INFO [AjpProtocol] Starting Coyote AJP/1.3 on ajp-GFS-IT01%2F192.168.0.100-8009
21:26:27,807 INFO [Server] JBoss (MX MicroKernel) [4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181417)] Started in 1m:10s:819ms
21:27:01,094 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 120 , # Busy Connections: 120 , # Idle Connections: 0 , # Orphaned Connections: 0 [11]
21:27:01,095 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 120 , # Busy Connections: 120 , # Idle Connections: 0 , # Orphaned Connections: 0 [11]
21:27:01,144 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 121 , # Busy Connections: 121 , # Idle Connections: 0 , # Orphaned Connections: 0 [11]
21:27:01,144 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 121 , # Busy Connections: 121 , # Idle Connections: 0 , # Orphaned Connections: 0 [11]
21:27:01,190 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 122 , # Idle Connections: 0 , # Orphaned Connections: 0 [12]
21:27:01,191 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 120 , # Idle Connections: 2 , # Orphaned Connections: 0 [14]
21:27:01,191 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 122 , # Idle Connections: 0 , # Orphaned Connections: 0 [12]
21:27:01,195 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 122 , # Idle Connections: 1 , # Orphaned Connections: 0 [13]
21:27:01,201 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 120 , # Idle Connections: 2 , # Orphaned Connections: 0 [14]
21:27:01,201 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 122 , # Idle Connections: 0 , # Orphaned Connections: 0 [20]
21:27:01,202 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 122 , # Idle Connections: 1 , # Orphaned Connections: 0 [13]
21:27:01,203 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 122 , # Idle Connections: 0 , # Orphaned Connections: 0 [20]
21:27:01,203 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 122 , # Idle Connections: 0 , # Orphaned Connections: 0 [19]
21:27:01,210 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 122 , # Idle Connections: 0 , # Orphaned Connections: 0 [19]
21:27:01,210 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 122 , # Idle Connections: 0 , # Orphaned Connections: 0 [18]
21:27:01,220 ERROR [STDERR] -----------> DB_PostgreSQL.getCachedConnection: # Connections: 122 , # Busy Connections: 120 , # Idle Connections: 2 , # Orphaned Connections: 0 [17]
Do you have any idea that which settings need to be corrected.
Horacio
@piracio
What version of database and Adempiere you have, also is possible to get the md5 of the file $HOME/Adempiere/lib/postgresql.jar ?
Also check the number of connections that you have with the database base, something is not happy there.
DulipKumara
@DulipKumara
Hi @piracio pgsql - 9.6,Adempiere 3.7
Yes there is postgresql.jar file
max_connections = 1000 in postgresql.conf file
DulipKumara
@DulipKumara
But normal adempiere system (RUN_Adempiere.bat) can be run without any issues
Horacio
@piracio
the error message tells me is something to do with the database, perhaps is the jdbc version ?
DulipKumara
@DulipKumara
jdk1.6.0_45
BRSInfotek
@BRSInfotek
Assume connection busy of postgreSQL... restart Service for these from Control Panel of windows
Michael McKay
@mckayERP
@e-Evolution Hi Victor, no not done yet. When I removed the old unit libraries some old tests broke. I'm slowly upgrading them. It will take another week.
In the meantime check out code coverage tools for your ide if you don't have them. And sonar lint for code quality.
Together with the tests, these really help.
Michael McKay
@mckayERP
@adaxa-steven Hi Steve, the issue I had is with the name server. Tomcat does not provide a name server. Swing depends on it to communicate with the server. Also there is no web start with jnlp under tomcat.
Best wishes for the holiday season!