Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jul 24 01:30

    e-Evolution on develop

    Fix root source marked as test … Merge pull request #3579 from O… (compare)

  • Jul 24 01:30
    e-Evolution closed #3579
  • Jul 24 01:30
    e-Evolution milestoned #3579
  • Jul 24 01:30
    e-Evolution labeled #3579
  • Jul 24 01:30
    e-Evolution labeled #3579
  • Jul 24 01:30
    e-Evolution assigned #3579
  • Jul 23 21:51
    rcapecce opened #3579
  • Jul 23 17:29
    marcalwestf commented #3371
  • Jul 23 17:18
    marcalwestf commented #3371
  • Jul 23 16:13
    marcalwestf commented #3371
  • Jul 22 17:38
    e-Evolution closed #3541
  • Jul 22 17:38
    e-Evolution edited #3575
  • Jul 22 17:37
    e-Evolution assigned #3541
  • Jul 22 17:37
    e-Evolution milestoned #3541
  • Jul 22 17:35

    e-Evolution on develop

    Redmine #16410 Merge pull request #3575 from O… (compare)

  • Jul 22 17:35
    e-Evolution closed #3575
  • Jul 22 17:35
    e-Evolution edited #3575
  • Jul 22 17:30
    e-Evolution milestoned #3575
  • Jul 22 17:30
    e-Evolution labeled #3575
  • Jul 22 17:29
    e-Evolution labeled #3575
Michael McKay
@mckayERP
@DulipKumara Are you trying out the software or is that your production version? 3.7 is quite old.
@e-Evolution HI Victor, hope you had (are having) a good holiday. The pull request for the Junit 5 upgrade is ready. Apologies that it took so long - there were a lot of junit3/4 tests lurking about that had to be updated manually. Both unit and integration tests are working on my local copy and the unit tests pass on the travis builder.
e-Evolution
@e-Evolution
@DulipKumara , if you what use the server connectio with EJB , is necessary deployment using jboss
and need webstart if you what download the swing client from server
but my recomendation is use the webui client is more efficient that swing client
Horacio
@piracio
@DulipKumara the EJB may perform OK only if your database is close to the client, if the database and the client have more than 20 ms delay between them, will be slow. some tasks may take about 65 calls at SQL level and any latency will impact the performance response, having the WEB version, usually the database and AD application servers the latency is under 1ms (having both servers in the same datacenter ), that is is the reason, plus adding a cache layer (web server with mod_pagespeed on top ) will reduce the responses times.
DulipKumara
@DulipKumara
Hi Mr Michael - I am using below verssions now
Windows os - Windows 2016 Server
Postgresql- 12
Adempiere - 393 version
Java - jdk1.8.0_31
Adempiere client is working properly .
But can't run web client (computer andm:8080/webui or admin).
DulipKumara
@DulipKumara
When i was running RUN_Server2 file
getting below message 12:26:14,702 INFO [Server] Starting JBoss (MX MicroKernel)...
12:26:14,702 INFO [Server] Release ID: JBoss [Trinity] 4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181417)
12:26:14,702 INFO [Server] Home Dir: C:\Adempiere\jboss
12:26:14,702 INFO [Server] Home URL: file:/C:/Adempiere/jboss/
12:26:14,702 INFO [Server] Patch URL: null
12:26:14,702 INFO [Server] Server Name: adempiere
12:26:14,702 INFO [Server] Server Home Dir: C:\Adempiere\jboss\server\adempiere
12:26:14,702 INFO [Server] Server Home URL: file:/C:/Adempiere/jboss/server/adempiere/
12:26:14,702 INFO [Server] Server Log Dir: C:\Adempiere\jboss\server\adempiere\log
12:26:14,702 INFO [Server] Server Temp Dir: C:\Adempiere\jboss\server\adempiere\tmp
12:26:14,702 INFO [Server] Root Deployment Filename: jboss-service.xml
12:26:14,981 INFO [ServerInfo] Java version: 1.8.0_31,Oracle Corporation
12:26:14,981 INFO [ServerInfo] Java VM: Java HotSpot(TM) 64-Bit Server VM 25.31-b07,Oracle Corporation
12:26:14,981 INFO [ServerInfo] OS-System: Windows Server 2012 R2 6.3,amd64
12:26:15,382 INFO [Server] Core system initialized
12:26:16,856 INFO [WebService] Using RMI server codebase: http://WIN-UGN8QE11HPQ:8083/
12:26:16,856 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:jboss-log4j.xml
12:26:17,088 WARN [ServiceController] Problem starting service jboss:service=NamingBeanImpl
javax.naming.NoInitialContextException: Need to specify class name in environment or system property, or as an applet parameter, or in an application resource file: java.naming.factory.initial
in the lines can see
12:26:17,088 WARN [ServiceController] Problem starting service jboss:service=NamingBeanImpl
javax.naming.NoInitialContextException: Need to specify class name in environment or system property, or as an applet parameter, or in an application resource file: java.naming.factory.initial
DulipKumara
@DulipKumara
But bottom of the lines can see---
12:26:22,505 INFO [Server] JBoss (MX MicroKernel) [4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181417)] Started in 7s:803ms
But webui client doesn't work.How to fix this issue please help on this.
Horacio
@piracio
did you check the ports are open ? disable the firewall and check the application server.
DulipKumara
@DulipKumara
Hi .. I have checked 8080 is opened . But same issue.
Also checked with off Windows firewall . But same issue.
e-Evolution
@e-Evolution
@DulipKumara do you run RUN_ImportAdempiere.sh/bat
DulipKumara
@DulipKumara
Yes i done it..Normal adempiere client can be run without any issue.
this is happening when running RUN_Server2.bat file .
result of that i couldn't run adempiere webui option.
DulipKumara
@DulipKumara
i think there is an issue when running RUN_Server2.bat file on windows 2016.
Any one can say meaning of below message 12:26:17,088 WARN [ServiceController] Problem starting service jboss:service=NamingBeanImpl
javax.naming.NoInitialContextException: Need to specify class name in environment or system property, or as an applet parameter, or in an application resource file: java.naming.factory.initial
Horacio
@piracio
Check if you have something running on the port 8080.... netstat -na | findstr 8080
Marek Mosiewicz
@marekmosiewicz
@DulipKumara How do you start Adempiere ? Is it via RunServer2.bat in ADEMPIERE_HOME utils dir ?
e-Evolution
@e-Evolution
may be need some other config
Michael McKay
@mckayERP
@e-Evolution I responded to the comments - you need to configure the IDE to use the latest version of ant - 1.10.8 is what I have. JunitLauncher was added in 1.10.6.
e-Evolution
@e-Evolution
but the problem is that the project should be build from utils_dev/RUN_build.sh/bat and this faild
@mckayERP so I think you need update this library ./tools/lib/ant.jar
Michael McKay
@mckayERP
@e-Evolution Sorry Victor - I missed the necessary updates to the RUN_Build files. I just pushed an update to the pull request which add all the ANT libraries and fixes the RUN_Build scripts. The RUN_Build.bat and RUN_Build2.bat work on my machine. Can you test the .sh versions please?
pmdw
@pmdw

Hi All I am getting a proxy error and server not found for: http://www.adempiere.io/
502 proxy error Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /.

Reason: Error reading from remote server

1 reply
and for http://www.adempiere.net/
I get server not found
https://www.isitdownrightnow.com/adempiere.net.html
also reports the site is down.
pmdw
@pmdw

Hi All
I am trying to find out what changed in the Allocations in the update to Version: 3.9.3
Allocations created before the 3.9.3 update are giving problems.

Menu

  • Open Items
    -- View Allocations
    select allocation
    reset allocation direct

Result: delete #0

if voided:
ERROR: update or delete on table "fact_acct" violates foreign key constraint "factacct_factreconciliation" on table "fact_reconciliation"
Detail: Key (fact_acct_id)=(1004894) is still referenced from table "fact_reconciliation".

On the web UI it does not show the document type as allocation whereas on the java client it shows it.
When trying to void it on the web UI, the error given is: Fill in mandatory fields: Document Type
Any ideas what to check or how to fix this?
Thanks

Michael McKay
@mckayERP
@pmdw The link to the fact reconciliation is the issue. In the Performance Analysis section, you should see the Fact Reconciliation (manual) window. Use it to find the reconciled entries for that allocation and unreconcile them. Then you should be able to delete the allocation. Someone likely performed an automatic or manual reconciliation on that record in the past. When you search for the reconciled records, you should be able to see when.
pmdw
@pmdw
@mckayERP Thanks I will try this.
pmdw
@pmdw
image.png

I am still having a problem
I think it has something to do with the update to 3.9.3
Issue: subsequent to an update, two things changed:

  • numbering
  • document type added

Unreconciled allocations can still not be deleted. However, there is a difference:
the allocations with the new numbering sequence (starting 5...AL) and the document type allocation can be reset whereas the allocations with previous document sequencing (starting 2....) and missing document type cannot be reset.

I have done a test and set the old document type to Allocation in the database but this has not helped.

What we are trying to achieve: some of the allocations cannot be reconciled as due to currency differences the payments to not match the invoice. I would like to reset the allocations and allocate the currency difference to a charge to make it matching.

Diego Chavez
@Diego-18
Good afternoon I was recommended that for the integration of the code in adempiere with other developments to use a cgi, which is compatible or which could be used with adempiere?
I was checking the wiki but the links there are missing.
Michael McKay
@mckayERP
@pmdw Can you set your trace level to fine and post any errors you get when you try to reset the allocation?
@Diego-18 It depends on what you are trying to integrate. What is your goal?
Diego Chavez
@Diego-18
@mckayERP Good evening, I'm part of a team where we are several developers, each working on a local DB where we apply our customizations (add either a table, elements or fields within the system) to cover the requirements requested, when integrating everything into a DB in general conflicts occur with the sequence of id, I've been looking for a tool that allows me to integrate the changes of each take into account the sequence of id of the DB in general and not the local DB and establish them to make the insert, but I have not managed to find a solution. Is there any tool or recommendation that can be used?
Michael McKay
@mckayERP
@Diego-18 Yes. For the project as a whole, we use a CGI script for this. See the doc in http://wiki.adempiere.io/Centralized_ID_Management#For_Projects_with_Distributed_Developers. The same script can be used for a project. The source is here - https://sourceforge.net/p/adempiere/svn/HEAD/tree/contributions/stuff/POC_Central_System_IDs/.
If you do not have access to the central ID system, let me know. If you are making changes to dictionary items or will want to contribute your changes back to the community at some point, you should also be using the central ID system as well.