Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 12:18

    agherzan on master

    linux-raspberrypi: bump to Linu… (compare)

  • 12:18
    agherzan closed #583
  • 08:22
    texierp review_requested #583
  • Feb 20 22:15
    texierp opened #583
  • Feb 20 17:52
    agherzan commented #580
  • Feb 20 17:49
    agherzan commented #532
  • Feb 20 17:49
    agherzan commented #532
  • Feb 20 17:48

    agherzan on warrior

    linux-raspberrypi: Updating the… (compare)

  • Feb 20 17:48
    agherzan closed #582
  • Feb 20 17:48
    agherzan commented #582
  • Feb 20 17:47
    agherzan commented #532
  • Feb 20 17:46
    agherzan commented #568
  • Feb 18 20:39
    myfreescalewebpage commented #568
  • Feb 18 20:30
    myfreescalewebpage synchronize #568
  • Feb 18 20:29
    myfreescalewebpage synchronize #568
  • Feb 18 15:05
    zpfvo commented #532
  • Feb 18 14:51
    zpfvo commented #532
  • Feb 17 17:59
    drewmoseley opened #582
  • Feb 13 19:01
    california68 opened #581
  • Feb 13 16:44
    sirus20x6 opened #580
thesillywhat
@thesillywhat
thanks a lot
thesillywhat
@thesillywhat
Has anyone else faced a similar issue. My whole computer froze and it has been in the same state for few hours now. This happened when I was running bitbake command. It has been on the same step for few hours now
Andrei Gherzan
@agherzan
@thesillywhat the build froze or the computer?
thesillywhat
@thesillywhat
both
I then ran the clean command and have started the build again
its currently close to completion at 97% was just curious if anyone else faced a similar situation
Carton32
@Carton32
Yes sometimes.
It's extremely ressources consumming
For my build setup (especially for Qt part), I need 16GB of RAM + some swap, > 90GB of HDD and 8 cores
So maybe you don't have enough RAM ? Just a guess
That was my case
thesillywhat
@thesillywhat
Currently this is the command I am using sudo dd if=tmp/deploy/images/raspberrypi2/rpi-basic-image-raspberrypi2.rpi-sdimg | pv | sudo dd of=/dev/sdX bs=16M
and When I insert the USB in my pi. It does not boot up
Is there a way to check where the problem lies. In the generated OS or the hardware
?
Andrei Gherzan
@agherzan
@thesillywhat attach a serial console. Also I recommend using etcher for writing the image. Just to be on the safe side.
thesillywhat
@thesillywhat
@agherzan thanks will do that. Also sorry if my questions seem a little redundant or inexperienced(I am blanking out on what should be the correct word of "beginner like questions") . Our team does not have a OS guy and I got promoted to do this. I am little excited about it. But I am very new to all of this.
Carton32
@Carton32
@thesillywhat Don't worry. I'm in the same boat !
thesillywhat
@thesillywhat
Also I have one more question. What is the difference between these to image files. Whats the difference between. Core-image-base-raspberrypi-cm3.rpisdimg and core-image-base-raspberrypi-cm3-<timestamp>.rootsfs.img
@Carton32 Thanks!!
Carton32
@Carton32
One is a file, the other a symlink if I remember correctly
Check with "ls -la"
to confirm
thesillywhat
@thesillywhat
yes. One is a link
thesillywhat
@thesillywhat
So just an update. I used etcher and I inserted the SDcard in cm3 with the core-image-base and it booted up
Thanks for the help
Matthijs ter Woord
@mterwoord
one is just the rootfs one is a complete image?
Matthijs ter Woord
@mterwoord
including partitioning table, boot partition, etc
thesillywhat
@thesillywhat
@mterwoord so does it matter which sdimg, I use to write into my SD card. Will I see a difference?
thesillywhat
@thesillywhat
are all these questions answered in the reference manual
?
Carton32
@Carton32
The file without timestamp is a symlink to the one with timestamp
I use dd to copy my images and always use the symlink as if arg
Matthijs ter Woord
@mterwoord
@Carton32 I usually have the with and without timestamp ones which are exactly same
in his case he has <timestamp>.rootfs.img and cm3.rpi-sdimg
those are same? that would mean rootfs actually contains more than just the 1 fs..
would be weird, imo..
thesillywhat
@thesillywhat
Also what are the advantages of using boot2qt then using yocto with qt5 layer for raspberry pi. Is the answer as simple as boot2qt is more designed for system using qt applications
thesillywhat
@thesillywhat
@Carton32 Have you tried creating raspberrypi image with Qt5 layer
?
So I downloaded the qt5 meta layer added that in bblayer.conf. Now all I have to do is run init script and bitbake command to make a qt5 image
Is this right?
bitbake qt5-image
Carton32
@Carton32
Yes I have an application that runs on eglfs (single window app)
What kind of Qt5 app do you have ?
I never tried the qt5-image
thesillywhat
@thesillywhat
I have an application that runs on xcb and eflfs
  • on either xcb or eglfs
so how did you proceed with it
am i atleast right on the bblayer.conf stuff ?