Thank you, I might repeat my question again.
how shall one name the following function to show their difference?
e.g. We can name 1. and 2. with suffix like
Async. For example
readdirAsync But how shall one differ 1/2 to 3 on the name of function?
readdirGenerator or something else? I havn't find any style guides on that.