Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 16:18
    stijnherreman commented #3039
  • 16:12
    IgorFedchenko commented #3973
  • 12:52
    Zetanova commented #3937
  • 12:51
    Zetanova commented #3937
  • 12:35
    Zetanova commented #3937
  • 12:35
    Zetanova commented #3937
  • 06:57
    amichel opened #3977
  • Oct 15 20:04
    IgorFedchenko synchronize #3973
  • Oct 15 20:03
    IgorFedchenko synchronize #3973
  • Oct 15 19:34
    IgorFedchenko synchronize #3973
  • Oct 15 17:53
    Aaronontheweb closed #3972
  • Oct 15 17:53
    Aaronontheweb commented #3972
  • Oct 15 17:53
    Aaronontheweb closed #3976
  • Oct 15 17:53
    Aaronontheweb commented #3976
  • Oct 15 17:40

    Aaronontheweb on dev

    cleaned up some samples to use … (compare)

  • Oct 15 17:40
    Aaronontheweb closed #3975
  • Oct 15 16:33
    IgorFedchenko synchronize #3973
  • Oct 15 16:31
    IgorFedchenko synchronize #3973
  • Oct 15 14:04
    wsvdyk opened #3976
  • Oct 14 21:02
    Aaronontheweb synchronize #3975
Diego Frata
@diegofrata
My actors implement a common interface and I was using the interface as T instead of the concrete type. It was messing the ActorCell creation. I wouldn't say this is a bug, but it's definitely a point for improvement IMHO. In the meantime I'm passing concrete types.
Thomas Tomanek
@thomastomanek
hmm, there was a bug ages ago that returned a similar/same exception when using autofac to create actors
#941
Christian Duhard
@cduhard
Christian Duhard
@cduhard

what might these messages mean?

[Debug] Resolve of path sequence [/"user/contact-pool-e4338572-5484-4e67-94d5-59e7289d207e/$b"] failed

Aaron Stannard
@Aaronontheweb
@cduhard what were you trying to do?
Christian Duhard
@cduhard
not sure when that log message is getting fired, but I have a small RR pool per Parent that gets handed to it's children
Aaron Stannard
@Aaronontheweb
that message occurs when an actor selection fails
the requested path could not be found
Christian Duhard
@cduhard
                Context.System.ActorOf(
                    Akka.Actor.Props.Create<ContactVerificationActor>(ContactService.GetInstance(),
                        new SequenceService())
                        .WithRouter(new RoundRobinPool(2))
                    , "contact-pool-{0}".FormatWith(Guid.NewGuid()));
why would selection fail? i have never seen that message before today
Aaron Stannard
@Aaronontheweb
my bad - here's where it gets called
private IActorRef ResolveActorRef(IInternalActorRef actorRef, IReadOnlyCollection<string> pathElements)
        {
            if(pathElements.Count == 0)
            {
                _log.Debug("Resolve of empty path sequence fails (per definition)");
                return _deadLetters;
            }
            var child = actorRef.GetChild(pathElements);
            if(child.IsNobody())
            {
                _log.Debug("Resolve of path sequence [/{0}] failed", ActorPath.FormatPathElements(pathElements));
                return new EmptyLocalActorRef(_system.Provider, actorRef.Path / pathElements, _eventStream);
            }
            return child;
        }
Inside LocalActorRefProvider
Christian Duhard
@cduhard
the messages eventually stop and everything seems to move along fine
Aaron Stannard
@Aaronontheweb
without seeing what's actually happening, i.e. the larger context
difficult to tell
never seen that error get logged before
Context.System.ActorOf is weird though - you're not creating a child when you do that
you're creating another top-level actor
not sure if that's intentional or not
Christian Duhard
@cduhard
shit, no it's not
hah, thanks for noticing that, dunno if it's related to my issue
Aaron Stannard
@Aaronontheweb
yeah me neither
could you post a bigger gist?
Christian Duhard
@cduhard
the weird thing is i have another pool created the exact same way that doesn't throw those errors
Christian Duhard
@cduhard
the only thing i've changed is i went from a ReceiveActor to ActorBase, it's likely something i missed there
Christian Duhard
@cduhard
i don't know what i'd put in the gist, what would help?
is there a problem with using PatternMatch in Receive?
Bartosz Sypytkowski
@Horusiath
@rogeralsing I've pushed #1408 for initial Akka.Cluster.Tools, but when working on example program, I've found two serialization issuess: 1) is concerning JSON.NET not being able to deserialize IDictionary<Address, ...> (if get serialized as map of string keys) and 2) is about Wire having problems with finding default constructor for System.Collections.Immutable.ImmutableDictionary
any of them is effectively blocking distributed pub/sub (and cluster client) examples to work
Christian Duhard
@cduhard
I am getting all these:
[Debug] Resolve of path sequence [/"user/contact-pool-e4338572-5484-4e67-94d5-59e7289d207e/$b"] failed
before the router even receives any messages.
Aaron Stannard
@Aaronontheweb
hmmm... mind creating an issue for that @cduhard ?
I wonder if there's something racy with the way routers create children
might be totally harmless
but we should investigate
Christian Duhard
@cduhard
could it have anything to do with monitoring?
Aaron Stannard
@Aaronontheweb
using Akka.Monitoring?
Christian Duhard
@cduhard
yes
Aaron Stannard
@Aaronontheweb
hmmm.... could be - calling it from the child actor/
?
Christian Duhard
@cduhard
yes
Aaron Stannard
@Aaronontheweb
only way I could see that happening would be if the actor was receiving a message while it was still being created... which Akka.Monitoring implementation are you using?
Christian Duhard
@cduhard
statsd
nothing gets to Receive until after i see a zillion of those messages
Aaron Stannard
@Aaronontheweb
could you do a test for me and try commenting the monitoring method calls out
see if those come in?
because I have literally never seen this message in two years of using Akka.NET
Christian Duhard
@cduhard
yeah i'm about to do that
yeah, they still show up
Aaron Stannard
@Aaronontheweb
post a gist with the full source for this