by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Sep 17 17:14
    briansain commented #4567
  • Sep 17 16:59
    briansain synchronize #4568
  • Sep 17 16:27
    VaclavK closed #51
  • Sep 17 16:27
    VaclavK closed #50
  • Sep 15 14:57
    BartHuls closed #4569
  • Sep 15 14:18
    Aaronontheweb commented #4563
  • Sep 15 13:53
    Zetanova commented #4563
  • Sep 15 13:41
    Aaronontheweb commented #4563
  • Sep 15 13:38
    Zetanova commented #4563
  • Sep 15 13:28
    Zetanova commented #4563
  • Sep 15 13:15
    Aaronontheweb commented #4567
  • Sep 15 13:11
    Aaronontheweb commented #4569
  • Sep 15 09:59
    BartHuls commented #4569
  • Sep 13 16:51
    to11mtm commented #4568
  • Sep 11 18:45
    briansain synchronize #4568
  • Sep 11 16:18
    briansain commented #4567
  • Sep 11 15:50
    briansain commented #4567
  • Sep 11 15:37
    ismaelhamed commented #4567
  • Sep 11 15:24
    dependabot-preview[bot] synchronize #146
  • Sep 11 15:24

    dependabot-preview[bot] on nuget

    Bump AkkaVersion from 1.4.9 to … (compare)

Stefan Sedich
@stefansedich
indeed
I need another laptop
Mikey
@BrainSlugs83
@Aaronontheweb thanks -- sometimes Akka makes me feel like, I have a hammer, and all these nails -- and for some reason, I'm looking for the screw driver anyway. XD
Zetanova
@Zetanova
How to run one tests or all of one tests lib?
Aaron Stannard
@Aaronontheweb
@Zetanova resharper ;)
or if you want to run the entire test suite, ./build.cmd all
as for re-running it on the build server, I'll need to give you an account
Bartosz Sypytkowski
@Horusiath
@Aaronontheweb this will be more complicated - for some reason when I'm updating nuget packages in persistence plugin projects, references get kicked out of the csproj
ok, I see now - when you usually get nuget package, you should have a separate dir create for it, with *.nupkg file and lib sub-directory
Bartosz Sypytkowski
@Horusiath
now when I'm downloading nightlies I don't have lib sub-dir, only [Content_Types].xml file
Aaron Stannard
@Aaronontheweb
so, no binaries?
Bartosz Sypytkowski
@Horusiath
nope
Zetanova
@Zetanova
@Aaronontheweb why not xunit.runner.visualstudio ?
Aaron Stannard
@Aaronontheweb
@Horusiath welp, might be the FAKE script then
blob
as you can see there, all of the NUKPGs I produced when I ran it yesterday definitely have binaries in them
based on the file sizes
ah, my bad!
those are the symbol pkgs
the true NuGet packages are screwed up
I can see that
so something must not have been updated in the FAKE script when paket was introduced
probably in the output copying step
let me check
Aaron Stannard
@Aaronontheweb
@Zetanova that should work too
we use XUnit 2
I'm pretty sure that's been updated to work with the VS Test Runner
James Connor
@megakid
@Aaronontheweb with the hack about monitoring gossip and having the singleton live on the cluster lead, would this work if you had Lighthouse as your seed nodes?
Aaron Stannard
@Aaronontheweb
you'd have to modify the source
couldn't use it OOB
it's definitely a hack
James Connor
@megakid
Cool, yeh just wanted to understand that - sounds like proper cluster singleton isn't too far away anyhow
Aaron Stannard
@Aaronontheweb
fixed it @Horusiath
Aaron Stannard
@Aaronontheweb
@Horusiath could you review #1455?
that should solve it
tru3d3v
@tru3d3v
Thank you @Aaronontheweb for helping me
Bartosz Sypytkowski
@Horusiath
@Aaronontheweb still nothing
Tom Rathbone
@chillitom
@Horusiath "System.TypeLoadException : Could not load type 'Akka.Actor.WithUnboundedStash' from assembly 'Akka, Version=0.8.0.0, Culture=neutral, PublicKeyToken=null'." whilst trying out the nuget packages for Akkling v0.2
Bartosz Sypytkowski
@Horusiath
you'll need newer version of Akka installed as set assembly bindings if needed
Zetanova
@Zetanova
i am adding the 1.0.5.109-beta over nuget and no akka asm appears as reference
Tom Rathbone
@chillitom
@Horusiath thanks, that got it. Odd that it would pull in such an old version.
ramusbucket
@ramusbucket
Hello Akkadotnet
I'm getting "has 0 routees" message with web-crawler sample
Any clue?
Zetanova
@Zetanova
to link the local builded nuget packages, its the same behavior as with the prerelease, no akka assemblies are under references
Simon Anderson
@thelegendofando
@ramusbucket 0 routees means your cluster hasn't formed.
You should be able to work out what's going on via the console output
ramusbucket
@ramusbucket
@thelegendofando thank you for your comments
It seems that I was ignorant about how to run those samples. The instructions given on Github wiki pages are not sufficient. I somehow figured out that I need to run "WebCrawler.CrawlService" and "WebCrawler.TrackingService" along with the "WebCrawler.Web" app and "Lighthouse" app
Thomas Tomanek
@thomastomanek
so I've just discovered that actors are created asynchronously (when ActorOf call completes my actor isn't guaranteed to have been ctor'd). Is there a way to control that, and also presumably if I send a message to an uncreated actor the message will be buffered untli it is created?