Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 14:21
    Ralf1108 edited #3933
  • 14:17
    Ralf1108 opened #3933
  • 12:57
    Aaronontheweb commented #3904
  • 12:15
    Aaronontheweb synchronize #3927
  • 11:21
    Zetanova synchronize #3916
  • 08:35

    Aaronontheweb on dev

    Fix build script to be able to … (compare)

  • 08:35
    Aaronontheweb closed #3924
  • 08:28
    Aaronontheweb synchronize #3927
  • 08:28
    Aaronontheweb synchronize #3924
  • 08:28

    Aaronontheweb on dev

    added updated Windows Release p… Merge pull request #3869 from A… Fixed Akka.Remote.ResendUnfulfi… and 6 more (compare)

  • 08:28
    Aaronontheweb closed #3932
  • 08:22
    Aaronontheweb opened #3932
  • 08:16

    Aaronontheweb on 1.3.15

    (compare)

  • 08:14

    Aaronontheweb on master

    Fixed Akka.Remote.ResendUnfulfi… added v1.4.0-beta2 release note… added Akka.NET v1.3.15 release … and 2 more (compare)

  • 08:14
    Aaronontheweb closed #3931
  • 08:11
    Aaronontheweb synchronize #3931
  • 07:59
    Aaronontheweb commented #3905
  • 07:58
    Aaronontheweb edited #3931
  • 07:57
    Aaronontheweb commented #3889
  • 07:54
    Aaronontheweb synchronize #3931
Aaron Stannard
@Aaronontheweb
will help with Xamarin support as well as .NET Core
put that stuff into a separate library that's only referenced on full-blown .NET installations
can probably do that part without needing a second nuget package
just an extra binary that only gets added to full .NET profile installs
although, nuts - kind of do need that for the automatic config loading
meh, going to need to just do #IFDEF macros then I guess
we can pretend we're C++ programmers and be all smug about it
Arjen Smits
@Danthar
resistence is futile :P
Vagif Abilov
@object
@Horusiath this is my case too - JSON.NET wouldn't work with my example, this is why I am trying to configure Wire. But don't have that machine now with me, will investigate tomorrow.
Chris Martin
@trbngr
Where did ReplayMessagesSuccess go?
Chris Martin
@trbngr
I guess that was renamed to RecoverySuccess akkadotnet/akka.net@93af339
Aaron Stannard
@Aaronontheweb
@Silv3rcircl3 weird, having this spec fail locally now for some reason: EventFilterTestBase
a couple different implementations of it - never seen that before
ever had any problems with that?
Marc Piechura
@marcpiechura
@Aaronontheweb you mean the remote spec ?
Aaron Stannard
@Aaronontheweb
no
these are testkit specs
SS coming
blob
Marc Piechura
@marcpiechura
Tbh I don't know anything about it, I know there was the PR which added the overload for a custom ActorSystem but haven't run the tests locally for a long time
Aaron Stannard
@Aaronontheweb
I had it fail locally on ./build.cmd all which is bad
since that's build server stuff
Marc Piechura
@marcpiechura
Why do you think I know something about it ? :)
Aaron Stannard
@Aaronontheweb
shows you were one the last people to touch it :p
Marc Piechura
@marcpiechura
o_O
Aaron Stannard
@Aaronontheweb
blob
I think I've found the issue
 protected EventFilterTestBase(string config)
            : base(@"akka.loggers = [""" + typeof(ForwardAllEventsTestEventListener).AssemblyQualifiedName + @"""], " + (string.IsNullOrEmpty(config) ? "" : config))
        {
            //We send a ForwardAllEventsTo containing message to the TestEventListenerToForwarder logger (configured as a logger above).
            //It should respond with an "OK" message when it has received the message.
            var initLoggerMessage = new ForwardAllEventsTestEventListener.ForwardAllEventsTo(TestActor);
            // ReSharper disable once DoNotCallOverridableMethodsInConstructor
            SendRawLogEventMessage(initLoggerMessage);
            ExpectMsg("OK");
            //From now on we know that all messsages will be forwarded to TestActor
        }
assertion in the constructor of the test
Marc Piechura
@marcpiechura
Man I really can't remember that I ever touched this code, will check my PR's from this time
Aaron Stannard
@Aaronontheweb
smells to me like a race condition where something isn't started before this command fires
but not otherwise
works fine when I debug it
Marc Piechura
@marcpiechura
Sorry can't look into it at the moment, can you show me in which PR I changed that? I can't find it
Aaron Stannard
@Aaronontheweb
honestly I'm kind of puzzled by this
it's not even the EventFilter stuff that broke this
it's like the testkit initialization is fucked up
ah nope
sure enough
there is a bug here I'm pretty sure
Kris Schepers
@schepersk
@Horusiath I just tried my sharding example again, this time with the new nuget packages.. The issue of the shards not being rebalanced is still there I'm afraid.
Bartosz Sypytkowski
@Horusiath
I'll try to take a look at this during the weekend. I'm feeling that fixing multinode test runner spec for cluster sharding should help to answer/predict this issue.
I assume that's not the reason for this ;)
Aaron Stannard
@Aaronontheweb
ah, yeah probably not
I'm going to revert the changes made to the EventFilter if I can't get this to pass
Marc Piechura
@marcpiechura
we haven't used it anyway if I remember correctly
Aaron Stannard
@Aaronontheweb
I have more important bugs to fix
Aaron Stannard
@Aaronontheweb
can't reproduce on build-server
Kris Schepers
@schepersk
@Horusiath Thanks! In the meanwhile I'll go for a simple coordinator for our first version then..