Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 14:35
    IgorFedchenko commented #3973
  • 13:10
    zbynek001 opened #4000
  • 11:20
    IgorFedchenko commented #3973
  • 11:20
    IgorFedchenko commented #3973
  • 11:18
    IgorFedchenko commented #3973
  • 10:47
    IgorFedchenko synchronize #3973
  • 10:13
    valdisz commented #3921
  • Oct 21 15:57
    Aaronontheweb closed #3877
  • Oct 21 15:57
    Aaronontheweb commented #3877
  • Oct 21 15:56

    Aaronontheweb on dev

    Persistence TestKit documentati… (compare)

  • Oct 21 15:56
    Aaronontheweb closed #3889
  • Oct 21 07:27
    dependabot-preview[bot] labeled #3999
  • Oct 21 07:27

    dependabot-preview[bot] on nuget

    Bump FluentAssertions from 4.14… (compare)

  • Oct 21 07:27
    dependabot-preview[bot] opened #3999
  • Oct 20 17:25
    valdisz synchronize #3889
  • Oct 20 17:17
    valdisz synchronize #3889
  • Oct 20 15:44
    valdisz synchronize #3889
  • Oct 20 09:22
    ismaelhamed commented #3863
  • Oct 19 23:39
    valdisz synchronize #3889
  • Oct 19 23:08
    edvinasz commented #2947
Maxim Cherednik
@maxcherednik
you will probably need to rewrite lots of things :)
but anyhow... try it... other than this, I don't know how to handle this
Daniel Söderberg
@raskolnikoov
I talked to Roger Johansson about this now and he answered that it's not possible to do my test case.
Maxim Cherednik
@maxcherednik
yeah - like you described - not possible...
Aaron Stannard
@Aaronontheweb
@Rattenkrieg I haven't seen any examples of this being needed in practice
but with your changes to the MNTR in #2502
is it still possible to give one node amongst the others in the spec its own configuration?
I.E. if I wanted to run a test that gave one node a different configuration from the others?
I kind of think this is YAGNI to some extent, but still - that's a capability we had before that I would like to preserve in some capacity
in case you missed it, YAGNI
Aaron Stannard
@Aaronontheweb
ah nice
do you mention how to do that on the documentation PR you sent in|?
(haven't looked at it yet)
Sergey Prytkov
@Rattenkrieg
Nope, but this part isn't one that was affected by my changes
Aaron Stannard
@Aaronontheweb
cool, good to know
Sergey Prytkov
@Rattenkrieg
Feel free to ask to add any part to docs
Aaron Stannard
@Aaronontheweb
could you add a section on configuring individual nodes?
as part of the section where you define a MultiNodeConfig?
doesn't need to be much, just a small example would be great
the PR was great btw, definitely like the look of the logs much more now
Sergey Prytkov
@Rattenkrieg
Thanks!
NodeConfig(new List<RoleName> { First }, new List<Config> { ConfigurationFactory.ParseString("akka.cluster.roles =[frontend]") });
could you add a section on configuring individual nodes?
Aaron Stannard
@Aaronontheweb
yep, that would be great
something like that
Sergey Prytkov
@Rattenkrieg
Ok got it
Will do after lunch ;)
David Rivera
@mithril52
I seem to be having some issues with Akka and its use of System.Collections.Immutable. If I use 1.2.0 version of Immutable, when I go to create my actor system with a provided config object, it throws an exception saying it cannot find Immutable 1.1.36. Then if I change the Immutable version to 1.1.36, it says it can't find version 1.2.0 of Immutable. Has anyone else come across an issue like this?
Aaron Stannard
@Aaronontheweb
@mithril52 which modules are you using?
all of the shipped Akka.NET modules depend on 1.1.36
David Rivera
@mithril52
Cluster, DI.Core, DI.Ninject, Logger.Serilog, Remote, Testkit, TestKit.XUnit
All 1.1.3
Well, exc ept Serilog. Its at 1.12
1.1.2
Aaron Stannard
@Aaronontheweb
although we're looking at upgrading to the latest here: akkadotnet/akka.net#2509
IMHO, check to see if you have a binding redirect defined in App.config
when you're using 1.1.36
and delete it if it's there
David Rivera
@mithril52
Hmm, ok
Aaron Stannard
@Aaronontheweb
could have been added when you upgraded to 1.2
David Rivera
@mithril52
But I should be using 1.136?
Aaron Stannard
@Aaronontheweb
yep
that's what we support today
David Rivera
@mithril52
Okay
Yup, loosk like thats it. It added rebindings to every project
David Rivera
@mithril52
Thanks Aaron, that fixed it. I hate it when I'm too deep into an issue to see the issue staring me in the face :)
Aaron Stannard
@Aaronontheweb
you're welcome man
some words of advice
it's almost always something stupid