Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 19 22:18
    ben9923 commented #57
  • Oct 19 14:00

    kprinssu on master

    Don't rely on defaults defined … (compare)

  • Oct 19 14:00
    kprinssu closed #482
  • Oct 15 10:04
    sqlsec edited #474
  • Oct 15 05:01
    BradenJ6164 commented #474
  • Oct 15 05:01
    BradenJ6164 commented #474
  • Oct 13 18:04
    kprinssu commented #482
  • Oct 13 17:34
    ben9923 review_requested #482
  • Oct 13 06:25
    stevezhengshiqi opened #483
  • Oct 13 04:02
    williambj1 synchronize #482
  • Oct 13 03:55
    williambj1 opened #482
  • Oct 12 03:20
    stevezhengshiqi commented #472
  • Oct 11 18:27
    lulu-gh commented #460
  • Oct 11 18:27
    lulu-gh closed #460
  • Oct 11 08:59
    juico commented #460
  • Oct 11 06:21
    stevezhengshiqi commented #472
  • Oct 10 02:47
    lulu-gh commented #460
  • Oct 09 10:13
    LucasDondo commented #358
  • Oct 08 23:41
    juico opened #57
  • Oct 08 22:49
    Lorys89 commented #358
pratiknborkar
@pratiknborkar
@tmbt78 hey man thanks for reply as you said i have followed the guide from Dortania and create USB and booted according and fortunately i got IOInterruptSpecifiers entries on my ACPI ID (TPD0). So i patch my DSDT only with following paches Windows Emulation patch ,GPI0 controller patch and CRS paches
My APIC pin number is 63
Still no trackpad appears.
Here is my EFI and IOREG
https://drive.google.com/drive/folders/1yOxtMU_hPhp_FlYgJIfcEEOcHe2V93y6?usp=sharing
Tasc11
@Tasc11

@YehJiaJun

I need help,I have a laptop is Asus ux434fac,it has a screenpad2.0,it is a touchpad also is a screen ,I try VoodooI2C but it not work,who can help me,please
This is my EFI and some laptop Info => https://drive.google.com/drive/u/0/folders/1MtzX5SCk80YQGc9EEAFmGZ5NEG1AkfQn

As far as i know, it's not supported yet. CMIIW.

tmbt78
@tmbt78
@pratiknborkar Your EFI is much better now. BUT you're still injecting BOTH VoodooHID and VoodooELAN
you need only one of those. So for the moment disable the VoodooELAN.kext from loading
also under ACPI Patch in the config.plist you've to enable XOSI rename and HPET rename because right now are disabled so your injecting the SSDT-XOSI do nothing
finally add this kext to your kext folder and load it in the config.plist
finally restart and in a terminal paste here the output of this command
dmesg | grep "Voodoo"
tmbt78
@tmbt78
Also under Windows check ACPI properties (same as the pictures you've in the first EFI) as you can see here
i want to be sure on which bus your trackpad is attached. Do you have also a touchscreen ?
Please try to follow all the things i've said because there is a lot of delay between every chat. In this way we optimize the debug process.
pratiknborkar
@pratiknborkar
@tmbt78 Again thanks again for the reply. I did what you told me to do then my Touchpad stared working like two finger scroll , Tap to click and three fingers like for move next window. but touchpad is missing on System Preference. And i dont have Touchscreen laptop

this the log

pratiknborkar@Pratiks-MacBook-Pro ~ % sudo dmesg | grep "Voodoo"
Password:
VoodooI2CControllerDriver::pci8086,6e8 Publishing device nubs
VoodooI2CControllerDriver::pci8086,6e8 Found I2C device: ELAN1203
VoodooI2CDeviceNub::TPD0 Got GPIO Controller! VoodooGPIOCannonLakeH
VoodooI2CHIDDevice:0x1000003e3 start
VoodooGPIOCannonLakeH::Registering hardware pin 0xE1 for GPIO IRQ pin 0x129
VoodooGPIOCannonLakeH::Successfully registered hardware pin 0xE1 for GPIO IRQ pin 0x129
VoodooI2CHIDDevice::ELAN1203 Device initiated reset accomplished
VoodooI2CHIDDevice:0x1000003e3 creating interfaces
VoodooInputSimulatorDevice:0x100000438 start
VoodooI2CHIDDevice:0x1000003e3 open by VoodooI2CPrecisionTouchpadHIDEventDriver 0x100000432 (0x0)
VoodooI2CPrecisionTouchpadHIDEventDriver::ELAN1203 Putting device into Precision Touchpad Mode
VoodooInputActuatorDevice:0x10000043b start
VoodooInputSimulatorDevice:0x100000438 creating interfaces
VoodooInputActuatorDevice:0x10000043b creating interfaces
VoodooInputSimulatorDevice:0x100000438 open by AppleMultitouchTrackpadHIDEventDriver 0x100000445 (0x0)
VoodooInputActuatorDevice:0x10000043b open by AppleActuatorHIDEventDriver 0x100000449 (0x0)
ApplePS2Controller: Notification consumer published: VoodooI2CPrecisionTouchpadHIDEventDriver
Sandbox: 4 duplicate reports for bluetoothd deny(1) mach-lookup com.apple.server.bluetoothSandbox: apsd(125) deny(1) user-preference-write com.apple.apsdALF, old data swfs_pid_entry <ptr>, updaterules_msg <ptr>, updaterules_state <ptr>ALF, hash_free: found kext_info <ptr> Sandbox: 2 duplicate reports for apsd deny(1) user-preference-write com.apple.apsdSandbox: mds(116) System Policy: allow file-read-metadata /private/var/folders/f3/r0g7fr1n3fq_kbwv9jx25lhc0000gn/0/com.apple.nsurlsessiond/com.apple.nsurlsessiondSandbox: apsd(125) deny(1) user-preference-write com.apple.apsdVoodooI2CPrecisionTouchpadHIDEventDriver::setProperties USBMouseStopsTrackpad = 0
pratiknborkar@Pratiks-MacBook-Pro ~ %

tmbt78
@tmbt78
@pratiknborkar you're welcome. The logs shows the kext is loaded and now you've the gesture too. I'm not sure about the trackpad preferences in System preferences ...
i would like to hotpatch your dsdt instead of using it patched. Could you please me provide an untouched DSDT ?
Also .. is your battery working ? Do you have the battery icon in the top bar ? Does it show battery remain energy ?
Also when you connect the power adapter is ricognized by the changing in the battery icon ?
Battery and touchpad are very connected one another (don't know why) so this could create the missing preferences for the touchpad
pratiknborkar
@pratiknborkar
@tmbt78 Thats great here are my Untouched Tables SSDT and DSDT. And yes Battery icon acting weirdly it wont appears neither on Battery power nor on AC adaptor.
One more thing Drag is not happening too if possible patch that too :D
pratiknborkar
@pratiknborkar
One more thing on big sur only cursor work but click and rest gestures not works
tmbt78
@tmbt78
@pratiknborkar Before patching the DSDT for the battery try to inject this kext and load it in config.plist. After reboot check if the battery icon works as expected and also if you have trackpad preferences and report back.
pratiknborkar
@pratiknborkar

Dude ECEnabler works.. ! With that Trackpad started works on both Catalina and Big Sur even though battery icon also started working fine in both OS.
here is my ioreg along with my EFI folder original tables i have already attached on previous post. (Kindly refer screenshots)

One strange thing is i come to know that my command key is replace by windows key it should be the with ALT key. and is there any way that can enable my RGB keyboard control or native key mapping for birghtness control because ASUSSMC won't works as it should be.
ROGHID app also not works properly.

https://drive.google.com/drive/folders/14JIKSuKQhoGVhZm1vW-Z79ZjZdEvA5VX?usp=sharing

pratiknborkar
@pratiknborkar
@feartech Do i need to add anything or just save to aml ?
feartech
@feartech
compile as aml, copy to acpi folder, add aml in your config.plist if using opencore
pratiknborkar
@pratiknborkar
@feartech Cool will update the result ASAP
tmbt78
@tmbt78
@pratiknborkar Replace your config.plist with the one in this zip. Replace your SSDT-XOSI.aml with the one in this zip and finally ADD SSDT-I2C.aml
restart and check if the touchpad is working as usual
keep a copy of your original EFI in case you've to boot from USB to recover
if after reboot the touchpad isn't working download patchmatic from here : https://bitbucket.org/RehabMan/os-x-maciasl-patchmatic/downloads/
and run this in terminal after you've extracted it : patchmatic -extract
and upload here all the aml files that command will generate
if everything is workin good then you can just delete from your ACPI folder DSDT.aml because is not needed anymore
after that i suggest you to go at this link and continue to optimize your hackintosh because you have a lot of room for optimization
tmbt78
@tmbt78
just few hints : you don't have a USB map , you haven't disabled your NVIDIA card, you're not using CPUFriend , i don't think you need RTC fixup kext
also remove the VoodooI2CELAN kext from the kexts folder because you're not using it
pratiknborkar
@pratiknborkar
I have disable NVDIA from Open core Device Propertiesbut don't why i am getting poor battery backup will try and update.
tmbt78
@tmbt78
if you have an NVME hard drive you should also install NVMEFix kext
also install Intel Power Gadget to check the power consumption
CPUFriend will help you too
there are a lot of things to check
also you shoudn't have -vI2c-force-pilling as boot-args this will force polling mode instead of Interrupt mode
you haven't this when you posted your logs yesterday