Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Sam Bender
    @rednebmas
    I can't seem to figure out how to install the plugin... I tried the addin manager and then install from file. I navigated to the directory and couldn't find any files to import. I'm not sure what to try next!
    TeddyZhang
    @teddyzhang29
    hi, does the vi add-in recognize the command "ci(" ?(ps,it means modify the value between '(' and ')')
    Jason Imison
    @nosami
    @teddyzhang29 I just started a new vim plugin... you can find it in the AddinRepo called "Vim"
    my plugin supports that
    but it it is still new and has many bugs :)
    TeddyZhang
    @teddyzhang29
    monodevelop add-in?
    Jason Imison
    @nosami
    yeah
    TeddyZhang
    @teddyzhang29
    let me try!
    Jason Imison
    @nosami
    you will probably need to uninstall VimAddin if you have that already installed...
    they probably don't play well together
    will need to restart MD too
    TeddyZhang
    @teddyzhang29
    I'v uninstalled....
    Jason Imison
    @nosami
    my aim is to have perfect vim emulation... but still a long way off
    will keep at it until it's perfect though ;)
    already visual block mode works as well as . and ;
    TeddyZhang
    @teddyzhang29
    fine.
    Jason Imison
    @nosami
    Screen Shot 2017-01-10 at 16.29.24.png
    TeddyZhang
    @teddyzhang29
    ehhh..
    I have a questing, how can I install your add-in?
    Jason Imison
    @nosami
    should be under IDE Extensions
    TeddyZhang
    @teddyzhang29
    I see your github page. but I dont know how to do from that
    Jason Imison
    @nosami
    Addins -> Ide Extensions -> Vim
    I assume you are on linux... so not sure which menu Addins is under
    you can install it from the IDE
    TeddyZhang
    @teddyzhang29
    I can see only one add-in when I search vim. (that's one which I uninstalled just now)
    Jason Imison
    @nosami
    which version are you on of MD?
    TeddyZhang
    @teddyzhang29
    5.9,
    unity built-in
    Jason Imison
    @nosami
    ah... mine is 6.0+ ... oops
    my plugin might possible work on 5.9 but I haven't tried
    but I specified 6.0 in the addin manifest
    TeddyZhang
    @teddyzhang29
    sorry, unity only support 5.9
    Jason Imison
    @nosami
    sorry about that... I will try and see if my plugin works with 5.9 later this evening
    TeddyZhang
    @teddyzhang29
    I can't debug with unity if I choose 5.9+
    Jason Imison
    @nosami
    (few hours from now)
    TeddyZhang
    @teddyzhang29
    thanks.
    do you have another contact way? I don't use this often. I unfortunately, I have to sleep...
    Jason Imison
    @nosami
    i am usually in this room https://gitter.im/hifi/monodevelop-justenoughvi but that probably doesn't help you either :)
    probably best just to contact me on here