Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 02 15:14

    AlbumenJ on 3.2

    Add dubbo metrics AutoConfigura… (compare)

  • Dec 02 15:13
    AlbumenJ closed #11062
  • Dec 02 15:11
    AlbumenJ commented #11014
  • Dec 02 15:09

    AlbumenJ on master

    update(qos): new foreign ip whi… (compare)

  • Dec 02 15:09
    AlbumenJ closed #1623
  • Dec 02 14:55
    Koooooo-7 commented #11015
  • Dec 02 14:33
    Koooooo-7 commented #11051
  • Dec 02 14:32
    Koooooo-7 synchronize #1623
  • Dec 02 14:31
    Koooooo-7 opened #1623
  • Dec 02 13:54
    XDanwar opened #11063
  • Dec 02 13:53
    Koooooo-7 commented #11051
  • Dec 02 13:28
    tigerhb001 commented #11031
  • Dec 02 13:24
    tigerhb001 commented #11041
  • Dec 02 13:21
    tigerhb001 commented #11041
  • Dec 02 13:02
    akaakking commented #10675
  • Dec 02 12:55
    akaakking commented #10675
  • Dec 02 12:50
    akaakking commented #10675
  • Dec 02 12:22
    AlbumenJ commented #11051
  • Dec 02 12:21
    AlbumenJ commented #11051
  • Dec 02 11:11
    EarthChen assigned #11059
Jon Small
@JonSmall
包都没有引入
无限风灵
@WuLex
沃日
Jon Small
@JonSmall
dubbo 还是2.6.5 我要用2.7.0+
你不会搜索吗
网上资源这么多
你确定找过?
Jon Small
@JonSmall
我相信官网 所以没有百度
坑了
无限风灵
@WuLex
<!-- Dubbo -->
    <dependency>
        <groupId>org.apache.dubbo</groupId>
        <artifactId>dubbo-spring-boot-starter</artifactId>
    </dependency>
    <dependency>
        <groupId>org.apache.dubbo</groupId>
        <artifactId>dubbo</artifactId>
    </dependency>

    <!-- Dubbo Registry Nacos -->
    <dependency>
        <groupId>org.apache.dubbo</groupId>
        <artifactId>dubbo-registry-nacos</artifactId>
        <version>2.7.3</version>
    </dependency>
    <dependency>
        <groupId>com.alibaba.nacos</groupId>
        <artifactId>nacos-client</artifactId>
    </dependency>
这篇文章写的不错
应该对你有帮助
Jon Small
@JonSmall
有很大帮助 我试试先 多谢 2.6.5我可以跑通 目前想用2.7.0+
Jon Small
@JonSmall
@EnableDubbo注解过期现在写法是什么
DubboComponentScan ?
Jon Small
@JonSmall
非的逼人看源码 注解失效就删掉 就换个包名。。。
learninghard-lizhi
@learninghard-lizhi
dubbo 2.6.5 版本ConsumerContextFilter类中没有调用 RpcContext.removeContext();,这样不会造成内存泄漏吗?
liu913306275
@liu913306275
问一下,dubbo2.7.3,zk没有启动, 提供者服务器启动也启动不了,一直再尝试重连, 请问一下,怎么能让服务器启动过程中忽略zk宕机得影响
Kehaw
@uniorder
请问,2.5.x 版本的 Dubbo 升级到最新版的 Dubbo 有什么需要注意的地方吗?
xuxingjia
@xuxingjia
请问dubbo 2.7.3 传递自定义异常 消费者接收到后 异常中数据不对是什么情况
SoybeanSoybean
@SoybeanSoybean
请问dubbo的telnet命令行怎么关闭?
maomaofeitui
@maomaofeitui
@SoybeanSoybean ctril+] 和telnet一样是通用的。
dubbo泛化实现的接口路由规则不生效,这个是什么原因呢。
无限风灵
@WuLex
🐒🐒🐒
(இдஇ; )
大佬们忙啥
Hao YANG
@hyang214
kuangxianxi
@kuangxianxi
有人吗?
gmywq
@gmywq
you
Ice_layer
@FlyingPigHasDream
?
edidada
@edidada
@wudongpo 但是如有有异地部署,多zk中心呢?
Hunt Young
@yanghong
请问有人遇到过这个报错吗?ChannelEventRunnable handle RECEIVED operation error, channel is NettyChannel [channel=[id: 0x47edcc6f, /127.0.0.1:10166 :> /127.0.0.1:20880]], message is status -l, dubbo version: 2.6.5
Alexzhang
@alex8224
动态加载dubbo有搞过的么?
wepoiuopijsdfnxcvl
@wepoiuopijsdfnxcvl
项目启动报找不到类
Hinsteny Hisoka
@Hinsteny
dubbo-admin这个项目相关负责人在吗?提交了验证了bugfix, 没人处理pr呢
强烈建议dubbo-admin这个项目添加几个可以长期愿意为项目负责的成员哈
Hinsteny Hisoka
@Hinsteny
feyjobs
@feyjobs
你好 我现在正在做c/c++ 泛化调用dubbo服务的功能 有一些问题想要咨询 按照文档上 我看到泛化调用把POJO都转成了Map类型 然后在传入类型时传入实际的java类名
但是我有个疑问 如果传入类名比较复杂
class A {
class B b;
....
}
就是类内的参数也是POJO, 我理解是不是也转化成了Map, 但是类内的b 没有地方制定他的java类名
哪位大佬能帮忙答疑解惑吗 是dubbo provider会自动按照key将value翻译成java POJO不需要指定类名吗
zhongkaiuu
@zhongkaiuu
问个问题,我们一个服务配置了20+的service group,并且随着服务迭代,版本号也在不断递增,服务ip也有变动。导致zk下/dubbo/com.xxxxService/configurators/xxx节点很多,而且configurators节点是永久节点,导致每次重启服务都会拉取所有节点,目前只有手动删除旧节点,还有其他比较好的方式吗?
Adrian Cole
@adriancole
@chickenlj hey the website says java 1.6, but I think that's old right? apache/dubbo@6cab4ef
as far as I can tell all paths that use futures will pin to JDK 1.8
it is easier for us (zipkin) to not try to do Java 1.6 especially if the library doesn't support it anymore, as then we don't have to do reflection to look at future type names etc.
can you confirm dubbo no longer supports 1.6?
edidada
@edidada
dubbo invoke this java interface code
public interface EchoService {
String echo(String msg);
}
invoke EchoService.echo("msg")
cause error