These are chat archives for allcount/allcountjs

1st
Feb 2016
shreyasubale
@shreyasubale
Feb 01 2016 04:20 UTC
am getting error LESS File error : '../lib/less/bootstrap/bootstrap.less' wasn't found
LESS File : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/less/main.less 1:0
Error
at new Parser (/Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/less/lib/less/parser.js:333:27)
at render (/Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/less-middleware/lib/middleware.js:153:18)
at /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/less-middleware/lib/middleware.js:245:13
at tryToString (fs.js:414:3)
at FSReqWrap.readFileAfterClose [as oncomplete] (fs.js:401:12)
have just set up the project
Pavel Tiunov
@paveltiunov
Feb 01 2016 07:43 UTC
Hi @shreyasubale ! It's probably means your npm install has failed please remove node_modules and try again.
shreyasubale
@shreyasubale
Feb 01 2016 08:16 UTC
I tried removing and reinstalling, facing the same isue. Using node v5.1.0
npm 0.29.0
Pavel Tiunov
@paveltiunov
Feb 01 2016 08:28 UTC
@shreyasubale could you please send your npm install logs?
shreyasubale
@shreyasubale
Feb 01 2016 08:52 UTC
there is no log in current directoty - i dont think anything failed
Pavel Tiunov
@paveltiunov
Feb 01 2016 08:55 UTC
@shreyasubale I mean console log.
Pavel Tiunov
@paveltiunov
Feb 01 2016 09:14 UTC
@shreyasubale It's usually caused by low memory issues.
shreyasubale
@shreyasubale
Feb 01 2016 09:17 UTC
let me try again and give you logs

➜ beerhug-admin npm install
npm WARN deprecated lodash@0.9.2: lodash@<2.0.0 is no longer maintained. Upgrade to lodash@^3.0.0
npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now out of date with respect to npm
npm WARN prefer global marked@0.3.5 should be installed with -g
npm WARN prefer global sqwish@0.2.2 should be installed with -g
npm WARN prefer global bower@1.3.12 should be installed with -g
npm WARN prefer global bower-installer@0.8.4 should be installed with -g

kerberos@0.0.11 install /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/kerberos
(node-gyp rebuild 2> builderror.log) || (exit 0)

CXX(target) Release/obj.target/kerberos/lib/kerberos.o

bson@0.2.22 install /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/bson
(node-gyp rebuild 2> builderror.log) || (exit 0)

CXX(target) Release/obj.target/bson/ext/bson.o

allcountjs@1.23.4 postinstall /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs
bower-installer

Setting up install paths...Finished
Running bower install...Finished
Installing:
allcountjs-angular-base : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/allcountjs-angular-base/allcount-base.js
angular-ui-sortable : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/angular-ui-sortable/sortable.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/css/blueimp-file-upload/jquery.fileupload.css
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/css/blueimp-file-upload/jquery.fileupload-noscript.css
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/css/blueimp-file-upload/jquery.fileupload-ui.css
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/css/blueimp-file-upload/jquery.fileupload-ui-noscript.css
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.postmessage-transport.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.xdr-transport.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.fileupload-process.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.fileupload-validate.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.fileupload-image.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.fileupload.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.fileupload-video.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.fileupload-ui.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.fileupload-audio.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.ui.widget.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jquery.fileupload-jquery-ui.js
blueimp-file-upload : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/lib/js/blueimp-file-upload/jqu

sorry for long paste
Pavel Tiunov
@paveltiunov
Feb 01 2016 09:20 UTC
You could use something like pastebin.com
Pavel Tiunov
@paveltiunov
Feb 01 2016 09:45 UTC
@shreyasubale seems like log is ok. Have you tried to run server again?
shreyasubale
@shreyasubale
Feb 01 2016 10:48 UTC
yes, having the same issue every time
Using db url: mongodb://localhost:27017/beerhug-admin
{ [Error: Cannot find module '../build/Release/bson'] code: 'MODULE_NOT_FOUND' }
js-bson: Failed to load c++ bson extension, using pure JS version
Failed to fetch "app-config". Trying to use as regular directory.
Application server for "app-config" listening on port 9080
LESS File error : '../lib/less/bootstrap/bootstrap.less' wasn't found
LESS File : /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/allcountjs/public/assets/less/main.less 1:0
Error
at new Parser (/Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/less/lib/less/parser.js:333:27)
at render (/Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/less-middleware/lib/middleware.js:153:18)
at /Users/shreyas.ubale/projects/beerhug/beerhug-admin/node_modules/less-middleware/lib/middleware.js:245:13
at tryToString (fs.js:414:3)
at FSReqWrap.readFileAfterClose [as oncomplete] (fs.js:401:12)
Pavel Tiunov
@paveltiunov
Feb 01 2016 10:50 UTC
@shreyasubale on what OS and what Node version you're running it? Some time ago there was similar issue with bootstrap fetching.
@shreyasubale could you please check out: http://sofa.developer-works.com/article/20490176/bower-installer+creates+duplicate+folder+with+trailing+dots . Probably you have the same issue
shreyasubale
@shreyasubale
Feb 01 2016 14:17 UTC
OS : OSX Yosemite 10.10.4
Node : v 5.1.0
shreyasubale
@shreyasubale
Feb 01 2016 14:59 UTC
cant see any folders with dots .. the less folder is empty ( in lib )
Chris
@picturaluce
Feb 01 2016 15:37 UTC
to see hidden folder on OSX (with dots at the beginning) do this: http://ianlunn.co.uk/articles/quickly-showhide-hidden-files-mac-os-x-mavericks/
Pavel Tiunov
@paveltiunov
Feb 01 2016 16:21 UTC
@shreyasubale could you find bootstrap in node_modules/allcountjs/public/lib ?
shreyasubale
@shreyasubale
Feb 01 2016 16:38 UTC
no