These are chat archives for allegro/ralph

17th
Dec 2014
✪ vi4m Marcin Kliks
@vi4m
Dec 17 2014 11:14
tak zintegrowana z githubem
możesz podglądać z prawej activitiy, wklejać markdown np tak
i widzieć podgląd bugów #1240 i commitów
Tomasz Mieszkowski
@xor-xor
Dec 17 2014 11:38
zgłoszone przez damiana:
z tego co widze przenosicie troche rzeczy z discovery do assetow.
w tej chwili jest maly zonk :smile:
ni emoge np w discovery ustawic modelu poprzez admina (inaczej sie nie da) bo przy zatwierdzaniu formularzu pojawia sie blad rzy polu management address, ktorego nie mozna zmienic bo go nie ma:smile:
Przy tworzeniu assetu i przejsciu pozniej do core'a mam model ustawiony na Unknown. Zeby go zmienic musze przejsc do admina , tam odszukuje wlasciwy model i chce kliknac przycisk Save. ale nie moge bo przy polu Management address (jest tam tylko etykieta bez textfielda) pojawia sie blad i nic nie moge zrobi. Jedyna opcja to mysql i update
u nas jest taka sytuacja ze nie mozna matchowac assetow i deviceow bo maszyny nie maja ustawionych S/N. Sugerwalem juz Wam, zebyscie tez taka sytuacja wzieli pod uwage i przy device byla mozliwosc wyboru asseta z reki bez automatycznego parowania
@vi4m - jakbyś mógł tu nieco światła rzucić to byłoby git
✪ vi4m Marcin Kliks
@vi4m
Dec 17 2014 11:41
tak @damian1976 ten ficzer z ręki wskazania załatwi Ci tą sytuację
powiedz tylko jaką masz wersję ralpha ?
damian1976
@damian1976
Dec 17 2014 11:41
czesc, przelaczylem sie na Wasza wersje develop i wiem, ze duzo jest teraz u Was rogrzebane, ale pozwalam sobie wkleic co nieco
ja ciagne teraz od Was z gita wszystko
✪ vi4m Marcin Kliks
@vi4m
Dec 17 2014 11:42
extra :fire:
to dorobimy ci ten ficzer i sobie wciągniesz updatem
damian1976
@damian1976
Dec 17 2014 11:42
ore'a asseta i scrooge'a bo wszystkie sa ze soba powiazane. np nie moge zcroogea z gta a reszta z pakietow bo nie pojdzie
✪ vi4m Marcin Kliks
@vi4m
Dec 17 2014 11:42
o to chodzi, ciągnij wszystko z developa na tym etapie
zakładałeś ticka na to ręczne wskazywanie asseta podczas skana?
damian1976
@damian1976
Dec 17 2014 11:45
ticka? w ktorym miejscu ui/ventures/venture_id/scan/ip_address ?
ticketa:) sorry
nie - nie zakladalem:)
a przy okazji tego linka powyzej - zlikwidowaliscie te funkcjonalnosc Select/Unselect All przy pluginach?. teraz sa wszystkie zaznaczone i nie moge ich odznaczyc. jak che miec zaznaczony 1 z 20 to musze pozostale 19 wyklikac :(
✪ vi4m Marcin Kliks
@vi4m
Dec 17 2014 11:50
to nie było usuwane
może odśwież sobie cache
damian1976
@damian1976
Dec 17 2014 11:56
hmm. wyczyscilem. klikniecie na Select All nie powoduje odznaczenia pluginow (gdy sa zaznaczone)
requesta utworzylem. Mam nadzieje, ze w dobrym miejscu :)
✪ vi4m Marcin Kliks
@vi4m
Dec 17 2014 12:41
damian?
napisałeś jakiś kod dla nas ? :)
zrób pull requesta do developa jeśli tak
teraz jest do brancha master
damian1976
@damian1976
Dec 17 2014 13:01
sorry:) to mam problem, jako base branch biore develop, jako compare biore Master. Wyswietla mi komunikat There isn't anything to compare.
✪ vi4m Marcin Kliks
@vi4m
Dec 17 2014 13:27
na jakim branchu swoim commitowałeś?
zrobiłeś git commit ?
git branch pokazuje ci na jakim jesteś branchu
git add plik.py && git commit -m ‚Moja poprawka’
damian1976
@damian1976
Dec 17 2014 13:30
ja do Was nic nie commitowalem. "Moje" male zmiany trzymam u siebie i dotycza one tylko scrooge'a. Requesta chcialem stworzyc bazujac tylko n a Waszym kodzie - chodzilo o dodanie tej funkcjonalnosci z matchowaniem asset<->device
takze zalozmy ze ja swojego kodu do Was nie wrzucalem zadnego
✪ vi4m Marcin Kliks
@vi4m
Dec 17 2014 13:30
to załóż buga
damian1976
@damian1976
Dec 17 2014 13:30
ok
tylko nie wiem czy ktos je czyta:)
#1242
damian1976
@damian1976
Dec 17 2014 13:37
#1238 - to tez by sie przydalo naprawic - mysle, ze nie jest to jakies trudne. Wspominalem tez ze "pasek" z linkiem, gdzie sie dokladnie znajduje w strukturze moglby caly czas u Was pozostac. Np jest problem jak mam np 10 podstron w Assetach i chce ktorys wyedytowac np z podstrony 8 . Edytuje, zapisuje. I jak powrocic do tej podstrony 8. W tej chwili musze z powrote kliknac na Asset i przeklikc sie do tej 8 podstrony. Majac pasek lokalizacji jednym kliknieciem wracam w miejsce, z ktorego przyszedlem.
to jeszcze 3cia kwestia. Openstack. Jesli po uruchomieniu 'ralph openstack' dostaje komunikat 'not configured' moze chodzic np. o problem ze zlym URLem, tak? dostalem od admina dane dot. openstacka, ale URLa nie byl pewien.
4ta - moglby ktos u Was sprawdzic z tym klikaniem na Select All w Scanie? i potwierdzic, czy sie odznacza?
✪ vi4m Marcin Kliks
@vi4m
Dec 17 2014 14:05
not configured = brak w settingsach wymaganych danych
damian1976
@damian1976
Dec 17 2014 14:12
hmm mam usera, haslo i url (ale narazie nie jestem go pewien)
✪ vi4m Marcin Kliks
@vi4m
Dec 17 2014 14:12
wklej tutaj, podpowiemy czy hasło jest dobre
damian1976
@damian1976
Dec 17 2014 14:13
:)
a moglbys podac jakis przykladowy url zebym mogl zobaczyc czy moze format jest wlasciwy
?
damian1976
@damian1976
Dec 17 2014 14:21
a nie musi byc openstack wpisany w settingsach w sekcji PLUGGABLE_APPS ?
lub COLLECT_PLUGINS
damian1976
@damian1976
Dec 17 2014 15:28
?