These are chat archives for allegro/ralph

16th
Apr 2015
damian1976
@damian1976
Apr 16 2015 13:30
pkg_resources.ContextualVersionConflict: (ralph-assets 2.4.0 (/home/ralph/ralph_assets/src), Requirement.parse('ralph-assets==2.5.0'), set(['ralph']))
w assetach src/init.py trzeba chyba zmienic VERSION z 2.4.0 na 2.5.0
✪ vi4m Marcin Kliks
@vi4m
Apr 16 2015 13:32
zrób make install na ralph
damian1976
@damian1976
Apr 16 2015 13:38
  1. (ralph)ralph@reseda:~/ralph_develop$ make install
    pip install -e . --use-mirrors --allow-all-external --allow-unverified ipaddr --allow-unverified postmarkup --allow-unverified pysphere
    --use-mirrors has been deprecated and will be removed in the future. Explicit uses of --index-url and/or --extra-index-url is suggested.
  2. https://github.com/allegro/ralph_assets/blob/develop/src/ralph_assets/__init__.py
    jest 2.4.0 zamiast 2.5.0 -> ?
damian1976
@damian1976
Apr 16 2015 13:54
co ciekawe:
(ralph)ralph@reseda:~/ralphassets$ more src/ralphassets/__init.py
VERSION = ('2', '4', '0')
(ralph)ralph@reseda:~/ralph_develop$ make install
pip install -e . --use-mirrors --allow-all-external --allow-unverified ipaddr --allow-unverified postmarkup --allow-unverified pysphere
....
Requirement already satisfied (use --upgrade to upgrade): ralph-assets==2.5.0 in /home/ralph/ralph_assets/src (from ralph==2.3.0)
...
dziwne...
ale ok. zmieniajac w init na 5 dziala. Bez zmiany jest komunikat requirement satisfied (dziwne) i komunikat
pkg_resources.ContextualVersionConflict: (ralph-assets 2.4.0 (/home/ralph/ralph_assets/src), Requirement.parse('ralph-assets==2.5.0'), set(['ralph']))
przy starcie serwera