These are chat archives for allegro/ralph

22nd
Jul 2015
Michael Akkermans
@MichaelAkkermans
Jul 22 2015 17:48
Having trouble installing Ralph doing manual install. Get message that scrooge is not installed. When installing it with pip, now i get the message "pkg_resources.VersionConflict: ... Requirement.parse('pbr>=0.6,<1.0')" . Following install-guide from Ralph's website. Help would be very much appreciated. :-)
After manual install of pbr with pip, now getting message that pbr must be >=1
Virtual environment setup and logged in as user ralph. Ptyhon path: /home/ralph/bin/python
Python 2.7.3, pip 1.1, OS Debian Wheezy 7.8, Servertype VM.
Michael Akkermans
@MichaelAkkermans
Jul 22 2015 17:53
If someone would be so kind as to push me in the right direction i would be very happy. Also if more details are needed please do ask. Did not want to clutter the IM with lots and lots of log output.
Michael Akkermans
@MichaelAkkermans
Jul 22 2015 18:35
Would like to add. Same problem in Ubuntu server 14.02. Did exactly what guide told me to do: https://ralph.readthedocs.org/en/latest/installation.html
(ralph)ralph@ralph:~$ ralph syncdb --all
No handlers could be found for logger "pluggableapp"
Traceback (most recent call last):
File "/home/ralph/bin/ralph", line 9, in <module>
...
...
File "/home/ralph/local/lib/python2.7/site-packages/django/template/loaders/app_directories.py", line 23, in <module>
raise ImproperlyConfigured('ImportError %s: %s' % (app, e.args[0]))
django.core.exceptions.ImproperlyConfigured: ImportError scrooge: No module named scrooge
then: (ralph)ralph@ralph:~$ pip install scrooge
Downloading/unpacking scrooge
Successfully installed scrooge python-ceilometerclient python-novaclient simplejson
Cleaning up...
Next:
(ralph)ralph@ralph:~$ ralph syncdb --all
Traceback (most recent call last):
File "/home/ralph/bin/ralph", line 9, in <module>
load_entry_point('ralph==2.3.1', 'console_scripts', 'ralph')()
File "/home/ralph/local/lib/python2.7/site-packages/ralph/main.py", line 56, in main
...
...
File "/home/ralph/local/lib/python2.7/site-packages/pkg_resources.py", line 592, in resolve
raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (pbr 1.3.0 (/home/ralph/lib/python2.7/site-packages), Requirement.parse('pbr>=0.6,<1.0'))
Then: (ralph)ralph@ralph:~$ pip install -I pbr==0.9
Successfully installed pbr pip
again: (ralph)ralph@ralph:~$ ralph syncdb --all
...
...
File "/home/ralph/local/lib/python2.7/site-packages/pkg_resources.py", line 592, in resolve
raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (pbr 1.3.0 (/home/ralph/lib/python2.7/site-packages), Requirement.parse('pbr>=0.6,<1.0'))
wuttt??? :-)
Michael Akkermans
@MichaelAkkermans
Jul 22 2015 20:29

Should be ok i guess...

(ralph)ralph@ralph:~$ pip show pbr

Metadata-Version: 1.1
Name: pbr
Version: 0.6

Michael Akkermans
@MichaelAkkermans
Jul 22 2015 20:52
I somehow managed to fix the issue. By uninstalling the modules the command "ralph syncdb --all" is complaining about, i somehow managed to got the stacktrace to tell me what version it did need. By manually installing the versions of different modules i managed to get it working. If someone is interested in the full details for debugging purposes, please contact me here :-)
Michael Akkermans
@MichaelAkkermans
Jul 22 2015 22:00
Reproduced the issue + solution that worked for me on debian and ubuntu: http://michael-akkermans.nl/?page_id=47 Im not a Python guru so forgive me for a strange workaround. It did the job so im happy. For me its a tool im looking at for use in a development space.
Nothing major or production