These are chat archives for allegro/ralph

20th
Aug 2015
Pierre-Yves Dubreucq
@pydubreucq
Aug 20 2015 09:39
Hi,
I saw that you only support Ubuntu 14.04 Trusty
I would like to know if someone try to test Ralph3 on Debian Jessie ?
Mateusz Kurek
@mkurek
Aug 20 2015 09:44
@pydubreucq probably not, but it should work fine - we do not depend on any ubuntu-specific package (for now, but we cannot predict what will be in the future); https://github.com/allegro/ralph/blob/ng/docker/provision.sh - here is list of our system packages dependencies
Pierre-Yves Dubreucq
@pydubreucq
Aug 20 2015 09:51
Ok thanks
I will try now on Debian Jessie and I will tell to you if it's work fine
Mateusz Kurek
@mkurek
Aug 20 2015 09:51
ok thanks
Pierre-Yves Dubreucq
@pydubreucq
Aug 20 2015 09:55
I've checked the list of packages and it's ok
Pierre-Yves Dubreucq
@pydubreucq
Aug 20 2015 16:41
Ralph3 seems to work fine on Debian Jessie
I just have this error when I use raplh command:

ralph createsuperuser
/opt/ralph/ralph-core/lib/python3.4/site-packages/django/contrib/contenttypes/models.py:159: RemovedInDjango19Warning: Model class django.contrib.contenttypes.models.ContentType doesn't declare an explicit app_label and either isn't in an application in INSTALLED_APPS or else was imported before its application was loaded. This will no longer be supported in Django 1.9.
class ContentType(models.Model):

/opt/ralph/ralph-core/lib/python3.4/site-packages/django/contrib/admin/models.py:28: RemovedInDjango19Warning: Model class django.contrib.admin.models.LogEntry doesn't declare an explicit app_label and either isn't in an application in INSTALLED_APPS or else was imported before its application was loaded. This will no longer be supported in Django 1.9.
class LogEntry(models.Model):

/opt/ralph/ralph-core/lib/python3.4/importlib/_bootstrap.py:321: RemovedInDjango19Warning: django.utils.importlib will be removed in Django 1.9.
return f(args, *kwds)

/opt/ralph/ralph-core/lib/python3.4/importlib/_bootstrap.py:321: RemovedInDjango19Warning: django.contrib.contenttypes.generic is deprecated and will be removed in Django 1.9. Its contents have been moved to the fields, forms, and admin submodules of django.contrib.contenttypes.
return f(args, *kwds)

Username:

I'd tested Ralph2 and I can say that Ralph3 is beautiful ;)
Thanks
✪ vi4m Marcin Kliks
@vi4m
Aug 20 2015 18:44
they are just general warnings, we will eventually get rid of them, will we @mkurek ?
glad you like new interface. It will improve even further (advanced search) and later - some visualization on the home screen