These are chat archives for allegro/ralph

21st
Jun 2016
Stefaan Vanbillemont
@kariboe
Jun 21 2016 12:59
hello all. discovered these great software today
i setup vagrant box with ubuntu and followed all installation steps for ralph 3 without problems
added entry in /etc/hosts to map easy url to ip of my vagrant box. When I navigate to this url I get nothing
cannot connect to this site/port
did i forget something? I disabled the firewall service on the vagrant box, but that didn't help
last command i ran: ralph runserver ralph.xxxxxxxx.be:8000
result: Starting development server at http://ralph.xxxxxxxx.be:8000/
Mateusz Kurek
@mkurek
Jun 21 2016 13:03
hi @kariboe . try to run ralph runserver 0.0.0.0:8000 and then connect in your browser to <YOUR VAGRANT IP>:8000 - see if this way is working
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:04
will try right away
@mkurek already progress
http://192.168.56.104:8000/login/?next=/ --> return Server Error (500)
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:06
dev_ralph runserver 0.0.0.0:8000 should show verbose error contents
dev_ralph == is like ralph command, but with the development settings enabled
Mateusz Kurek
@mkurek
Jun 21 2016 13:11
are you sure your provisioning has succeeded? Try to run cd src/ralph/ ; make install-dev
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:12
@mkurek /opt/ralph/ralph-core is part of vagrant sources ?
it looks like our debian package contents ? o_O
@kariboe did you use apt-get install method or just cloned from sources installation?
Mateusz Kurek
@mkurek
Jun 21 2016 13:13
hmm yes - you're right. @kariboe did you install ralph's deb in vagrant?
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:14
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:14
did you set DEBUG=true in /opt/ralph/ralph-core/lib/python3.4/site-packages/ralph/settings/prod.py ?
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:14
I did now :-)
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:15
Zrzut ekranu 2016-06-21 o 15.14.54.png
make sure these 4 steps are done, and try to run again with production mode (ralph)
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:16
should I rerun step 2 until 4 after I changed DEBUG=True?
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:16
no, if already made
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:16
ooooh .. it works now!
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:17
like magic.
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:17
thanks for the great assistance!
magic is great ;-)
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:17
don't forget to contribute and give feedback
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:18
I will! This software looks very promising!
great job!
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:18
thanks
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:19
is most of the ralph 2 documentation still valid for ralph 3?
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:20
i would say - ralph 3 has different documentation, quickstart is a good start http://ralph-ng.readthedocs.io/en/ng/user/quickstart/
so ralph 2 docs could be not compatible with the newest version
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:21
thanks! I will go and explore!
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:21
just use the latest
ok
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:21
is there a list of events where I can see/speak the Ralph team? (in europe)
✪ vi4m Marcin Kliks
@vi4m
Jun 21 2016 13:23
we will attend the europython conference
and we plan to make open Ralph Days in Poland, this fall
Stefaan Vanbillemont
@kariboe
Jun 21 2016 13:24
ok thanks for the update!