These are chat archives for allegro/ralph

2nd
Aug 2016
✪ vi4m Marcin Kliks
@vi4m
Aug 02 2016 14:26
@msuszko zdzwonimy się pogadać tak będzie łatwiej ;-)
Bryan Taylor
@brylor
Aug 02 2016 17:27
Hi all. I have Ralph3 deployed in docker... I'd like to add new "Cluster Status," but I see no option to change Cluster Status?
Bryan Taylor
@brylor
Aug 02 2016 18:05
I can't make my transitions unless I can specify my own states ?
is it not something from the GUI?
Bryan Taylor
@brylor
Aug 02 2016 18:19
found it in src/ralph/data_center/models/virtual.py ... what is the motivation to not have status in the DB?
I can just add to this list right? fordeploy = ('for deploy') reserved = ('reserved') free = ('free')
✪ vi4m Marcin Kliks
@vi4m
Aug 02 2016 18:43
Yes you can add it. The motivation is - we have some logic connected to this statuses
But it's safe to add to the list
Bryan Taylor
@brylor
Aug 02 2016 19:19
@vi4m seems I can't remove 'for deploy' or 'in use' I get: AttributeError: type object 'ClusterStatus' has no attribute 'in_use'
Other thoughts: How would I implement "blades?" I need to account for the enclosure and any parts inside of it
... then I have clusters of blades
✪ vi4m Marcin Kliks
@vi4m
Aug 02 2016 19:37
You can add statuses, not removing.
Just read QuickStart blades are included in docs.
Bryan Taylor
@brylor
Aug 02 2016 19:41
Ah I see it, sorry... too impatient for the quickstart :D
ty
I have a slack ruby bot talking to the API... so hopefully nobody has to ask me ever again the status of a cluster :)
Bryan Taylor
@brylor
Aug 02 2016 21:39
@vi4m I feel like I've done everything, and I can't get my blade to show up in DC view
Bryan Taylor
@brylor
Aug 02 2016 21:45
@vi4m http://ctrlv.in/815533 currently setup like this, but sslco0202 and sslco0203 do not show up in the rack
Bryan Taylor
@brylor
Aug 02 2016 22:11
Do I need to make a third asset for the "enclosure" and have that be the parent to my two node assets?
hrm
Bryan Taylor
@brylor
Aug 02 2016 22:30
Yeah... I did that and it seemed to work