Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Mateusz Kurek
@mkurek
@pydubreucq try with replace vi4m with allegrogroup
Pierre-Yves Dubreucq
@pydubreucq
Thanks, I've tried and I have mysql error
flashput
@flashput
Venture/Department/Business segment/Profit Center , how to understand the relations between them?
✪ vi4m Marcin Kliks
@vi4m
@pydubreucq - just do docker pull allegrogroup/ralph:latest and run : docker run -P -t -i -volumes-from mysql_data allegrogroup/ralph:latest /home/ralph/upgrade_ralph.sh
@mkurek could you push the new image ?
@pydubreucq remebert to stop all docker instances before upgrading.
@flashput there are some examples in initials file in upstream develop - ask @mkurek for details
flashput
@flashput
@vi4m If I change CI type name from /admin/cmdb/citype/, rename ci name of Environment from ‘Environment’ to other word like ‘Env’, should that operation affects any created environment entities?
Mateusz Kurek
@mkurek
@flashput - department you can treat as team responsible for all devices in venture (which is hierarchical container for devices). profit center is next level in hierarchy (over venture) - profit center is a section of a company treated as a separate business - profit center could group many ventures. business segment is top level in this hierarchy and it groups multiple profit centers. similar relations are used in CMDB services.
@flashput if you rename it (ex. in django admin) nothing should happen - we are using this CI id internally
flashput
@flashput
I tried, and when adding new devices , all pre-configured environments are all gone
Happens in my installation
Mateusz Kurek
@mkurek
do you remember that you have to choose service (with proper environments assigned in CMDB) on this form first?
flashput
@flashput
Before I modify ‘Environment’ to ‘Env', all environments are there as default , nothing have to choose first.
After my modification , nothing appeared even if I choose a ’Service catalog’
Mateusz Kurek
@mkurek
do you have anything not-ordinary in logs (ex. exceptions)?
flashput
@flashput
nothing printed out
similar things happened when I modify ‘Default region’ to ‘Default regions’.
✪ vi4m Marcin Kliks
@vi4m
I guess we should try to reprodouce it on devdemo instance.
flashput
@flashput
I can reproduce the behaviors on both docker image version and manual installation version.
✪ vi4m Marcin Kliks
@vi4m
So. Do you only change ci name field ?
flashput
@flashput
yes, if I change names back to Environment, everything goes OK again
Mateusz Kurek
@mkurek
ok - could you please create an issue for this in our github repo?
flashput
@flashput
OK, I’ll do it
damian1976
@damian1976
btw I don't know if it matters but in settings you can also find i.e. DEFAULT_REGION_NAME = 'Default region'
flashput
@flashput
since we can select different regions in the form , means there will be more than one region , not only the ‘Default region’. If add/modify cause unexpected results, people who needs multi regions will be confused.
for my situation, single region is fairly enough.
damian1976
@damian1976
hej, nie wiem czy jest moze Arek, do ktorego pisalem, wiec pozwole sobie jeszcze na ogolny: sciagnalem z developa django-bob, install, pozniej git pull na core i assets + install , migrate, collectstatic, restart servera, cache w przegladarce wyczyszczony
dostaje przy wyswietlaniu racka: http://dpaste.com/103WEDF
damian1976
@damian1976
Arku, jestes moze? udalob Ci sie zrobic te poprawke do bledu z wyswietlaniem Racka? W tej chwili nie mozna w ogole nic wyswietlic (procz góry szafy)
✪ vi4m Marcin Kliks
@vi4m
@damian1976 zrób pip freeze i wklej
damian1976
@damian1976
@vi4m tu w zasadzie chodzilo o poprawke allegro/ralph_assets#639 - tylko nie jest (chyba) ukonczona
Arkadiusz Adamski
@ar4s
@damian1976 już jest na ukończeniu, jeszcze ktoś drugi przejrzy i zaraz powinno byc w developie
damian1976
@damian1976
ok, fajnie
damian1976
@damian1976
wyglada na to, ze jest ok, dzieki:)
flashput
@flashput
In Site administration, there are 2 Data Centers, Discovery/Data Centers and Ralph_Assets/Data Centers, are they the same thing?
Arkadiusz Adamski
@ar4s
@flashput Data Center in discovery module is deprecated, please use Data center in assets
flashput
@flashput
Data Center in discovery module is still used in CMDB
damian1976
@damian1976
There's even 3rd DC - data center as a device (in discovery). This is DC is, in turn, displayed in hierarchy in ui/racks/
flashput
@flashput
Thanks @damian1976 , looking for the 3rd DC for almost 2 hours
damian1976
@damian1976
Co do obecnie komentowanego allegro/ralph#1349 chcialem Wam jeszcze zwrocic uwage na zgloszony juz dawno temu przez mnie problem allegro/ralph#1275 , dalej allegro/ralph#1246 oraz allegro/ralph#1238. Tak jak gdzies tam napisalem w opisie czasami poslugujecie sie nazwa, czasami ID. uwazam, ze w budowaniu linkow np powinniscie poslugiwac sie ID, a wyswietlac z kolei nazwe.
Arkadiusz Adamski
@ar4s
@damian1976 właśnie zajmuję się tym problemem, przywracamy poprzedni widok racków i przenosimy wizualizację w inne miejsce
damian1976
@damian1976
@ar4s ok. zwroc prosze uwage na budowanie sciezek w Core/Racks (juz po kliknieciu w dowolny DC w hierarchii po lewej). Podaje przyklad: Pod niebieskim poziomym menu jest sciezka Racks (z hiperlinkiem ui/racks/) , pozniej slash, pozniej kolejny hiperlink z moja nazwa DC i hiperlinkiem wskazujacym na /ui/racks/view/data_center_view/. Jego klikniecie daje Page Not Found. Takich miejsc jest sporo w UI (szczegolnie w okolicach Scan'a)
flashput
@flashput
how to create a selectable data center in ralph core?
flashput
@flashput
After all demo devices deleted in discovery/devices, I try to add data centers /racks on my own , but none of them can be selected in /ui/services page
✪ vi4m Marcin Kliks
@vi4m
@flashput discovering the proper way to add rack is hard currently . Fortunately @szok made some tutorial about it
flashput
@flashput
thanks @vi4m , I’ll talk to him
damian1976
@damian1976
Could you share the link if available?
Piotr Jarolewski
@szok
We're working on it, in a few days to be ready. :)
flashput
@flashput
Maybe I have discovered the proper way