Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
damian1976
@damian1976
hmm mialem caly czas zrobiony clone develope'a boba... najwyzej sciagne jescze raz z develope'a
Mateusz Kurek
@mkurek
git pull i pip install -e .
damian1976
@damian1976
zrobilem dla swietego spokoju: rm -rf django-bob, git clone -b develop https://github.com/allegro/django-bob.git, pozniej pip install -e . i to samo...
pip freeze | grep bob
-e git+https://github.com/allegro/django-bob.git@aa3dd5999f7f8f70e21cb3b855a8c73710869866#egg=django_bob-origin/develop
damian1976
@damian1976
jest ktos moze kto moglby pomoc?
damian1976
@damian1976
damian1976
@damian1976
This message was deleted
damian1976
@damian1976
problem solved...
✪ vi4m Marcin Kliks
@vi4m
@mkurek we need some easy way to install Ralph from develop
apart from docker
damian1976
@damian1976
pkg_resources.ContextualVersionConflict: (ralph-assets 2.4.0 (/home/ralph/ralph_assets/src), Requirement.parse('ralph-assets==2.5.0'), set(['ralph']))
w assetach src/init.py trzeba chyba zmienic VERSION z 2.4.0 na 2.5.0
✪ vi4m Marcin Kliks
@vi4m
zrób make install na ralph
damian1976
@damian1976
  1. (ralph)ralph@reseda:~/ralph_develop$ make install
    pip install -e . --use-mirrors --allow-all-external --allow-unverified ipaddr --allow-unverified postmarkup --allow-unverified pysphere
    --use-mirrors has been deprecated and will be removed in the future. Explicit uses of --index-url and/or --extra-index-url is suggested.
  2. https://github.com/allegro/ralph_assets/blob/develop/src/ralph_assets/__init__.py
    jest 2.4.0 zamiast 2.5.0 -> ?
damian1976
@damian1976
co ciekawe:
(ralph)ralph@reseda:~/ralphassets$ more src/ralphassets/__init.py
VERSION = ('2', '4', '0')
(ralph)ralph@reseda:~/ralph_develop$ make install
pip install -e . --use-mirrors --allow-all-external --allow-unverified ipaddr --allow-unverified postmarkup --allow-unverified pysphere
....
Requirement already satisfied (use --upgrade to upgrade): ralph-assets==2.5.0 in /home/ralph/ralph_assets/src (from ralph==2.3.0)
...
dziwne...
ale ok. zmieniajac w init na 5 dziala. Bez zmiany jest komunikat requirement satisfied (dziwne) i komunikat
pkg_resources.ContextualVersionConflict: (ralph-assets 2.4.0 (/home/ralph/ralph_assets/src), Requirement.parse('ralph-assets==2.5.0'), set(['ralph']))
przy starcie serwera
sjaredj
@sjaredj
really stupid question.....just installed the ralph docker....go to login....don't know the default login credentials. :(
I'm not a developer...just an end user who just heard about Ralph and wanted to kick the tires, but am stuck
Mateusz Kurek
@mkurek
@sjaredj user:ralph passoword:ralph
✪ vi4m Marcin Kliks
@vi4m
@sjaredj quickstart is your friend if you are new
sjaredj
@sjaredj
Awesome! That worked!
Thanks!
sjaredj
@sjaredj
Trying to get network discovery setup. The docs say "Go to ‘Networks’ module and find network you want to scan.".....what is the networks module? I can not see any more documentation on it and can't find the web page that shows in the screenshot in the docs.
✪ vi4m Marcin Kliks
@vi4m
You will need to upgrade Docker image.
@sjaredj we enabled it by default lately
sjaredj
@sjaredj
hmm....I installed the docker image two days. Its newer than two days?
root@a29a4275e8d1:~/.ralph# exit
[root@ut06minion02 ~]# docker images
REPOSITORY TAG IMAGE ID CREATED VIRTUAL SIZE
centos latest 0114405f9ff1 2 days ago 229.6 MB
allegrogroup/ralph latest 7ca4c79c2b42 3 days ago 884.5 MB
allegrogroup/ralph preview 7ca4c79c2b42 3 days ago 884.5 MB
busybox latest 4986bf8c1536 3 months ago 2.433 MB
[root@ut06minion02 ~]# docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
a29a4275e8d1 allegrogroup/ralph:latest "/root/start.sh" 15 hours ago Up 15 hours 0.0.0.0:8000->8000/tcp, 0.0.0.0:49164->22/tcp ralph
that shows I am running allegrogroup/ralph:latest and it was actually installed 3 days ago
sjaredj
@sjaredj
ok....
I did as you asked and grabbed the latest which says 29 hours ago....sure enough....looks like it is there. Thanks for the heads up!!
damian1976
@damian1976
Arku - dziala Ci DC View po ostatnich zmianach (hashowanie w nazwie pliku)?
✪ vi4m Marcin Kliks
@vi4m
cache odświeżałeś?
damian1976
@damian1976
tak, wszystko standardowo
bledow nie widze w przegladarce, za to przestal wyswietlac DC (gridy) i racki
✪ vi4m Marcin Kliks
@vi4m
wklej screena
damian1976
@damian1976
✪ vi4m Marcin Kliks
@vi4m
błąd pewnie gdzieś w js - jest?
damian1976
@damian1976
firebug w DCView nic blednego nie pokazuje
✪ vi4m Marcin Kliks
@vi4m
a odpal w innej przeglądarce
i powiedz czy pomogło
i później z dockera jak możesz
damian1976
@damian1976
explorer to samo
jesli chodzi o dockera to jeszcze z niego nie korzystalem ... musialbym zobaczyc co i jak
damian1976
@damian1976
u Was jest ok?
✪ vi4m Marcin Kliks
@vi4m
A robiłeś collectstatic ?
damian1976
@damian1976
tak, wszystko jak trzeba
damian1976
@damian1976
masz jakis pomysl? u Was wszystko biega z developa?
✪ vi4m Marcin Kliks
@vi4m
Tak
damian1976
@damian1976
hmm
zrobilem jeszcze raz pulla na core i assetach, collectstatic, wyczysciem cache'a w browserze, zrestartowalem server i workery. bez zmian