Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
developer1010
@developer1010
Does anyone know how to install version 2.3.0 instead of version 2.3.1? I need help!
xliiv
@xliiv
@developer1010 could you try pip install ralph==2.3.0?
developer1010
@developer1010
Ok. But now, i don't know how to access Ralph via web (with a IP). And another question: What's the name of the repository version 2.3.0?
Mateusz Kurek
@mkurek
repository is the same; run git clone https://github.com/allegro/ralph.git and then git checkout 2.3.0
✪ vi4m Marcin Kliks
@vi4m
@all does anybody attend the Europython this year?
GnR
@GnRRocks
@all Hello?
xliiv
@xliiv
@GnRRocks hi
✪ vi4m Marcin Kliks
@vi4m
nice nickname, @GnRRocks
GnR
@GnRRocks
@vi4m Thanks.
@xliiv @vi4m Work down,See u tomorrow.
damian1976
@damian1976
Hi guys. Is it possible to add rack accessory which occupies more than 1U?
✪ vi4m Marcin Kliks
@vi4m
Not possible afaik
damian1976
@damian1976
ok, thank you
damian1976
@damian1976
If possible it would be great to add (besides Position/Remarks/Orientation) the height of the accessory.
damian1976
@damian1976
Hi all, Today I encountered the problem after switching the ralph site to https. In the Asset/Add form there'is no lookup for Model, Service etc. When Selecting DC (In Additional Info) Server room list is also empty. Do you know why is that?
Mateusz Kurek
@mkurek
2 or ng?
damian1976
@damian1976
2.1
Mateusz Kurek
@mkurek
any error in browser console?
damian1976
@damian1976
yes,
"NetworkError: 404 Not Found - https://SERVER_ADDRESS/%2Fajax_select/ajax_lookup/KFZyYWxwaF9hc3NldHMubW9kZWxzClZEQ0Fzc2V0TW9kZWxMb29rdXAKdHAxCi4=?term=my model"
this one appears then doing the above
Michael Akkermans
@MichaelAkkermans
Having trouble installing Ralph doing manual install. Get message that scrooge is not installed. When installing it with pip, now i get the message "pkg_resources.VersionConflict: ... Requirement.parse('pbr>=0.6,<1.0')" . Following install-guide from Ralph's website. Help would be very much appreciated. :-)
After manual install of pbr with pip, now getting message that pbr must be >=1
Virtual environment setup and logged in as user ralph. Ptyhon path: /home/ralph/bin/python
Python 2.7.3, pip 1.1, OS Debian Wheezy 7.8, Servertype VM.
Michael Akkermans
@MichaelAkkermans
If someone would be so kind as to push me in the right direction i would be very happy. Also if more details are needed please do ask. Did not want to clutter the IM with lots and lots of log output.
Michael Akkermans
@MichaelAkkermans
Would like to add. Same problem in Ubuntu server 14.02. Did exactly what guide told me to do: https://ralph.readthedocs.org/en/latest/installation.html
(ralph)ralph@ralph:~$ ralph syncdb --all
No handlers could be found for logger "pluggableapp"
Traceback (most recent call last):
File "/home/ralph/bin/ralph", line 9, in <module>
...
...
File "/home/ralph/local/lib/python2.7/site-packages/django/template/loaders/app_directories.py", line 23, in <module>
raise ImproperlyConfigured('ImportError %s: %s' % (app, e.args[0]))
django.core.exceptions.ImproperlyConfigured: ImportError scrooge: No module named scrooge
then: (ralph)ralph@ralph:~$ pip install scrooge
Downloading/unpacking scrooge
Successfully installed scrooge python-ceilometerclient python-novaclient simplejson
Cleaning up...
Next:
(ralph)ralph@ralph:~$ ralph syncdb --all
Traceback (most recent call last):
File "/home/ralph/bin/ralph", line 9, in <module>
load_entry_point('ralph==2.3.1', 'console_scripts', 'ralph')()
File "/home/ralph/local/lib/python2.7/site-packages/ralph/main.py", line 56, in main
...
...
File "/home/ralph/local/lib/python2.7/site-packages/pkg_resources.py", line 592, in resolve
raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (pbr 1.3.0 (/home/ralph/lib/python2.7/site-packages), Requirement.parse('pbr>=0.6,<1.0'))
Then: (ralph)ralph@ralph:~$ pip install -I pbr==0.9
Successfully installed pbr pip
again: (ralph)ralph@ralph:~$ ralph syncdb --all
...
...
File "/home/ralph/local/lib/python2.7/site-packages/pkg_resources.py", line 592, in resolve
raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (pbr 1.3.0 (/home/ralph/lib/python2.7/site-packages), Requirement.parse('pbr>=0.6,<1.0'))
wuttt??? :-)
Michael Akkermans
@MichaelAkkermans

Should be ok i guess...

(ralph)ralph@ralph:~$ pip show pbr

Metadata-Version: 1.1
Name: pbr
Version: 0.6

Michael Akkermans
@MichaelAkkermans
I somehow managed to fix the issue. By uninstalling the modules the command "ralph syncdb --all" is complaining about, i somehow managed to got the stacktrace to tell me what version it did need. By manually installing the versions of different modules i managed to get it working. If someone is interested in the full details for debugging purposes, please contact me here :-)
Michael Akkermans
@MichaelAkkermans
Reproduced the issue + solution that worked for me on debian and ubuntu: http://michael-akkermans.nl/?page_id=47 Im not a Python guru so forgive me for a strange workaround. It did the job so im happy. For me its a tool im looking at for use in a development space.
Nothing major or production
✪ vi4m Marcin Kliks
@vi4m
@micmit007 don't forget to try out 3.x version
✪ vi4m Marcin Kliks
@vi4m
this time we provide deb package - apt-get install ralph-core http://ralph-ng.readthedocs.org/installation/
Michael Akkermans
@MichaelAkkermans
Hi vi4m thanks for your advice. Will look into it rightaway.
✪ vi4m Marcin Kliks
@vi4m
guys, i've just pushed the new ralph deb package
root@vagrant-ubuntu-vivid-64:/home/vagrant/import-lymph# dpkg -l "*ralph*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                              Version               Architecture          Description
+++-=================================-=====================-=====================-========================================================================
ii  ralph-core                        3.0.0-23              amd64                 Ralph is an DCIM/CMDB - asset management for Data Centers/ Back Office.
you can upgrade with the apt-get upgrade && ralph migrate
@mkurek dc part works fine, but the back office fails with "Key 'force_deprecation' not found in 'BackOfficeAssetForm'"
when adding back office asset
is it known issue?
Mateusz Kurek
@mkurek
Afaik @xlliv is working on that. @xlliv?
✪ vi4m Marcin Kliks
@vi4m
fine
xliiv
@xliiv
@vi4m @mkurek not yet i'd like to finish that 'simple change' :D with context-switch.. simple pasting example from foundation doen't work, so i'm debugging it
✪ vi4m Marcin Kliks
@vi4m
fingers crossed