by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
✪ vi4m Marcin Kliks
@vi4m
okay @micmit007
it should be very similar to 3.x version until we update it
so i recommend to stick with the quickstart: http://ralph.readthedocs.org/en/latest/quickstart.html
✪ vi4m Marcin Kliks
@vi4m
the difference is - we don't provide scanner yet
ivan-sv
@ivan-sv
hey, i have a couple of questions. First, can you elaborate more on what is the difference exactly between the Asset and a Device, it seems like i have to always create both Asset model and Device model for the same type of device whenever I want to add more. Second is if I have a switch (for example) connected to a physical host, I can link the host to the switch via the Inbound/Outbound connection in the Device properties in Admin panel, however, I can't seem to figure out how to link what port on the host is connected on what port on the switch, I do see the option in Core module when I look at the device that state "This Device Port Connected Device Connected Device Port", but i don't know how to link those to each other
connections between devices are handled by discovery scripts, we don't do this by hand
ivan-sv
@ivan-sv
so if i have 30 switches and over 200 servers, Ralph should be able to determine what is connected to what on it's own?
✪ vi4m Marcin Kliks
@vi4m
if you tune the lldp plugin by yourself - maybe
ivan-sv
@ivan-sv
is there no way to add this information manually? it would be good help. We don't want to allow access to ralph persay to scan the entire range of subnets
testing ralph 2.x at this time
✪ vi4m Marcin Kliks
@vi4m
Zrzut ekranu 2015-08-12 o 15.50.36.png
the answer is - no and yes ;-) we didn't expose in gui this functionality, but going to the admin site -> devices -> edit you will see
so you can manually set it if you want
ivan-sv
@ivan-sv
this is from ralph 3.x?
✪ vi4m Marcin Kliks
@vi4m
no, its still ralph 2.x - old version
ivan-sv
@ivan-sv
ah, right
✪ vi4m Marcin Kliks
@vi4m
it has admin panel included
ivan-sv
@ivan-sv
but i can't specify what port is connected to where?
✪ vi4m Marcin Kliks
@vi4m
no port names are there exposed
This message was deleted
ivan-sv
@ivan-sv
yes, i can see that, but it only tells me what device it's connected to, not necessarily the port on the device
✪ vi4m Marcin Kliks
@vi4m
that's true
ivan-sv
@ivan-sv
blob
✪ vi4m Marcin Kliks
@vi4m
it should be easy to add this missing field to this form
ivan-sv
@ivan-sv
blob
i'm looking for highlighted fields
so if i have a server with 4 network ports for example, i want to specify which ports on the switch they are connected to. Is this possible?
vi4m @vi4m is investigating
ivan-sv
@ivan-sv
also, if i add an asset such as a router or switch, can i specify how many ports it has and what type of ports they are eg. 1gb, 10gb, fiber etc. So i can then connect my devices across to it?
✪ vi4m Marcin Kliks
@vi4m
no, not implemented yet
we do this another way
ivan-sv
@ivan-sv
which way?
also, i have deleted the default dc from devices and now my rack view is empty, even though i have data center configured, how do i get it back so i can see the rack view?
blob
ivan-sv
@ivan-sv
Nevermind, i figured out the part with the Rack view :) just had to create devices for data center and racks separately, which is kind of weird imo, since it should pull this information straight from data centers and racks section when they are created, since you already able to see them in DC view :)
✪ vi4m Marcin Kliks
@vi4m
yes ivan-sv, we fixed it in ralph 3.x
ivan-sv
@ivan-sv
is ralph 3 still in development? I've clicked around it a bit from the link you provided, but for some reason i can't seem to find the section where you can configure device with the components it has. As in ralph 2 it was very extensive where you were able to modify device properties
This message was deleted
blob
also, i don't know if it's a bug in ralph 2.x, but it seems like for some devices i'm able to modify the physical parent field and for some I can't. Do you know why that is?
blob
ivan-sv
@ivan-sv
any input on this?
Pierre-Yves Dubreucq
@pydubreucq
Hi,
I saw that you only support Ubuntu 14.04 Trusty
I would like to know if someone try to test Ralph3 on Debian Jessie ?
Mateusz Kurek
@mkurek
@pydubreucq probably not, but it should work fine - we do not depend on any ubuntu-specific package (for now, but we cannot predict what will be in the future); https://github.com/allegro/ralph/blob/ng/docker/provision.sh - here is list of our system packages dependencies
Pierre-Yves Dubreucq
@pydubreucq
Ok thanks
I will try now on Debian Jessie and I will tell to you if it's work fine
Mateusz Kurek
@mkurek
ok thanks