Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Stefaan Vanbillemont
@kariboe
should I rerun step 2 until 4 after I changed DEBUG=True?
✪ vi4m Marcin Kliks
@vi4m
no, if already made
Stefaan Vanbillemont
@kariboe
ooooh .. it works now!
✪ vi4m Marcin Kliks
@vi4m
like magic.
Stefaan Vanbillemont
@kariboe
thanks for the great assistance!
magic is great ;-)
✪ vi4m Marcin Kliks
@vi4m
don't forget to contribute and give feedback
Stefaan Vanbillemont
@kariboe
I will! This software looks very promising!
great job!
✪ vi4m Marcin Kliks
@vi4m
thanks
Stefaan Vanbillemont
@kariboe
is most of the ralph 2 documentation still valid for ralph 3?
✪ vi4m Marcin Kliks
@vi4m
i would say - ralph 3 has different documentation, quickstart is a good start http://ralph-ng.readthedocs.io/en/ng/user/quickstart/
so ralph 2 docs could be not compatible with the newest version
Stefaan Vanbillemont
@kariboe
thanks! I will go and explore!
✪ vi4m Marcin Kliks
@vi4m
just use the latest
ok
Stefaan Vanbillemont
@kariboe
is there a list of events where I can see/speak the Ralph team? (in europe)
✪ vi4m Marcin Kliks
@vi4m
we will attend the europython conference
and we plan to make open Ralph Days in Poland, this fall
Stefaan Vanbillemont
@kariboe
ok thanks for the update!
Markusolavit
@Markusolavit
In ralph 2.3 impact analysis you can't check full path of the CI like. Router-switch-server-service except opening new tab for every CI. In ralph 3 would it be possible to have one chart where you can open every CI and watch the full relationship path? and also is it possible to get read-only configuration data to ralph from servers and in which form?
Markusolavit
@Markusolavit
and is API different in 3 than in 2.3?
✪ vi4m Marcin Kliks
@vi4m
@Markusolavit it's hard to say, we don't have on our roadmap complete graph presentation
if open source community make such a feature, i think we can merge it into 3
Markusolavit
@Markusolavit
Okay, that would be great feature :),, And how about getting read-only configuration data to ralph?
✪ vi4m Marcin Kliks
@vi4m
hm. What does it mean?
any examples?
Markusolavit
@Markusolavit
like server is running apache, and ralph would show its configuration in servers information
only text
✪ vi4m Marcin Kliks
@vi4m
we have something in development called ralph-cli https://github.com/allegro/ralph-cli
which can scan servers and put information about disks, configuration, firmware, operating system and so on
Markusolavit
@Markusolavit
okay have to check it out
thanks :)
neW1-
@neW1-
Hi guys, I'm running into a weird issue. I can't see the toolbar but and have reports of everyone else on the team that the toolbar is missing. Ralph3 is deployed on an Ubuntu 14.04 server via the deb package and i have followed the instructions to the dot. Here is a screenshot https://www.dropbox.com/s/0i5e2dnmvki0av4/Screenshot%202016-06-23%2019.22.27.png?dl=0
has anyone else ran into an issue like this? Thanks
Mateusz Kurek
@mkurek
hi @neW1- . Did you log in as a superuser? If yes, then did you run menu creation? ralph sitetree_resync_apps?
neW1-
@neW1-
hi @mkurek , yes i am logged in as a super user and have run that command. I will try again now and let you know if it helps
getting an error when i run that command... just noticing that
Mateusz Kurek
@mkurek
@neW1- allegro/ralph#2496 - here is fix for your bug - it'll be merged tomorrow
neW1-
@neW1-
@mkurek thanks! How much time would it usually take to reach the debian repository?
Mateusz Kurek
@mkurek
about 15-20 minutes after the PR will be merged (it's uploaded automatically)
neW1-
@neW1-
i updated to the latest ralph-core just now and get a 500 internal error when i try to visit the web page. Also getting the same errors when trying to resync the menus
Mateusz Kurek
@mkurek
@neW1- the newest deb wasn't uploaded yet to debian repo
neW1-
@neW1-
My bad, debug=true got reverted to false after the upgrade, no more internal errors
oh ok, i'll wait for it
Mateusz Kurek
@mkurek
@neW1- new deb should be in repo
neW1-
@neW1-
@mkurek thanks, i can confirm that it is indeed fixed!
Mateusz Kurek
@mkurek
great! i'll fix this annoying debug=true bug soon too :)
neW1-
@neW1-
awesome