Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
swb
@spencewb16_twitter
hey everyone - i am done making customizations i want for now. now i want to run the app for real instead of using ralph runserver 0.0.0.0:8000. what should i do? what is best practice?
Miriam Cox
@marzipanic
nginx or apache, I assume
swb, did you use Vagrant when installing ralph?
swb
@spencewb16_twitter
i did not
justinlos
@justinlos
Hi all, just have a quick question that I hope would be quick to answer. Regarding the usability of Ralph: WRT Racks, are there PDU specific options or should everything be added as an accessory at the moment?
I found some information in the github issues, and it pointed to the possibility, but I'm unaware of where to find the settings or visualizations.
justinlos
@justinlos
I apologize if this is not the place to ask this.
Miriam Cox
@marzipanic
Hmm, wondering what is causing the server error on my end then
✪ vi4m Marcin Kliks
@vi4m
@marzipanic did you set settings?
export DATABASE_NAME=ralph
export DATABASE_USER=someuser
export DATABASE_PASSWORD=somepassword
export DATABASE_HOST=127.0.0.1
export PATH=/opt/ralph/ralph-core/bin/:$PATH
export RALPH_DEBUG=1
Miriam Cox
@marzipanic
Yep
But, I should note that the machine I was on did not initially have a home directory for me
So I made one, made the .profile file, then slapped this in it
✪ vi4m Marcin Kliks
@vi4m
please make sure env variables are set correctly
like echo $RALPH_DEBUG
i think it might be an issue
Miriam Cox
@marzipanic
Ah, thanks :-)
I will try that
swb
@spencewb16_twitter
I really just want to run ralph as a service, and have it start up in /etc/init.d, not really going as far as apache, etc.
✪ vi4m Marcin Kliks
@vi4m
@mkurek could write such a script ;-)
we always have something more important, and it's quite easy to do
damian1976
@damian1976
@spencewb16_twitter you can look at as an example http://stackoverflow.com/questions/22336075/linux-process-into-a-service
Bram
@Oreios
Hello :)
@xliiv Catching you here ;)
xliiv
@xliiv
ok then you're using deb?
Miriam Cox
@marzipanic
Back at this project. When i run "echo $RALPH_DEBUG" it kicks back "1"
(So, still not able to get Ralph working.)
I mean, that should be correct, since I have debug mode turned on, per the settings. But for whatever reason, I still get a 500 error when attempting to visit the IP address of the site
Miriam Cox
@marzipanic
I should note, that visiting the IP kicks me to "http://10.139.42.183/login/?next=/" so redirect is working. But for whatever reason, nothing shows up there. Hmm.
(Just a 500 server error)
✪ vi4m Marcin Kliks
@vi4m
when you do sudo it probably clear this variables
maybe try something like "sudo su -" and then set all variables, and then run ralph ...
(i'm just guessing right now)
setting RALPH_DEBUG should show all messages instead of 500
so i suppose it is not recognized
Miriam Cox
@marzipanic
Ahhh, hmm.
Miriam Cox
@marzipanic
Ralph command isn't recognized for the root user
hm.
✪ vi4m Marcin Kliks
@vi4m
you have to export all variables again (including PATH)
Miriam Cox
@marzipanic
Did that, and checked (with env command)
Still getting server 500.
I will try running this on a fresh ubuntu install next week. Could be an issue with the set up I'm on.
✪ vi4m Marcin Kliks
@vi4m
maybe @mkurek has some idea
looks more like an installation issue to me
swb
@spencewb16_twitter
http://ralph.readthedocs.io/en/latest/installation.html#apache I've been trying to follow this, but i think this is for an older version. is there an updated doc on how to deploy ralph using apache?
✪ vi4m Marcin Kliks
@vi4m
no at the moment.
should be quite similar, we still use gunicorn
but we prefer nginx