Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
bencheikh
@bencheikh
which settings exactly ?
✪ vi4m Marcin Kliks
@vi4m
debian or ubuntu?
bencheikh
@bencheikh
debian jessie
✪ vi4m Marcin Kliks
@vi4m
and which package version?
bencheikh
@bencheikh
Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux
✪ vi4m Marcin Kliks
@vi4m
dpkg -l ralph-core
bencheikh
@bencheikh
||/ Name Version Architecture Description
+++-===========================-==================-==================-============================================================
ii ralph-core 3.0.0-11 amd64 Ralph is an DCIM/CMDB - asset management for Data Centers/ B
✪ vi4m Marcin Kliks
@vi4m
this is a prehistoric ralph version
bencheikh
@bencheikh
Wich one should install
✪ vi4m Marcin Kliks
@vi4m
the latest (highest build)
bencheikh
@bencheikh
ralph-core_3.0.0-snapshot-20170120-7552_amd64.deb
this one is Ok ?
just to make sure :p
✪ vi4m Marcin Kliks
@vi4m
@mkurek can we issue the new one ?
Mateusz Kurek
@mkurek
I'll do it tomorrow
✪ vi4m Marcin Kliks
@vi4m
swb
@spencewb16_twitter
has anyone given thought to "shared IP addresses"?... in other words. if i have 2 servers that are primary and listener (e.g. specifically sql always on in mind) i'd like to have an ip address that can be attached to both?
✪ vi4m Marcin Kliks
@vi4m
what about VIP-s in this case ?
well how can you avoid network ip collisions in this case? Do you attach 2 ip addresses to different machines in the same LAN ?
✪ vi4m Marcin Kliks
@vi4m
Or - maybe you mean - active / passive scenario when only one ipaddress is reachable at a time?
swb
@spencewb16_twitter
Yes the last one. Active/passive kinda dealio
bencheikh
@bencheikh
@vi4m Good Morning and thank you i will try it :)
✪ vi4m Marcin Kliks
@vi4m
@bencheikh it seems we need to do another build today since the last one still doesn't work
I fixed it yesterday
bencheikh
@bencheikh
Ok I will wait for your confirmation and then i will install it
✪ vi4m Marcin Kliks
@vi4m
Yeah.
✪ vi4m Marcin Kliks
@vi4m
i’ve scheduled new build, waiting
✪ vi4m Marcin Kliks
@vi4m
@bencheikh this is the most up2date build, it works great on jessie: https://bintray.com/vi4m/ralph/ralph/3.0.0-snapshot-20170515-7975#files/dists/jessie/main/binary-amd64
Zrzut ekranu 2017-05-15 o 14.36.34.png
I followed the installation manual and worked just fine
Jim Ntosas
@purplexss
ty vi4m! :)
Ruslan Vakilov
@supaflyster
Good morning! Setting up ralph3 now and have a minor but mysterious issue. maybe somebody can point where to look at. I've set it up with LDAP backend, it all works if I run app via "ralph runserver 127.0.0.1:8000"but when I run it via gunicorn as a daemon I can only login with local user but not with LDAP user. Any help is appreciated :) (Ubuntu 14.04, installed ralph via apt)
bencheikh
@bencheikh
@vi4m Thank you Boss i wil test it
Ruslan Vakilov
@supaflyster
I have my LDAP config in prod.py, is it possible that wsgi when starts ignores this setting?
Mr Black
@lip177891840
hello :)
here is my problem:
I want to reload result table only by using Ajax when clicking the "Filter" button,
and I have no idea how to make it ,
518.PNG
✪ vi4m Marcin Kliks
@vi4m
@supaflyster yeah, that's what i think.. some settings missing
Jungle93
@Jungle93
which version the django-debug-toolbar specified?it seems not so good to get from a git commit .
Roman Prykhodchenko
@romcheg
@mkurek could you please merge this one allegro/ralph#3039 ?
Christopher
@ni-christopher
Hi all - I have a problem with populating the "is_active" and /or "is_staff" attribute of the actual django user object while using django-auth-ldap. I narrowed it down to the fact, that Ralph is catching up the populate_user.send() event and reverts the values from django-auth-ldap (which are defined by the Setting AUTH_LDAP_USER_FLAGS_BY_GROUP).
Does someone had the same problem? Is there a Ralph setting which could result in such problem?
Christopher
@ni-christopher
@vi4m Hi. I'm about to start a new Issue according to LDAP Authentication with OpenLDAP. Would be great if you could take a look and may have an Idea, whats the problem.
✪ vi4m Marcin Kliks
@vi4m
sure, go ahead @ni-christopher. It seems we need more data
to analyze your particular problem. Do you have one?
Christopher
@ni-christopher
The main problem is the "active" flag after the user creation. If the user got synced by the OpenLDAP, the active flag is unset.
I played around with MappedGroupOfNamesType and tried to map the user-group against the Ralph-Group. But this doesn't work either.
Because of our OpenLDAP does not have any memberOfAttribute at the User level.
The behavior is, that the user is being created and synced with the LDAP but not able to login.
✪ vi4m Marcin Kliks
@vi4m
@mkurek it seems like you know a bit about this part of codebase? any ideas?
Christopher
@ni-christopher
If I turn off AUTH_LDAP_ALWAYS_UPDATE_USER and set the active flag or add the user to the activeGroup, the User is able to log in. But thats no option for us :(