Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Richlv
@richlv
But looks like that symlink made it attempt to use the system pip3. Virtualenv did not have Python3, apparently. So I gave up last night, might try later to force venv with Python3.
Roman Prykhodchenko
@romcheg
right, that what dh-virtualenv does
Richlv
@richlv
Ah, dh-virtualenv seems to be a Debian specific thing. No, not aware of what exactly it does or any equivalents for RHEL.
Roman Prykhodchenko
@romcheg
it prepares a virtualenv and manages links so they actually work on the destination system
Richlv
@richlv
I guess that would still have to be prepared by somebody for Ralph?
Roman Prykhodchenko
@romcheg
right
we simply don't have enough human power to make and support something like that
xiaomabetter
@xiaomabetter
image.png
how to set the single grid Size ?
Richlv
@richlv
Roman, completely understood. If I get it running, will post the steps online. The existing ones I found don't cut it.
xiaomabetter
@xiaomabetter
how to use ralph_pricing ? when i install https://github.com/allegro/ralph_pricing ,I find that the package of ralph_pricing required is different from ralph-core ! when ralph_pricing is installed , the ralph-core can not run up !
xiaomabetter
@xiaomabetter
How does ralph_scrooge work with Ralph ?
imvad
@imvad
Hi guys, is there any update with this issue? allegro/ralph#3077
LDAP Authentication with OpenLDAP and Ralph3
CaptainSifff
@CaptainSifff
I wouldn't call this an update... but I'll share my changes to get it working...:
Richlv
@richlv
I managed to have "make install" finish without obvious errors after forcing venv to be Python 3, but after that there is no executable "ralph". What could have gone wrong?
Re-running "make install" doesn't throw any errors either.
"ralphctl" references ralph-core, but that directory does not exist.
Richlv
@richlv
Very much blocked by that with installing Ralph. Anybody with an idea why that executable could be missing?
Marek Bleschke
@MarekBleschke
Hi @richlv, "make install" doesn't create "ralph" command. It only installs dependencies to your python venv. To get ralph command you would need to install through setup.py, ie. "python setup.py install". For more complete giude of installation you can look here: https://ralph-ng.readthedocs.io/en/stable/installation/installation/ and https://ralph-ng.readthedocs.io/en/stable/development/development_environment/.
Official docs do not deal with RHEL much.

There was at least one error:

Extracting ralph-20190807.1-py3.4.egg to /opt/ralph/ralphvenv/lib/python3.4/site-packages
File "/opt/ralph/ralphvenv/lib/python3.4/site-packages/ralph-20190807.1-py3.4.egg/ralph/ssl_certificates/tests/api.py", line 12
self.certificate1: SSLCertificate
^
SyntaxError: invalid syntax

Richlv
@richlv
Uhh, in the end it's running and I managed to log in - huge help for all the help :)
Ergh. Huge thank you.
sere
@sere
Hi everybody, a quick configuration question: is there a configuration parameter that enables custom fields for components?
sere
@sere
Is it provided/planned for?
sere
@sere
In particular, we need to store the serial number for the memory component. Is it supported in any way?
Fabian Krack
@onibox
Hi. I'm currently working on an RPM package for Ralph. On CentOS SELinux denies to create the home directory for the ralph user at /var/local/ralph. Not sure how SELinux (or equivalent) behaves on Debian-based distributions, but it's the first time for me creating a home directory under /var/local. Is there a specific reason for this directory location?
sere
@sere
I found that components have a "model" object associated that's only accessible via the web interface. It would partially solve my requirements, but I need access to it via the API. Is there a specific reason why it's not?
Nekasas
@Nekasas
Hello everyone. So I installed this ralph on new Ubuntu and now my page is not loading any images
[10.09.2019 07:19:46,147] WARNING [MainProcess 3504] base - Not Found: /static/src/js/ralph-autocomplete.13d61526c8b6.js
[10.09.2019 07:19:46,159] WARNING [MainProcess 3506] base - Not Found: /static/vendor/js/foundation-datepicker.b36e3fbb5331.js
[10.09.2019 07:19:46,172] WARNING [MainProcess 3504] base - Not Found: /static/src/js/foundation-datepicker-init.78976d2e8159.js
Could someone help me to understand what I am doing wrong
sere
@sere
hello @Nekasas . Can you provide more information on that? Did you follow the tutorial on https://ralph-ng.readthedocs.io/en/stable/installation/installation/ ?
Nekasas
@Nekasas
sorry I forgot to mention, problem was that I used 8000 port instead of 80 :)
sere
@sere
So you solved it? good to know :)
Chris
@chrisrbmn
Hi All, just wanted to reach out to see if there were any concrete plans yet to get LDAP authentication with Active Directory working? If there is a working way to use AD auth documented, could anyone point me to that location? Thanks!
Nekasas
@Nekasas
Hello again, I noticed 1 bug. I tried to create data center asset with hostname testingÄ–Ä™ and I got Error 500.
from log I can find this line
django.db.utils.OperationalError: (1366, "Incorrect string value: '\xC4\x99\xC4\x97\xC4\x8D...' for column 'hostname' at row 1")
sere
@sere
Hello again too. Is the history of an object accessible via API? how do I do that?
CaptainSifff
@CaptainSifff
Not sure if it helps:
for LDAP:
@chrisrbmn and here's my stab at getting LDAP working:
Chris
@chrisrbmn
@CaptainSifff - Does that work with AD though? I am really looking for a solid documented implementation that is specific to Active Directory.
CaptainSifff
@CaptainSifff
You can't copy and paste it, since I connect it to OpenLDAP. You have to adapt it to the data that is in AD, as usual. See e.g. as done for another system here: https://support.sugarcrm.com/Knowledge_Base/Password_Management/Configuring_LDAP_Authentication_Using_Active_Directory/
of course it would be great if you open an issue on github documenting your success :-)