These are chat archives for alvarosanchez/spring-security-rest

12th
Aug 2015
Luis Muniz
@LuisMuniz
Aug 12 2015 14:30

Hi just in case someone else hits this roadblock. I was getting this error when starting up the application (grails-2.5.1) hosting spring-security-rest (1.4.0):

| Error 2014-07-22 17:47:55,824 [localhost-startStop-1] ERROR plugins.DefaultGrailsPluginManager  - Error configuring dynamic methods for plugin [springSecurityCore:2.0-RC4]: null
Message: null
    Line | Method
->>  327 | compileStaticRules        in grails.plugin.springsecurity.web.access.intercept.AnnotationFilterInvocationDefinition

When I switch to using spring-security-core-2.0-RC3 (instead of 2.0-RC4), the error does not occur. And when I switched back to RC4, the error disappeared. Some kind of caching issue, but i ran clean-all about a googol times with no results