Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 24 13:10
  • Oct 22 01:08
    andrewc910 review_requested #1236
  • Oct 21 22:51
    andrewc910 edited #1236
  • Oct 21 22:51
    andrewc910 commented #1236
  • Oct 21 22:49
    andrewc910 edited #1236
  • Oct 21 22:42
    andrewc910 edited #1236
  • Oct 21 22:29
    andrewc910 synchronize #1236
  • Oct 21 20:40
    andrewc910 synchronize #1236
  • Oct 21 17:28
    andrewc910 commented #1236
  • Oct 21 17:26
    andrewc910 synchronize #1236
  • Oct 21 17:19
    andrewc910 synchronize #1236
  • Oct 21 16:28
    andrewc910 synchronize #1236
  • Oct 21 15:17

    drujensen on master

    Plugin: Add support for a confi… (compare)

  • Oct 21 15:17
    drujensen closed #1235
  • Oct 21 13:48
    andrewc910 synchronize #1235
  • Oct 21 13:46
    andrewc910 commented #1235
  • Oct 21 13:46
    andrewc910 commented #1235
  • Oct 21 13:43
    andrewc910 synchronize #1235
  • Oct 21 12:08

    drujensen on master

    Change the path (#1237) * Chan… (compare)

  • Oct 21 12:08
    drujensen closed #1237
Stephen Jackson
@sjackson
Hi I'm new to amber really liking the speed but I was wondering if it supports crystal 35.1?
Andrew
@andrewc910
@sjackson Yes 0.35.1 is supported. Its the crystal version I use 😁
Massimiliano Bertinetti
@maxbertinetti

Hi guys

Unable to satisfy the following requirements:

- `pg (~> 0.21.1)` required by `amber 0.35.0+git.commit.4e749b4cc6a6abab470f9fd2c147d77b018a6a17`
- `pg (branch master)` required by `clear 0.8+git.commit.4120e5e9bdea4d1ea78c9c7c74b6deb65bfcebe2`
Failed to resolve dependencies

It’s something that can be resolved?

(Also I think is the same version….)
Andrew Smith
@silentworks
I'm trying to upgrade from amber 0.9.0 to 0.35 and I am being hit with errors all over, I am now getting this error which doesn't have much meaning to me right now and I can't see anything in the controllers in 0.35 that has changed this drastically.
Error: can't infer the type of instance variable '@comment' of CommentController
George Dietrich
@Blacksmoke16
wew, 0.9.0 to 0.35.0
Andrew Smith
@silentworks
hehe
Yeah I haven't touched this project in a while and haven't done much with amber since
George Dietrich
@Blacksmoke16
i imagine most of the errors are going to be due to crystal changes
Andrew Smith
@silentworks
Screenshot 2020-09-04 at 21.22.13.png
So in my newly installed amber 0.35 app, I can't get it to build either because its complaining about log ^
George Dietrich
@Blacksmoke16
what crystal version are you on?
Andrew Smith
@silentworks
0.30.1
George Dietrich
@Blacksmoke16
yea you'll need to update
0.35.1 is latest
and required
Andrew Smith
@silentworks
ok trying again now with that version
If that works then it might be easier to rewrite all my code in this new project than trying to upgrade the 0.9.0 one
George Dietrich
@Blacksmoke16
whats the project?
Andrew Smith
@silentworks
its a reddit clone
just a pet project
George Dietrich
@Blacksmoke16
gotcha
Andrew Smith
@silentworks
ok the build worked on the new amber project now that I upgraded to 0.35.1 of crystal
George Dietrich
@Blacksmoke16
:tada:
Elias Perez
@eliasjpr
Nice!
Andrew Smith
@silentworks
if I modify a model, would that create a new migration if amber watch is running?
George Dietrich
@Blacksmoke16
i doubt it, prob easy enough to try it tho
Andrew Smith
@silentworks
I'm almost certain in 0.9.0 there was something like rails g migration where you could also pass the filed names amber g migration add_new_fields_to_model name:string email:string
was this ever the case or was I dreaming
its so hard to remember things from 2 years ago
George Dietrich
@Blacksmoke16
i think it is, granted i never used amber so only going off of what i heard :P
Andrew Smith
@silentworks
oh right, I thought you were a amber core dev
George Dietrich
@Blacksmoke16
more so granite
Stephen Jackson
@sjackson
@andrewc910 Excellent!
Andrew Smith
@silentworks
The code examples in the documentation is hard to read due to the colours chosen
Screenshot 2020-09-08 at 11.55.17.png
George Dietrich
@Blacksmoke16
mine has white text, try clearing cache/refreshing
or maybe you have some extension thats altering it
Andrew Smith
@silentworks
That's weird, because in Firefox its that way but in Chrome I see white text
Andrew Smith
@silentworks
I'm now convinced that Firefox is mad, it's stating the correct colour in the developer tools while displaying the wrong colour on screen.
Andrew Smith
@silentworks
So turning off the font-family on the code section fixes the issue, it seems it doesn't like something about Source Code Pro font
Damian Hamill
@damianham
@eliasjpr @drujensen I just opened a PR #1231 that fixes the json response Content-Type header. I would appreciate a quick review (it's a 1 line change) and merge so I can deploy to production without editing the amber src each time. Thanks
Elias Perez
@eliasjpr
@damianham I have reviewed and approved
Damian Hamill
@damianham
:thumbsup: thanks @eliasjpr
Massimiliano Bertinetti
@maxbertinetti
@damianham you are an Amber Recipes expert: please I just created a new one but give me this error:
Missing shard.yml. Please run 'shards init'
Environment file not found for ./config/environments/production
The files are present, but I think the problem is the extension. Mine is .ecr, in your recipes is .lqd
Can be the format the problem?
I started with the template of the amber framework directly and added the feature that I want...
Hai Nguyen
@greentornado
Hi i got 403 error whenever enable plug Amber::Pipe::CORS.new on api pipeline
how do i fix that please
Hai Nguyen
@greentornado
okay, after I added Origin Headers to the request, it works