Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Venu Vardhan Reddy Tekula
    @vchrombie
    Hey Everyone. I created this room specially for the project, Qujini. Anyone who has doubts regarding the project can ask here.
    Nishant Pandey
    @nipan09
    Venu Bhaiya, I was rebasing the last PR regarding issue #15 using git rebase -i origin/master , its showing error: invalid line 1 while trying with both 'Indentation error fixed' and 'Indentation fixed', what should I do?
    Ashwin Shenoy
    @aswinshenoy
    @nipan09 if you could also share the screenshot of the problem you are facing, it will help us to better understand the problem and help you out with it. :)
    Perhaps, I don't understand, why you had to do a rebase? Please fork the repo, make changes, commit, push, and send in a PR :)
    Nishant Pandey
    @nipan09
    @aswinshenoy , thank you for your quick response. I had resolved the issue.
    Ashwin Shenoy
    @aswinshenoy
    Cool @nipan09, welcome to the community :) Looking forward to contributions from you. Ping back for any help.
    Nishant Pandey
    @nipan09
    @aswinshenoy there is a little doubt, my master branch is already 1 commit ahead of amfoss:master but the master branch is under PR and I had created another branch through it and so that branch is also 1 commit ahead.
    I need to send a PR for #8 and so it will show the changes made for the issue #15 also. So, is it fine or shall i reset my master branch and create another branch and solve the issue again?
    Because my master branch is one commit ahead of amfoss:master, the respective change of issue #15 will be showing in every PR.
    Ashwin Shenoy
    @aswinshenoy
    Its a general practice to keep the master of your fork synced with the master of thr remote/upstream (amfoss:master, in this case).
    While implementing new features, fixing bugs, its recommended that you make a branch from lastest master and work on that new branch. Once you are done with it, open a pull request from that branch in your fork (which fixes the issue) to amfoss:master.
    Now in your case, you can reset your master syncing it with amfoss:master, and then create new branches for solving each issue.
    Ashwin Shenoy
    @aswinshenoy
    Hope that clarifies. Feel free to ping back if you feel stuck somewhere, since the project is pretty new, we haven't documented anything or setup any condributor guidelines yet. :-D
    Nishant Pandey
    @nipan09
    @aswinshenoy thanks for your reply. I knows the fact that the master branch should be synced with the master of remote/upstream. It was a mistake that I merged the two branches while solving the first issue.
    There's already a PR sent for issue #8 in which the the solution of even the first solved issue is also mentioned. Please consider that PR as a PR for issue #8 . The new PRs will be perfect and fine in future.
    Nishant Pandey
    @nipan09
    @aswinshenoy , for the issue #9 , the forgot password link is created but I cant able to change the background colour of the admin login site. I have created a directory- templates/admin/base_site.html under Qujini directory. Here is the code for background colour which I tried-

    **{% extends "admin/base.html" %}
    {% load i18n %}

    {% block title %}{{ title }} | {% trans 'Django site admin' %}{% endblock %}

    {% block extrastyle %}

    <style type="text/css">
    body.login {background-color: #008000;}
    </style>
    {% endblock %}**

    {% block branding %}

    <h1 id="site-name">{% trans 'Admin Login' %} </h1>
    {% endblock %}

    {% block nav-global %}{% endblock %} **

    Nishant Pandey
    @nipan09
    And also I have tried to change the site header into a logo by using <img src= {{site_header}} tag in {% blockbranding %} but not getting the issue solved. What should be my approach to change the logo?
    Nishant Pandey
    @nipan09
    I am trying to change the colour of log in button in admin page, but I am not getting it. I know that I have to do something with <div class= "submit-row">. Should I create a separate css file in static/css directory?
    Also, for the page of password reset, I am not getting the input box to be placed one line below Email Address: and background color changed. I have tried to change the background color in the same way as I did for admin login page, but not getting the background color. What should be my approach?
    Nishant Pandey
    @nipan09
    @vchrombie can you explain a little bit more about the Admin part of issue #5?
    Amresh Kumar
    @amreshk005
    @aswinshenoy can I work on #9 issuse
    Ashwin Shenoy
    @aswinshenoy
    @amreshk005 sure, go ahead :)
    Amresh Kumar
    @amreshk005
    okay
    Amresh Kumar
    @amreshk005
    @aswinshenoy I have fixed the issue #9.