These are chat archives for andyet/SimpleWebRTC

28th
Dec 2017
mashakos
@mashakos
Dec 28 2017 04:49
Found something worrying: I can't get relay to work between chrome and firefox no matter what I have tried. The issue even affects https://simplewebrtc.com/demo.html
try the demo website while firefox is set to relay only
401 errors
LuckyCyborg
@LuckyCyborg
Dec 28 2017 04:50
That's usual. Chrome and Firefox usually barks to each other. ;)
mashakos
@mashakos
Dec 28 2017 04:50
hmmm
LuckyCyborg
@LuckyCyborg
Dec 28 2017 04:51
The WebRTC implementations from Chrome and Firefox are not exactly compatible. And any other browser has his own vision about this subject.
mashakos
@mashakos
Dec 28 2017 04:52
host based connection works, relay doesn't
LuckyCyborg
@LuckyCyborg
Dec 28 2017 04:53
Was a time when you cannot had a videochat between FF and Chrome. :shipit:
mashakos
@mashakos
Dec 28 2017 04:53
ouch...
do you have any experience with restund and signalmaster? I am stuck trying to get relay to work at all
LuckyCyborg
@LuckyCyborg
Dec 28 2017 04:55
What you understand by relaying? You want to build a TURN server?
There are tons of docs about this subject.
mashakos
@mashakos
Dec 28 2017 04:56
I have already set up restund and signalmaster servers, https
and my restund server works according to ICE trickle test page
but on simplewebrtc... :(
ONLY relay doesn't work mind you, signalmaster functions with host based conn.
LuckyCyborg
@LuckyCyborg
Dec 28 2017 04:58
Just setup into SWRTC your restund as TURN server.
OK, it should be put into TURN mode.
mashakos
@mashakos
Dec 28 2017 04:59
doesn't restund function as both TURN and STUN server?
LuckyCyborg
@LuckyCyborg
Dec 28 2017 04:59
yes, works as both.
BUT, you should proper configure it.
No magic included.
mashakos
@mashakos
Dec 28 2017 05:01
are you talking about config of signalmaster? That is not very complex to pin down
LuckyCyborg
@LuckyCyborg
Dec 28 2017 05:01
about restund config also
mashakos
@mashakos
Dec 28 2017 05:02
yeah config and database all set up
also relay works on ICE trickle test page
so I don't believe it's the server configuration
LuckyCyborg
@LuckyCyborg
Dec 28 2017 05:03
Usually I develop the site side over some public STUN/TURN then when everything is OK, I move to a private one.
mashakos
@mashakos
Dec 28 2017 05:04
wait
the demo site does not have TURN server does it?
I think I read that somewhere in the main page
LuckyCyborg
@LuckyCyborg
Dec 28 2017 05:04
If I remember right, nope
mashakos
@mashakos
Dec 28 2017 05:04
ok then that makes sense why it doesn't work, lol
LuckyCyborg
@LuckyCyborg
Dec 28 2017 05:05
TURN relays the streams, STUN helps the users to find each other
mashakos
@mashakos
Dec 28 2017 07:27
ok this is driving me nuts
I've been up for 48 hours trying to fix this relay thing
ICE trickle page relays successfully, restund server page shows relays over UDP
yet zero luck with simplewebrtc
mashakos
@mashakos
Dec 28 2017 07:40
relay.png
does this look right?
should permissions and channels be blank?
mashakos
@mashakos
Dec 28 2017 08:18
I keep getting auth: unknown user in restund...
mashakos
@mashakos
Dec 28 2017 09:28
figured out that I need to update restund and patch it according to: https://github.com/otalk/restund/issues/11#issuecomment-307804601
now turn relays but getting no stream...