Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Anthony Nahas
    @AnthonyNahas
    @mogo-edenpark you should add angular flex layout or use the correct version if it's already installed
    jayaprakashmani92
    @jayaprakashmani92
    and also Flag not showing. In console am getting 404 error
    add in angular.json
    {
    "glob": "*/",
    "input": "./node_modules/svg-country-flags/svg",
    "output": "./node_modules/svg-country-flags/svg"
    }
    but now showing
    Anthony Nahas
    @AnthonyNahas
    is svg-country-flag already installed
    ?
    jayaprakashmani92
    @jayaprakashmani92
    Yes I have installed npm i svg-country-flags -s
    jayaprakashmani92
    @jayaprakashmani92
    image.png
    My package.json
    jayaprakashmani92
    @jayaprakashmani92
    @AnthonyNahas Waiting for your reply
    Ephraim Khantsis
    @doom777
    @AnthonyNahas hey, just to note, we released a newer version of @agm/core. you may want to add support to it
    Anthony Nahas
    @AnthonyNahas
    @jayaprakashmani92 your configuration in angular.json is incorrect
    {
    "glob": "*/",
    "input": "./node_modules/svg-country-flags/svg",
    "output": "src/assets/svg-country-flags/svg"
    }
    please use the above code
    @doom777 what is the new version ? v3 beta ?
    John Paulo Rodriguez
    @Necromancerx
    Hello! I have a question. How can I dynamically change the value of mat-google-maps-autocomplete input? Thank you.
    José Alberto Vázquez
    @JoseAlbertoVazq
    Hey @AnthonyNahas , please check this issue, angular-material-extensions/select-country#25
    Ephraim Khantsis
    @doom777
    @AnthonyNahas correct, 3.0.0-beta.0
    Shalu Pundir
    @shalupundir_gitlab
    Hello, Guys, anyone can help me here regarding Google Map autocomplete
    I am trying to implement that for Angular 9 and Seems not working as it through an error
    Shalu Pundir
    @shalupundir_gitlab
    ERROR in The target entry-point "@angular-material-extensions/google-maps-autocomplete" has missing dependencies:
    • @angular/flex-layout
    Shalu Pundir
    @shalupundir_gitlab

    Even When I am trying to clone demo app Its seems not working for me
    Can you guys please help me out here

    import {Appearance} from '@angular-material-extensions/google-maps-autocomplete';

                               ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    9 import {MatGoogleMapsAutocompleteModule} from '@angular-material-extensions/google-maps-autocomplete';
                                                    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    ERROR in src/app/app.component.ts:2:51 - error TS2307: Cannot find module '@angular-material-extensions/google-maps-autocomplete'.

    2 import {Appearance, GermanAddress, Location} from '@angular-material-extensions/google-maps-autocomplete';
    Shalu Pundir
    @shalupundir_gitlab
    @AnthonyNahas Hi
    fzucchet
    @fzucchet
    hi @AnthonyNahas , i try to use fab menu but it not display in my html . i don't have any error or something , can you help me ?
    fzucchet
    @fzucchet
    and remove this color = "primary" because ERROR Error: Uncaught (in promise): Error: Invalid color: primary
    Shalini-2818
    @Shalini-2818
    ERROR in The target entry-point "ngx-auth-firebaseui" has missing dependencies:
    • @angular-material-extensions/password-strength
    How to overcome this error
    Anthony Nahas
    @AnthonyNahas
    @shalupundir_gitlab do you gave flex layout installed ?
    @fzucchet PLease open a related issue in github
    @shs
    @Shalini-2818 is password strength lib installed ?
    Anthony Liriano
    @anthonyliriano
    Hi is there a way to change the font-size of the search results. Looks like modifying .pac-container, .pac-item is not working for me :S
    @AnthonyNahas
    Anthony Liriano
    @anthonyliriano
    nvm, got it thank
    Anthony Nahas
    @AnthonyNahas
    @anthonyliriano PLease specify the related project ...
    Ally
    @AllySummers
    @AnthonyNahas i'm trying to use google maps autocomplete but i'm having an issue where i can't bind either the country or the component restrictions to a variable, it seems to have to be hard coded
    Anthony Nahas
    @AnthonyNahas
    [country]='de'
    this should work
    can you post a snippet of your code ?
    Brahmadev Pandey
    @BrahmadevPandey
    Hi Anthony

    for https://angular-material-extensions.github.io/link-preview/doc/index.html
    Is I can run without using this URL and access key ?
    export class MatLinkPreviewService {

    private _accessKey = '5b54e80a65c77848ceaa4630331e8384950e09d392365';
    private _apiURL = 'https://api.linkpreview.net/';

    ADarkDividedGem
    @ADarkDividedGem
    @AnthonyNahas Can I store the result of the google-maps-autocomplete into sessionStorage and then load the auto complete field on page load if the value exists in the sessionStorage?
    3 replies
    Ryan Martin
    @rmartin-sommset
    I keep hitting npm errors like this when trying to install @angular-material-extensions/google-maps-autocomplete
    npm ERR! While resolving: entity-monorepo-prototype@0.0.1
    npm ERR! Found: zone.js@0.11.3
    npm ERR! node_modules/zone.js
    npm ERR!   zone.js@"^0.11.1" from the root project
    npm ERR!   peer zone.js@"~0.11.1" from @angular-material-extensions/google-maps-autocomplete@6.0.0
    npm ERR!   node_modules/@angular-material-extensions/google-maps-autocomplete
    npm ERR!     @angular-material-extensions/google-maps-autocomplete@"*" from the root project
    npm ERR! 
    npm ERR! Could not resolve dependency:
    npm ERR! peer zone.js@"~0.10.3" from @angular/core@10.2.3
    npm ERR! node_modules/@angular/core
    npm ERR!   @angular/core@"^10.1.4" from the root project
    npm ERR!   peer @angular/core@"^9.1.0 || ^10.0.0" from @agm/core@3.0.0-beta.0
    npm ERR!   node_modules/@agm/core
    npm ERR!     peer @agm/core@"^3.0.0-beta.0" from @angular-material-extensions/google-maps-autocomplete@6.0.0
    npm ERR!     node_modules/@angular-material-extensions/google-maps-autocomplete
    npm ERR!       @angular-material-extensions/google-maps-autocomplete@"*" from the root project
    npm ERR!   1 more (@angular/common)
    npm ERR! 
    npm ERR! Fix the upstream dependency conflict, or retry
    npm ERR! this command with --force, or --legacy-peer-deps
    npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
    npm ERR! 
    npm ERR! See /Users/ryan/.npm/eresolve-report.txt for a full report.
    Any advice would be appreciated. Once I start up and downgrading packages things start getting more wonky
    Ryan Craig Martin
    @ryancraigmartin
    I was able to get it working. Does anyone know of a good way to repopulate a previously selected value and force the selection on an input with the directive?
    Ryan Craig Martin
    @ryancraigmartin
    conlont
    @conlont
    Hi has anyone managed to get bounds working with google-maps-autocomplete? or is it possible? strictBounds is an option in the API docs but not bounds..
    conlont
    @conlont
    Does anyone know if using bounds is possible within the angular-material-extensions/google-maps-autocomplete library?