These are chat archives for angular/angular-2-ionic-2

13th
Aug 2016
sachin
@sachin
Aug 13 2016 07:23

Hi All, i need help to resolve the dependencies in ionic2 app.

Initially my app package.json was
```
"@angular/common": "2.0.0-rc.2",
"@angular/compiler": "2.0.0-rc.2",
"@angular/core": "2.0.0-rc.2",
"@angular/platform-browser": "2.0.0-rc.2",
"@angular/platform-browser-dynamic": "2.0.0-rc.2",
"@angular/http": "2.0.0-rc.2",
"ionic-angular": "2.0.0-beta.8",
...

sachin
@sachin
Aug 13 2016 07:40
This message was deleted
sachin
@sachin
Aug 13 2016 07:56
Please ignore my above node that is incomplete
sorry guys
sachin
@sachin
Aug 13 2016 08:16

Hi All,

i need help to resolve the dependencies in ionic2 app.

Initially my app package.json was

  "@angular/common": "2.0.0-rc.2",
  "@angular/compiler": "2.0.0-rc.2",
  "@angular/core": "2.0.0-rc.2",
  "@angular/platform-browser": "2.0.0-rc.2",
  "@angular/platform-browser-dynamic": "2.0.0-rc.2",
  "@angular/http": "2.0.0-rc.2",
  "ionic-angular": "2.0.0-beta.8",
  .
  .
  .

I installed the Angularfire2 by following the steps on github page and it was working fine.

Problem starts when i must have to update my ionic version for other features in my application. So my pakage.json looks like

  "@angular/common": "2.0.0-rc.4",
  "@angular/compiler": "2.0.0-rc.4",
  "@angular/core": "2.0.0-rc.4",
  "@angular/platform-browser": "2.0.0-rc.4",
  "@angular/platform-browser-dynamic": "2.0.0-rc.4",
  "@angular/http": "2.0.0-rc.4",
  "@angular/forms": "0.2.0",
  "ionic-angular": "2.0.0-beta.11",
  .
  .
  .

Now the angularfire2 stop working which is fine.
now i installed the angularfire2 using the

npm install git+https://github.com/angular/angularfire2.git

angular/angularfire2#325

but by doing this the angularfire2 installed its the dependencies and output looks like
BotleServiceTab@ /drive/workspace/ionic_apps/papayaheaderlabs.bearberryMobile
-- angularfire2@2.0.0-beta.2 (git+https://github.com/angular/angularfire2.git#b38b5fdee70fd9854f47ab8073c7eb22b717a591) +-- @angular/common@ +-- @angular/compiler@2.0.0-rc.5 +-- @angular/core@2.0.0-rc.5 +-- @angular/platform-browser@2.0.0-rc.5-- @angular/platform-browser-dynamic@2.0.0-rc.5

Its installed angular 2.0.0-rc.5 this version is not supported by ionic

Its there any way i can installed angularfire2 for angular "2.0.0-rc.4"

Maek Twain
@maektwain
Aug 13 2016 19:40
hi
Alex
@zefrench
Aug 13 2016 20:07
Hi everybody
Alex
@zefrench
Aug 13 2016 22:36
..